On Thu, Mar 02, 2017 at 02:24:06PM -0500, Tejun Heo wrote: > Hello, > > On Thu, Mar 02, 2017 at 02:50:00PM +0200, Andy Shevchenko wrote: > > > I thought about that and did not do it because here we are remapping > > > resources that are _not_ PCI bus resources (ie it is not PCI BARs we > > > are remapping), keeping the devm_* prefix would be more consistent > > > to the typical device drivers remapping functions pattern (ie a > > > typical PCI host controller driver would mix devm_ and pcim_ calls > > > which is a bit hard to parse), that was my rationale. > > > > > > I am not too fussed about that either way, I am happy to update it to > > > pcim_* though, it is Bjorn/Arnd's decision. > > > > I would vote for pcim_*() variant. > > Me too, for brevity. devm_* is equally brief. Also, all existing pcim_*() functions take a struct pci_dev * as their first argument, because they operate on the PCI devices. However in this case the devm_pci_remap_*() functions do not operate on PCI devices. Rather they operate on the struct device that represents the PCI host bridge. Therefore I think devm_ is more appropriate here. Thierry