linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Josh Triplett <josh@joshtriplett.org>
To: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Cc: Peter Zijlstra <peterz@infradead.org>,
	Christian Borntraeger <borntraeger@de.ibm.com>,
	linux-kernel@vger.kernel.org, mingo@kernel.org,
	jiangshanlai@gmail.com, dipankar@in.ibm.com,
	akpm@linux-foundation.org, mathieu.desnoyers@efficios.com,
	tglx@linutronix.de, rostedt@goodmis.org, dhowells@redhat.com,
	edumazet@google.com, dvhart@linux.intel.com, fweisbec@gmail.com,
	oleg@redhat.com, bobby.prani@gmail.com, marc.zyngier@arm.com
Subject: Re: [PATCH v2 tip/core/rcu 0/13] Miscellaneous fixes for 4.12
Date: Wed, 19 Apr 2017 07:58:44 -0700	[thread overview]
Message-ID: <20170419145844.GA17080@cloud> (raw)
In-Reply-To: <20170419144730.GA20845@linux.vnet.ibm.com>

On Wed, Apr 19, 2017 at 07:47:30AM -0700, Paul E. McKenney wrote:
> On Wed, Apr 19, 2017 at 02:08:47PM +0200, Peter Zijlstra wrote:
> > On Wed, Apr 19, 2017 at 01:48:08PM +0200, Christian Borntraeger wrote:
> > > On 04/19/2017 01:28 PM, Peter Zijlstra wrote:
> > > > 
> > > > So the thing Maz complained about is because KVM assumes
> > > > synchronize_srcu() is 'free' when there is no srcu_read_lock() activity.
> > > > This series 'breaks' that.
> > > 
> > > Why is such a behaviour change not mentioned in the cover letter?
> > > I could not find anything in the patch descriptions that would
> > > indicate a slowdown. How much slower did it get?
> > > 
> > > But indeed, there are several places at KVM startup which have been
> > > reworked to srcu since normal rcu was too slow for several usecases.
> > > (Mostly registering devices and related data structures at startup,
> > > basically the qemu/kvm coldplug interaction)
> > 
> > I suspect Paul is not considering this a 'normal' RCU feature, and
> > therefore didn't think about changing this.
> > 
> > I know I was fairly surprised by this requirement when I ran into it;
> > and only accidentally remembered it now that maz complained.
> 
> Indeed -- the natural thing to have done back when KVM's scalability was
> first being worked on would have been to simply change synchronize_rcu()
> to synchronize_rcu_expedited().  However, at that time, these things
> did try_stop_cpus() and the like, which was really bad for latency.
> Moving to SRCU avoided this problem.  Of course, now that KVM uses
> SRCU, why change unless there is a problem?  Besides, I vaguely recall
> some KVM cases where srcu_read_lock() is used from CPUs that look to
> be idle or offline from RCU's perspective, and that sort of thing only
> works for SRCU.
> 
> Which reminds me...
> 
> The RCU expedited primitives have been completely rewritten since then,
> and no longer use try_stop_cpus(), no longer disturb idle CPUs, and no
> longer disturb nohz_full CPUs running in userspace.  In addition, there
> is the rcupdate.rcu_normal kernel boot paramter for those who want to
> completely avoid RCU expedited primitives.
> 
> So it seems to me to be time for the patch below.  Thoughts?
> 
> 							Thanx, Paul
> 
> ------------------------------------------------------------------------
> 
> commit 333d383fad42b4bdef3d27d91e940a6eafed3f91
> Author: Paul E. McKenney <paulmck@linux.vnet.ibm.com>
> Date:   Wed Apr 19 07:37:45 2017 -0700
> 
>     checkpatch: Remove checks for expedited grace periods
>     
>     There was a time when the expedited grace-period primitives
>     (synchronize_rcu_expedited(), synchronize_rcu_bh_expedited(), and
>     synchronize_sched_expedited()) used rather antisocial kernel
>     facilities like try_stop_cpus().  However, they have since been
>     housebroken to use only single-CPU IPIs, and typically cause less
>     disturbance than a scheduling-clock interrupt.  Furthermore, this
>     disturbance can be eliminated entirely using NO_HZ_FULL on the
>     one hand or the rcupdate.rcu_normal boot parameter on the other.
>     
>     This commit therefore removes checkpatch's complaints about use
>     of the expedited RCU primitives.
>     
>     Signed-off-by: Paul E. McKenney <paulmck@linux.vnet.ibm.com>

Reviewed-by: Josh Triplett <josh@joshtriplett.org>

Still something to hesitate a bit before using, but not something
checkpatch should warn about.

  parent reply	other threads:[~2017-04-19 14:59 UTC|newest]

Thread overview: 106+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-04-12 16:54 [PATCH tip/core/rcu 0/13] Miscellaneous fixes for 4.12 Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 01/13] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Paul E. McKenney
2017-04-13  9:12   ` Peter Zijlstra
2017-04-13 11:06     ` Vlastimil Babka
2017-04-13 16:00       ` Paul E. McKenney
2017-04-13 16:17       ` Peter Zijlstra
2017-04-13 17:24         ` Paul E. McKenney
2017-04-13 21:30         ` Eric Dumazet
2017-04-14  8:45           ` Peter Zijlstra
2017-04-14 13:39             ` Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 02/13] lockdep: Use "WARNING" tag on lockdep splats Paul E. McKenney
2017-04-13  9:14   ` Peter Zijlstra
2017-04-13 16:01     ` Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 03/13] types: Update obsolete callback_head comment Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 04/13] rcu: Make RCU_FANOUT_LEAF help text more explicit about skew_tick Paul E. McKenney
2017-04-13  9:15   ` Peter Zijlstra
2017-04-13 16:03     ` Paul E. McKenney
2017-04-13 16:19       ` Peter Zijlstra
2017-04-13 16:55         ` Paul E. McKenney
2017-04-13 17:04           ` Peter Zijlstra
2017-04-13 17:31             ` Paul E. McKenney
2017-04-13 17:46               ` Peter Zijlstra
2017-04-13 18:19                 ` Paul E. McKenney
2017-04-13 18:23                   ` Peter Zijlstra
2017-04-13 18:42                     ` Paul E. McKenney
2017-04-19 13:22                       ` Peter Zijlstra
2017-04-19 13:48                         ` Peter Zijlstra
2017-04-19 15:08                           ` Paul E. McKenney
2017-04-19 15:40                             ` Peter Zijlstra
2017-04-19 16:13                               ` Paul E. McKenney
2017-04-19 14:50                         ` Paul E. McKenney
2017-04-13 18:29               ` Peter Zijlstra
2017-04-13 19:42                 ` Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 05/13] rcu: Remove obsolete comment from rcu_future_gp_cleanup() header Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 06/13] hlist_add_tail_rcu disable sparse warning Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 07/13] rcu: Add smp_mb__after_atomic() to sync_exp_work_done() Paul E. McKenney
2017-04-13  9:18   ` Peter Zijlstra
2017-04-13  9:33     ` Peter Zijlstra
2017-04-13 16:10     ` Paul E. McKenney
2017-04-13 16:24       ` Peter Zijlstra
2017-04-13 16:57         ` Paul E. McKenney
2017-04-13 17:10           ` Peter Zijlstra
2017-04-13 17:39             ` Paul E. McKenney
2017-04-13 17:51               ` Peter Zijlstra
2017-04-13 17:59                 ` Peter Zijlstra
2017-04-19 23:24                   ` Paul E. McKenney
2017-04-19 23:23                 ` Paul E. McKenney
2017-04-20 11:17                   ` Peter Zijlstra
2017-04-20 15:03                     ` Paul E. McKenney
2017-04-20 15:08                       ` Peter Zijlstra
2017-06-09 22:56                         ` Paul E. McKenney
2017-06-12 14:51                           ` Dmitry Vyukov
2017-06-12 21:54                             ` Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 08/13] rcu: Improve comments for hotplug/suspend/hibernate functions Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 09/13] mm: Use static initialization for "srcu" Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 10/13] torture: Use correct path for Kconfig fragment for duplicates Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 11/13] rcu: Use bool value directly Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 12/13] rcu: Use true/false in assignment to bool Paul E. McKenney
2017-04-12 16:55 ` [PATCH tip/core/rcu 13/13] rcu: Fix typo in PER_RCU_NODE_PERIOD header comment Paul E. McKenney
2017-04-17 23:27 ` [PATCH v2 tip/core/rcu 0/13] Miscellaneous fixes for 4.12 Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 01/11] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Paul E. McKenney
2017-04-18  0:14     ` David Rientjes
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 02/11] lockdep: Use "WARNING" tag on lockdep splats Paul E. McKenney
2017-04-19 15:00     ` Josh Triplett
2017-04-19 16:26       ` Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 03/11] types: Update obsolete callback_head comment Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 04/11] rcu: Make RCU_FANOUT_LEAF help text more explicit about skew_tick Paul E. McKenney
2017-04-18  0:18     ` Josh Triplett
2017-04-18 18:42       ` Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 05/11] rcu: Remove obsolete comment from rcu_future_gp_cleanup() header Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 06/11] hlist_add_tail_rcu disable sparse warning Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 07/11] rcu: Improve comments for hotplug/suspend/hibernate functions Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 08/11] torture: Use correct path for Kconfig fragment for duplicates Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 09/11] rcu: Use bool value directly Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 10/11] rcu: Use true/false in assignment to bool Paul E. McKenney
2017-04-17 23:28   ` [PATCH v2 tip/core/rcu 11/11] rcu: Fix typo in PER_RCU_NODE_PERIOD header comment Paul E. McKenney
2017-04-19 11:28   ` [PATCH v2 tip/core/rcu 0/13] Miscellaneous fixes for 4.12 Peter Zijlstra
2017-04-19 11:35     ` Peter Zijlstra
2017-04-19 11:48     ` Christian Borntraeger
2017-04-19 12:08       ` Peter Zijlstra
2017-04-19 12:51         ` Marc Zyngier
2017-04-19 14:47         ` Paul E. McKenney
2017-04-19 14:52           ` Peter Zijlstra
2017-04-19 15:13             ` Paul E. McKenney
2017-04-19 14:58           ` Josh Triplett [this message]
2017-04-19 15:03             ` Peter Zijlstra
2017-04-19 15:17               ` Paul E. McKenney
2017-04-19 13:22       ` Paul E. McKenney
2017-04-19 13:25         ` Christian Borntraeger
2017-04-19 13:02     ` Paul E. McKenney
2017-04-19 13:15       ` Peter Zijlstra
2017-04-19 15:37         ` Paul E. McKenney
2017-04-19 15:43           ` Peter Zijlstra
2017-04-19 16:12             ` Paul E. McKenney
2017-04-19 16:45   ` Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 01/11] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 02/11] lockdep: Use "WARNING" tag on lockdep splats Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 03/11] types: Update obsolete callback_head comment Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 04/11] rcu: Make RCU_FANOUT_LEAF help text more explicit about skew_tick Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 05/11] rcu: Remove obsolete comment from rcu_future_gp_cleanup() header Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 06/11] hlist_add_tail_rcu disable sparse warning Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 07/11] rcu: Improve comments for hotplug/suspend/hibernate functions Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 08/11] torture: Use correct path for Kconfig fragment for duplicates Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 09/11] rcu: Use bool value directly Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 10/11] rcu: Use true/false in assignment to bool Paul E. McKenney
2017-04-19 16:46     ` [PATCH v3 tip/core/rcu 11/11] rcu: Fix typo in PER_RCU_NODE_PERIOD header comment Paul E. McKenney

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170419145844.GA17080@cloud \
    --to=josh@joshtriplett.org \
    --cc=akpm@linux-foundation.org \
    --cc=bobby.prani@gmail.com \
    --cc=borntraeger@de.ibm.com \
    --cc=dhowells@redhat.com \
    --cc=dipankar@in.ibm.com \
    --cc=dvhart@linux.intel.com \
    --cc=edumazet@google.com \
    --cc=fweisbec@gmail.com \
    --cc=jiangshanlai@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marc.zyngier@arm.com \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=mingo@kernel.org \
    --cc=oleg@redhat.com \
    --cc=paulmck@linux.vnet.ibm.com \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).