linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Andrew Lunn <andrew@lunn.ch>
To: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
Cc: netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
	kernel@savoirfairelinux.com,
	"David S. Miller" <davem@davemloft.net>,
	Florian Fainelli <f.fainelli@gmail.com>
Subject: Re: [PATCH net-next 03/18] net: dsa: mv88e6xxx: move VTU Operation accessors
Date: Thu, 27 Apr 2017 20:32:49 +0200	[thread overview]
Message-ID: <20170427183249.GE17364@lunn.ch> (raw)
In-Reply-To: <20170426155336.5937-4-vivien.didelot@savoirfairelinux.com>

On Wed, Apr 26, 2017 at 11:53:21AM -0400, Vivien Didelot wrote:
> Move the helper functions to access the Global 1 VTU Operation register
> to a new global1_vtu.c file, and get rid of the old underscore prefix
> naming convention. This file will be extended will all VTU/STU related
> code.
> 
> Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
> ---
>  drivers/net/dsa/mv88e6xxx/Makefile      |  1 +
>  drivers/net/dsa/mv88e6xxx/chip.c        | 39 +++++++++------------------------
>  drivers/net/dsa/mv88e6xxx/global1.h     |  3 +++
>  drivers/net/dsa/mv88e6xxx/global1_vtu.c | 33 ++++++++++++++++++++++++++++
>  4 files changed, 47 insertions(+), 29 deletions(-)
>  create mode 100644 drivers/net/dsa/mv88e6xxx/global1_vtu.c
> 
> diff --git a/drivers/net/dsa/mv88e6xxx/Makefile b/drivers/net/dsa/mv88e6xxx/Makefile
> index 31d37a90cec7..6edd869c8d6f 100644
> --- a/drivers/net/dsa/mv88e6xxx/Makefile
> +++ b/drivers/net/dsa/mv88e6xxx/Makefile
> @@ -2,5 +2,6 @@ obj-$(CONFIG_NET_DSA_MV88E6XXX) += mv88e6xxx.o
>  mv88e6xxx-objs := chip.o
>  mv88e6xxx-objs += global1.o
>  mv88e6xxx-objs += global1_atu.o
> +mv88e6xxx-objs += global1_vtu.o
>  mv88e6xxx-$(CONFIG_NET_DSA_MV88E6XXX_GLOBAL2) += global2.o
>  mv88e6xxx-objs += port.o
> diff --git a/drivers/net/dsa/mv88e6xxx/chip.c b/drivers/net/dsa/mv88e6xxx/chip.c
> index f025d3c22dba..bf0350432337 100644
> --- a/drivers/net/dsa/mv88e6xxx/chip.c
> +++ b/drivers/net/dsa/mv88e6xxx/chip.c
> @@ -3,9 +3,6 @@
>   *
>   * Copyright (c) 2008 Marvell Semiconductor
>   *
> - * Copyright (c) 2015 CMC Electronics, Inc.
> - *	Added support for VLAN Table Unit operations
> - *
>   * Copyright (c) 2016 Andrew Lunn <andrew@lunn.ch>
>   *
>   * Copyright (c) 2016-2017 Savoir-faire Linux Inc.
> @@ -1266,31 +1263,15 @@ static void mv88e6xxx_port_fast_age(struct dsa_switch *ds, int port)
>  		netdev_err(ds->ports[port].netdev, "failed to flush ATU\n");
>  }
>  
> -static int _mv88e6xxx_vtu_wait(struct mv88e6xxx_chip *chip)
> -{
> -	return mv88e6xxx_g1_wait(chip, GLOBAL_VTU_OP, GLOBAL_VTU_OP_BUSY);
> -}
> -
> -static int _mv88e6xxx_vtu_cmd(struct mv88e6xxx_chip *chip, u16 op)
> -{
> -	int err;
> -
> -	err = mv88e6xxx_g1_write(chip, GLOBAL_VTU_OP, op);
> -	if (err)
> -		return err;
> -
> -	return _mv88e6xxx_vtu_wait(chip);
> -}
> -
>  static int _mv88e6xxx_vtu_stu_flush(struct mv88e6xxx_chip *chip)
>  {
>  	int ret;
>  
> -	ret = _mv88e6xxx_vtu_wait(chip);
> +	ret = mv88e6xxx_g1_vtu_op_wait(chip);
>  	if (ret < 0)
>  		return ret;
>  
> -	return _mv88e6xxx_vtu_cmd(chip, GLOBAL_VTU_OP_FLUSH_ALL);
> +	return mv88e6xxx_g1_vtu_op(chip, GLOBAL_VTU_OP_FLUSH_ALL);
>  }
>  
>  static int _mv88e6xxx_vtu_stu_data_read(struct mv88e6xxx_chip *chip,
> @@ -1380,11 +1361,11 @@ static int _mv88e6xxx_vtu_getnext(struct mv88e6xxx_chip *chip,
>  	u16 val;
>  	int err;
>  
> -	err = _mv88e6xxx_vtu_wait(chip);
> +	err = mv88e6xxx_g1_vtu_op_wait(chip);
>  	if (err)
>  		return err;
>  
> -	err = _mv88e6xxx_vtu_cmd(chip, GLOBAL_VTU_OP_VTU_GET_NEXT);
> +	err = mv88e6xxx_g1_vtu_op(chip, GLOBAL_VTU_OP_VTU_GET_NEXT);
>  	if (err)
>  		return err;

Hi Vivien

This patch got me for a while. It initially looks like a bad idea. It
is not until you read all the patches, you can see why it is actually
good. It is a simple mechanical translation, which is easy to
review. But it seemed odd to be using these names in chip.c. But later
patches solve that, by moving the code in global1_vtu.c.

	Andrew

  reply	other threads:[~2017-04-27 18:33 UTC|newest]

Thread overview: 48+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-04-26 15:53 [PATCH net-next 00/18] net: dsa: mv88e6xxx: 802.1s and 88E6390 VTU Vivien Didelot
2017-04-26 15:53 ` [PATCH net-next 01/18] net: dsa: mv88e6xxx: add max VID to info Vivien Didelot
2017-04-26 16:04   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 02/18] net: dsa: mv88e6xxx: split VTU entry data member Vivien Didelot
2017-04-27 18:25   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 03/18] net: dsa: mv88e6xxx: move VTU Operation accessors Vivien Didelot
2017-04-27 18:32   ` Andrew Lunn [this message]
2017-04-27 18:33   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 04/18] net: dsa: mv88e6xxx: move VTU flush Vivien Didelot
2017-04-27 18:34   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 05/18] net: dsa: mv88e6xxx: move VTU FID accessors Vivien Didelot
2017-04-27 18:35   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 06/18] net: dsa: mv88e6xxx: move VTU SID accessors Vivien Didelot
2017-04-27 18:37   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 07/18] net: dsa: mv88e6xxx: move VTU VID accessors Vivien Didelot
2017-04-27 18:51   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 08/18] net: dsa: mv88e6xxx: move generic VTU GetNext Vivien Didelot
2017-04-27 18:59   ` Andrew Lunn
2017-04-28 15:07     ` Vivien Didelot
2017-04-26 15:53 ` [PATCH net-next 09/18] net: dsa: mv88e6xxx: move VTU Data accessors Vivien Didelot
2017-04-27 19:19   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 10/18] net: dsa: mv88e6xxx: move STU GetNext operation Vivien Didelot
2017-04-27 19:43   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 11/18] net: dsa: mv88e6xxx: get STU entry on VTU GetNext Vivien Didelot
2017-04-27 20:17   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 12/18] net: dsa: mv88e6xxx: load STU entry with VTU entry Vivien Didelot
2017-04-28  2:07   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 13/18] net: dsa: mv88e6xxx: add VTU GetNext operation Vivien Didelot
2017-04-28  2:10   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 14/18] net: dsa: mv88e6xxx: add VTU Load/Purge operation Vivien Didelot
2017-04-28  2:14   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 15/18] net: dsa: mv88e6xxx: make VTU helpers static Vivien Didelot
2017-04-28  2:15   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 16/18] net: dsa: mv88e6xxx: simplify VTU entry getter Vivien Didelot
2017-04-28  2:19   ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 17/18] net: dsa: mv88e6xxx: support the VTU Page bit Vivien Didelot
2017-04-28 12:53   ` Andrew Lunn
2017-04-28 14:25     ` Vivien Didelot
2017-04-28 14:52       ` Andrew Lunn
2017-04-26 15:53 ` [PATCH net-next 18/18] net: dsa: mv88e6xxx: add VTU support for 88E6390 Vivien Didelot
2017-04-28 12:55   ` Andrew Lunn
2017-05-01 15:51 ` [PATCH net-next 00/18] net: dsa: mv88e6xxx: 802.1s and 88E6390 VTU Vivien Didelot
2017-05-01 16:08   ` David Miller
2017-05-01 16:21     ` Vivien Didelot
2017-05-01 16:25       ` Andrew Lunn
2017-05-01 17:16         ` Vivien Didelot
2017-05-01 16:26       ` David Miller
2017-05-01 16:36         ` Vivien Didelot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170427183249.GE17364@lunn.ch \
    --to=andrew@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=f.fainelli@gmail.com \
    --cc=kernel@savoirfairelinux.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=vivien.didelot@savoirfairelinux.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).