From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752912AbdFVIZI (ORCPT ); Thu, 22 Jun 2017 04:25:08 -0400 Received: from mail-wr0-f196.google.com ([209.85.128.196]:32908 "EHLO mail-wr0-f196.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752859AbdFVIZF (ORCPT ); Thu, 22 Jun 2017 04:25:05 -0400 Date: Thu, 22 Jun 2017 10:25:01 +0200 From: Ingo Molnar To: Dmitry Vyukov Cc: Mark Rutland , Peter Zijlstra , Ingo Molnar , Will Deacon , "H. Peter Anvin" , Andrey Ryabinin , kasan-dev , "x86@kernel.org" , LKML , Thomas Gleixner , Andrew Morton , "linux-mm@kvack.org" , Linus Torvalds Subject: Re: [PATCH v4 5/7] kasan: allow kasan_check_read/write() to accept pointers to volatiles Message-ID: <20170622082501.5q66ucborgxdxqzg@gmail.com> References: <20170619105008.GD10246@leverpostej> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: NeoMutt/20170113 (1.7.2) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Dmitry Vyukov wrote: > On Mon, Jun 19, 2017 at 12:50 PM, Mark Rutland wrote: > > On Sat, Jun 17, 2017 at 11:15:31AM +0200, Dmitry Vyukov wrote: > >> Currently kasan_check_read/write() accept 'const void*', make them > >> accept 'const volatile void*'. This is required for instrumentation > >> of atomic operations and there is just no reason to not allow that. > >> > >> Signed-off-by: Dmitry Vyukov > >> Cc: Mark Rutland > >> Cc: Andrey Ryabinin > >> Cc: Thomas Gleixner > >> Cc: "H. Peter Anvin" > >> Cc: Peter Zijlstra > >> Cc: Andrew Morton > >> Cc: linux-kernel@vger.kernel.org > >> Cc: x86@kernel.org > >> Cc: linux-mm@kvack.org > >> Cc: kasan-dev@googlegroups.com > > > > Looks sane to me, and I can confirm this doesn't advervsely affect > > arm64. FWIW: > > > > Acked-by: Mark Rutland > > > > Mark. > > > Great! Thanks for testing. > > Ingo, what are your thoughts? Are you taking this to locking tree? When? Yeah, it all looks pretty clean to me too. I've applied the first three patches to the locking tree, but did some minor stylistic cleanups to the first patch to harmonize the style of the code - which made the later patches not apply cleanly. Mind sending the remaining patches against the locking tree, tip:locking/core? (Please also add in all the acks you got.) This should also give people (Peter, Linus?) a last minute chance to object to my suggestion of increasing the linecount in patch #1: 0f2376eb0ff8: locking/atomic/x86: Un-macro-ify atomic ops implementation arch/x86/include/asm/atomic.h | 69 ++++++++++++++++++++++++++++++++++++++++++++++----------------------- arch/x86/include/asm/atomic64_32.h | 81 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++------------------------ arch/x86/include/asm/atomic64_64.h | 67 ++++++++++++++++++++++++++++++++++++++++++++----------------------- 3 files changed, 147 insertions(+), 70 deletions(-) ... to me the end result looks much more readable despite the +70 lines of code, but if anyone feels strongly about this please holler! Thanks, Ingo