From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751776AbdF1RTH (ORCPT ); Wed, 28 Jun 2017 13:19:07 -0400 Received: from mail-lf0-f68.google.com ([209.85.215.68]:35856 "EHLO mail-lf0-f68.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751511AbdF1RS6 (ORCPT ); Wed, 28 Jun 2017 13:18:58 -0400 Date: Wed, 28 Jun 2017 20:18:54 +0300 From: Vladimir Davydov To: Sahitya Tummala Cc: Alexander Polakov , Andrew Morton , Jan Kara , viro@zeniv.linux.org.uk, linux-mm@kvack.org, linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org Subject: Re: [PATCH v3 1/2] mm/list_lru.c: fix list_lru_count_node() to be race free Message-ID: <20170628171854.t4sjyjv55j673qzv@esperanza> References: <20170622174929.GB3273@esperanza> <1498630044-26724-1-git-send-email-stummala@codeaurora.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1498630044-26724-1-git-send-email-stummala@codeaurora.org> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Jun 28, 2017 at 11:37:23AM +0530, Sahitya Tummala wrote: > list_lru_count_node() iterates over all memcgs to get > the total number of entries on the node but it can race with > memcg_drain_all_list_lrus(), which migrates the entries from > a dead cgroup to another. This can return incorrect number of > entries from list_lru_count_node(). > > Fix this by keeping track of entries per node and simply return > it in list_lru_count_node(). > > Signed-off-by: Sahitya Tummala > --- > include/linux/list_lru.h | 1 + > mm/list_lru.c | 14 ++++++-------- > 2 files changed, 7 insertions(+), 8 deletions(-) > > diff --git a/include/linux/list_lru.h b/include/linux/list_lru.h > index cb0ba9f..eff61bc 100644 > --- a/include/linux/list_lru.h > +++ b/include/linux/list_lru.h > @@ -44,6 +44,7 @@ struct list_lru_node { > /* for cgroup aware lrus points to per cgroup lists, otherwise NULL */ > struct list_lru_memcg *memcg_lrus; > #endif > + long nr_count; 'nr_count' sounds awkward. I think it should be called 'nr_items'. Other than that, looks good to me.