From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752320AbeDIHGR (ORCPT ); Mon, 9 Apr 2018 03:06:17 -0400 Received: from mail-wm0-f67.google.com ([74.125.82.67]:37863 "EHLO mail-wm0-f67.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751458AbeDIHGP (ORCPT ); Mon, 9 Apr 2018 03:06:15 -0400 X-Google-Smtp-Source: AIpwx4+dbNiLQQvOf4Z0czOVu7TF3MwCDXscxLwJxPWpCLGwSacaTFcVW9vjvk75RFzpWVaUdHZWJg== Date: Mon, 9 Apr 2018 09:06:11 +0200 From: Ingo Molnar To: Dominik Brodowski Cc: linux-kernel@vger.kernel.org, Al Viro , Andi Kleen , Andrew Morton , Andy Lutomirski , Brian Gerst , Denys Vlasenko , "H. Peter Anvin" , Ingo Molnar , Linus Torvalds , Peter Zijlstra , Thomas Gleixner , x86@kernel.org, Maninder Singh , Arnd Bergmann , linux-arch Subject: Re: [PATCH 0/3] syscalls: clean up stub naming convention Message-ID: <20180409070611.43iq66eay2ctwv2m@gmail.com> References: <20180407074651.29014-1-linux@dominikbrodowski.net> <20180408083550.32d65b6ra6yca5p7@gmail.com> <20180408091536.GA10120@light.dominikbrodowski.net> <20180409064511.ejhfqcurtlq2srq5@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20180409064511.ejhfqcurtlq2srq5@gmail.com> User-Agent: NeoMutt/20170609 (1.8.3) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Ingo Molnar wrote: > > * Dominik Brodowski wrote: > > > On Sun, Apr 08, 2018 at 10:35:50AM +0200, Ingo Molnar wrote: > > > - _____sys_waitid() # ridiculous number of underscores? > > > - __sys_waitid() # too generic sounding? > > > > ... and we'd need to rename internal helpers in net/ > > > > > - __inline_sys_waitid() # too long? > > > > sounds acceptable, though a bit long (especially for the compat case, though > > it doesn't really matter in the case of > > __inline_compat_sys_sched_rr_get_interval) > > So as per the previous mail this is not just an inline function, but an active > type conversion wrapper that sign-extends 32-bit ints to longs, which is important > on some 64-bit architectures. > > And that's a really non-obvious property IMO, and the name should probably reflect > _that_ non-obvious property, not the inlining property which is really just a > small detail. > > I.e. how about: > > __se_sys_waitid() > > ... where 'se' stands for sign-extended, with a comment in the macro that explains > the prefix? (The historical abbreviation for sign extension is 'sext', which I > think wouldn't really be suitable these days.) Ok, so I got confused there: I think it's the do_sys_waitid() intermediate that is actually doing the sign-extension - and the inlined helper is what is in the syscall definition body. So it's all still somewhat of a confusing misnomer: the 'do' named function is actually the sign-extension function variant - and the '_il' variant actually 'does' the real work ... I.e., old naming: 810f08d0 t kernel_waitid # common C function (see kernel/exit.c) __il_sys_waitid # inlined helper doing the actual work # (takes parameters as declared) 810f1aa0 T __do_sys_waitid # C function calling inlined helper # (takes parameters of type long; casts # them to the declared type) 810f1aa0 T sys_waitid # alias to __do_sys_waitid() (taking # parameters as declared), to be included # in syscall table New suggested naming: 810f08d0 t kernel_waitid # common C function (see kernel/exit.c) __do_sys_waitid # inlined helper doing the actual work # (takes original parameters as declared) 810f1aa0 T __se_sys_waitid # sign-extending C function calling inlined # helper (takes parameters of type long; # casts them to the declared type) 810f1aa0 T sys_waitid # alias to __se_sys_waitid() (but taking # original parameters as declared), to be # included in syscall table Agreed? Thanks, Ingo