linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: Peter Rosin <peda@axentia.se>
Cc: linux-kernel@vger.kernel.org,
	Martyn Welch <martyn.welch@collabora.co.uk>,
	David Airlie <airlied@linux.ie>,
	dri-devel@lists.freedesktop.org,
	Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
	linux-samsung-soc@vger.kernel.org,
	Kyungmin Park <kyungmin.park@samsung.com>,
	Krzysztof Kozlowski <krzk@kernel.org>,
	Kukjin Kim <kgene@kernel.org>,
	Peter Senna Tschudin <peter.senna@collabora.com>,
	Martin Donnelly <martin.donnelly@ge.com>,
	linux-arm-msm@vger.kernel.org, Jyri Sarha <jsarha@ti.com>,
	Matthias Brugger <matthias.bgg@gmail.com>,
	Vincent Abriou <vincent.abriou@st.com>,
	linux-arm-kernel@lists.infradead.org,
	Seung-Woo Kim <sw0312.kim@samsung.com>,
	linux-renesas-soc@vger.kernel.org,
	linux-mediatek@lists.infradead.org,
	freedreno@lists.freedesktop.org
Subject: Re: [PATCH 23/24] drm/bridge: require the .owner to be filled in on drm_bridge_attach
Date: Mon, 30 Apr 2018 17:24:38 +0200	[thread overview]
Message-ID: <20180430152438.GO12521@phenom.ffwll.local> (raw)
In-Reply-To: <20180426223139.16740-24-peda@axentia.se>

On Fri, Apr 27, 2018 at 12:31:38AM +0200, Peter Rosin wrote:
> The .owner will be handy to have around.
> 
> Signed-off-by: Peter Rosin <peda@axentia.se>
> ---
>  drivers/gpu/drm/drm_bridge.c | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/drivers/gpu/drm/drm_bridge.c b/drivers/gpu/drm/drm_bridge.c
> index 9f023bd84d56..a038da696802 100644
> --- a/drivers/gpu/drm/drm_bridge.c
> +++ b/drivers/gpu/drm/drm_bridge.c
> @@ -115,6 +115,9 @@ int drm_bridge_attach(struct drm_encoder *encoder, struct drm_bridge *bridge,
>  	if (!encoder || !bridge)
>  		return -EINVAL;
>  
> +	if (WARN_ON(!bridge->owner))
> +		return -EINVAL;

I think conceptually this is checked at the wrong place, and I think also misnamed
a bit. The ->owner is essentially the struct device (and its associated
driver) that provides the drm_bridge. As such it should be filled out
already at drm_bridge_add() time, and I think the check should be in
there. For driver-internal bridges it might make sense to also check this
here, not sure. Or just require all bridges get added.

Wrt the name, I think we should call this pdev or something. ->owner
usually means the module owner. I think in other subsystems ->dev is used,
but in drm we use ->dev for the drm_device pointer, so totally different
thing. pdev = physical device is the best I came up with. Better
suggestions very much welcome.
-Daniel

> +
>  	if (previous && (!previous->dev || previous->encoder != encoder))
>  		return -EINVAL;
>  
> -- 
> 2.11.0
> 
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch

  reply	other threads:[~2018-04-30 15:24 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CGME20180426223215epcas2p38fe3b0b7b1ea1c8190805f9e2a89e11e@epcas2p3.samsung.com>
2018-04-26 22:31 ` [PATCH 00/24] device link, bridge supplier <-> drm device Peter Rosin
2018-04-26 22:31   ` [PATCH 01/24] drm/bridge: allow optionally specifying an .owner device Peter Rosin
2018-04-26 22:31   ` [PATCH 02/24] drm/bridge: adv7511: provide " Peter Rosin
2018-04-26 22:31   ` [PATCH 03/24] drm/bridge/analogix: core: specify the .owner of the bridge Peter Rosin
2018-04-26 22:31   ` [PATCH 04/24] drm/bridge: analogix-anx78xx: provide an .owner device Peter Rosin
2018-04-26 22:31   ` [PATCH 05/24] drm/bridge: vga-dac: " Peter Rosin
2018-04-26 22:31   ` [PATCH 06/24] drm/bridge: lvds-encoder: " Peter Rosin
2018-04-26 22:31   ` [PATCH 07/24] drm/bridge: megachips-stdpxxxx-ge-b850v3-fw: " Peter Rosin
2018-04-26 22:31   ` [PATCH 08/24] drm/bridge: nxp-ptn3460: " Peter Rosin
2018-04-26 22:31   ` [PATCH 09/24] drm/bridge: panel: " Peter Rosin
2018-04-26 22:31   ` [PATCH 10/24] drm/bridge: ps8622: " Peter Rosin
2018-04-26 22:31   ` [PATCH 11/24] drm/bridge: sii902x: " Peter Rosin
2018-04-26 22:31   ` [PATCH 12/24] drm/bridge: sii9234: " Peter Rosin
2018-04-26 22:31   ` [PATCH 13/24] drm/bridge: sii8620: " Peter Rosin
2018-04-26 22:31   ` [PATCH 14/24] drm/bridge: synopsys: provide an .owner device for the bridges Peter Rosin
2018-04-26 22:31   ` [PATCH 15/24] drm/bridge: tc358767: provide an .owner device Peter Rosin
2018-04-26 22:31   ` [PATCH 16/24] drm/bridge: ti-tfp410: " Peter Rosin
2018-04-26 22:31   ` [PATCH 17/24] drm/exynos: mic: provide an .owner device for the bridge Peter Rosin
2018-04-26 22:31   ` [PATCH 18/24] drm/mediatek: hdmi: " Peter Rosin
2018-04-26 22:31   ` [PATCH 19/24] drm/msm: specify the .owner of the bridges Peter Rosin
2018-04-26 22:31   ` [PATCH 20/24] drm/rcar-du: lvds: provide an .owner device for the bridge Peter Rosin
2018-04-26 22:31   ` [PATCH 21/24] drm/sti: provide an .owner device for the bridges Peter Rosin
2018-04-26 22:31   ` [PATCH 22/24] drm/bridge: remove the .of_node member Peter Rosin
2018-04-28  8:09     ` kbuild test robot
2018-04-30 11:14       ` Peter Rosin
2018-04-26 22:31   ` [PATCH 23/24] drm/bridge: require the .owner to be filled in on drm_bridge_attach Peter Rosin
2018-04-30 15:24     ` Daniel Vetter [this message]
2018-04-30 20:32       ` Peter Rosin
2018-04-26 22:31   ` [PATCH 24/24] drm/bridge: establish a link between the bridge supplier and consumer Peter Rosin
2018-04-30 15:32     ` Daniel Vetter
2018-04-30 21:12       ` Peter Rosin
     [not found]   ` <1881012.XPHlTWYXH6@avalon>
2018-04-26 23:09     ` [PATCH 00/24] device link, bridge supplier <-> drm device Peter Rosin
     [not found]       ` <3483427.EaMxDYJt8U@avalon>
2018-04-27  7:27         ` Peter Rosin
2018-04-30 15:18     ` Daniel Vetter
2018-04-27  7:11   ` Andrzej Hajda
2018-04-27  7:37     ` Peter Rosin
2018-04-27  7:51       ` Peter Rosin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180430152438.GO12521@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=Laurent.pinchart@ideasonboard.com \
    --cc=airlied@linux.ie \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=freedreno@lists.freedesktop.org \
    --cc=jsarha@ti.com \
    --cc=kgene@kernel.org \
    --cc=krzk@kernel.org \
    --cc=kyungmin.park@samsung.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=linux-samsung-soc@vger.kernel.org \
    --cc=martin.donnelly@ge.com \
    --cc=martyn.welch@collabora.co.uk \
    --cc=matthias.bgg@gmail.com \
    --cc=peda@axentia.se \
    --cc=peter.senna@collabora.com \
    --cc=sw0312.kim@samsung.com \
    --cc=vincent.abriou@st.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).