linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] ath10k: use crash_dump enum instead of magic numbers
@ 2018-06-11 18:19 Brian Norris
  2018-06-14 15:13 ` Kalle Valo
  0 siblings, 1 reply; 2+ messages in thread
From: Brian Norris @ 2018-06-11 18:19 UTC (permalink / raw)
  To: Kalle Valo; +Cc: ath10k, linux-wireless, linux-kernel, Brian Norris

The comments are telling you what the enum could tell you instead.

Signed-off-by: Brian Norris <briannorris@chromium.org>
---
 drivers/net/wireless/ath/ath10k/core.c | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/drivers/net/wireless/ath/ath10k/core.c b/drivers/net/wireless/ath/ath10k/core.c
index 4cf54a7ef09a..eae46a04f503 100644
--- a/drivers/net/wireless/ath/ath10k/core.c
+++ b/drivers/net/wireless/ath/ath10k/core.c
@@ -41,10 +41,8 @@ static bool uart_print;
 static bool skip_otp;
 static bool rawmode;
 
-/* Enable ATH10K_FW_CRASH_DUMP_REGISTERS and ATH10K_FW_CRASH_DUMP_CE_DATA
- * by default.
- */
-unsigned long ath10k_coredump_mask = 0x3;
+unsigned long ath10k_coredump_mask = BIT(ATH10K_FW_CRASH_DUMP_REGISTERS) |
+				     BIT(ATH10K_FW_CRASH_DUMP_CE_DATA);
 
 /* FIXME: most of these should be readonly */
 module_param_named(debug_mask, ath10k_debug_mask, uint, 0644);
-- 
2.18.0.rc1.242.g61856ae69a-goog


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: ath10k: use crash_dump enum instead of magic numbers
  2018-06-11 18:19 [PATCH] ath10k: use crash_dump enum instead of magic numbers Brian Norris
@ 2018-06-14 15:13 ` Kalle Valo
  0 siblings, 0 replies; 2+ messages in thread
From: Kalle Valo @ 2018-06-14 15:13 UTC (permalink / raw)
  To: Brian Norris
  Cc: Kalle Valo, ath10k, linux-wireless, linux-kernel, Brian Norris

Brian Norris <briannorris@chromium.org> wrote:

> The comments are telling you what the enum could tell you instead.
> 
> Signed-off-by: Brian Norris <briannorris@chromium.org>
> Signed-off-by: Kalle Valo <kvalo@codeaurora.org>

Patch applied to ath-next branch of ath.git, thanks.

7f8f72d8511a ath10k: use crash_dump enum instead of magic numbers

-- 
https://patchwork.kernel.org/patch/10458637/

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2018-06-14 15:13 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-06-11 18:19 [PATCH] ath10k: use crash_dump enum instead of magic numbers Brian Norris
2018-06-14 15:13 ` Kalle Valo

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).