linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: Mark Rutland <mark.rutland@arm.com>
Cc: Will Deacon <will.deacon@arm.com>,
	linux-kernel@vger.kernel.org, peterz@infradead.org,
	boqun.feng@gmail.com, Richard Henderson <rth@twiddle.net>,
	Ivan Kokshaysky <ink@jurassic.park.msu.ru>,
	Matt Turner <mattst88@gmail.com>
Subject: Re: [PATCHv3 09/18] atomics/alpha: define atomic64_fetch_add_unless()
Date: Thu, 21 Jun 2018 13:00:02 +0200	[thread overview]
Message-ID: <20180621110002.GA1057@gmail.com> (raw)
In-Reply-To: <20180618160829.5jrscmfkorjxdvod@lakrids.cambridge.arm.com>


* Mark Rutland <mark.rutland@arm.com> wrote:

> On Mon, Jun 18, 2018 at 04:54:40PM +0100, Will Deacon wrote:
> > On Mon, Jun 18, 2018 at 11:19:10AM +0100, Mark Rutland wrote:
> > >  /**
> > > - * atomic64_add_unless - add unless the number is a given value
> > > + * atomic64_fetch_add_unless - add unless the number is a given value
> > >   * @v: pointer of type atomic64_t
> > >   * @a: the amount to add to v...
> > >   * @u: ...unless v is equal to u.
> > >   *
> > >   * Atomically adds @a to @v, so long as it was not @u.
> > > - * Returns true iff @v was not @u.
> > > + * Returns the old value of @v.
> > >   */
> > > -static __inline__ int atomic64_add_unless(atomic64_t *v, long a, long u)
> > > +static __inline__ int atomic64_fetch_add_unless(atomic64_t *v, long a, long u)
> > 
> 
> Whoops; yes.
> 
> From a scan of the series, I messed that up in the instrumentation, too,
> but the rest sems fine.
> 
> I'll fix those up and push out an updated branch.

Please send out an updated series via email as well once it has all settled down.

Thanks!

	Ingo

  reply	other threads:[~2018-06-21 11:00 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-18 10:19 [PATCHv3 00/18] atomics: API cleanups Mark Rutland
2018-06-18 10:19 ` [PATCHv3 01/18] atomics/treewide: s/__atomic_add_unless/atomic_fetch_add_unless/ Mark Rutland
2018-06-18 10:19 ` [PATCHv3 02/18] atomics/treewide: remove redundant atomic_inc_not_zero() definitions Mark Rutland
2018-06-18 10:19 ` [PATCHv3 03/18] atomics/treewide: remove atomic_inc_not_zero_hint() Mark Rutland
2018-06-18 10:19 ` [PATCHv3 04/18] atomics: make conditional ops return bool Mark Rutland
2018-06-18 10:19 ` [PATCHv3 05/18] atomics/treewide: make atomic64_inc_not_zero() optional Mark Rutland
2018-06-18 10:19 ` [PATCHv3 06/18] atomics/treewide: make atomic_fetch_add_unless() optional Mark Rutland
2018-06-18 10:19 ` [PATCHv3 07/18] atomics: prepare for atomic64_fetch_add_unless() Mark Rutland
2018-06-18 16:10   ` Mark Rutland
2018-06-18 10:19 ` [PATCHv3 08/18] atomics/generic: define atomic64_fetch_add_unless() Mark Rutland
2018-06-18 10:19 ` [PATCHv3 09/18] atomics/alpha: " Mark Rutland
2018-06-18 15:54   ` Will Deacon
2018-06-18 16:08     ` Mark Rutland
2018-06-21 11:00       ` Ingo Molnar [this message]
2018-06-18 10:19 ` [PATCHv3 10/18] atomics/arc: " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 11/18] atomics/arm: " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 12/18] atomics/powerpc: " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 13/18] atomics/riscv: " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 14/18] atomics/treewide: make atomic64_fetch_add_unless() optional Mark Rutland
2018-06-18 10:19 ` [PATCHv3 15/18] atomics/treewide: make test ops optional Mark Rutland
2018-06-18 10:19 ` [PATCHv3 16/18] atomics/treewide: make unconditional inc/dec " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 17/18] atomics/treewide: make conditional " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 18/18] atomics/treewide: clean up andnot ifdeffery Mark Rutland
2018-06-18 16:38 ` [PATCHv3 00/18] atomics: API cleanups Will Deacon
2018-06-18 19:21   ` Mark Rutland
2018-06-19 10:18     ` Mark Rutland
2018-06-19 10:20       ` Will Deacon
2018-06-19 10:38         ` Mark Rutland

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180621110002.GA1057@gmail.com \
    --to=mingo@kernel.org \
    --cc=boqun.feng@gmail.com \
    --cc=ink@jurassic.park.msu.ru \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=mattst88@gmail.com \
    --cc=peterz@infradead.org \
    --cc=rth@twiddle.net \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).