linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Mark Rutland <mark.rutland@arm.com>
To: mingo@kernel.org, will.deacon@arm.com, peterz@infradead.org,
	linux-kernel@vger.kernel.org
Cc: Mark Rutland <mark.rutland@arm.com>,
	Boqun Feng <boqun.feng@gmail.com>,
	Palmer Dabbelt <palmer@sifive.com>, Albert Ou <albert@sifive.com>
Subject: [PATCHv4 13/18] atomics/riscv: define atomic64_fetch_add_unless()
Date: Thu, 21 Jun 2018 13:13:16 +0100	[thread overview]
Message-ID: <20180621121321.4761-14-mark.rutland@arm.com> (raw)
In-Reply-To: <20180621121321.4761-1-mark.rutland@arm.com>

As a step towards unifying the atomic/atomic64/atomic_long APIs, this
patch converts the arch/riscv implementation of atomic64_add_unless()
into an implementation of atomic64_fetch_add_unless().

A wrapper in <linux/atomic.h> will build atomic_add_unless() atop of
this, provided it is given a preprocessor definition.

No functional change is intended as a result of this patch.

Signed-off-by: Mark Rutland <mark.rutland@arm.com>
Acked-by: Peter Zijlstra (Intel) <peterz@infradead.org>
Acked-by Palmer Dabbelt <palmer@sifive.com>
Reviewed-by: Will Deacon <will.deacon@arm.com>
Cc: Boqun Feng <boqun.feng@gmail.com>
Cc: Palmer Dabbelt <palmer@sifive.com>
Cc: Albert Ou <albert@sifive.com>
---
 arch/riscv/include/asm/atomic.h | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

diff --git a/arch/riscv/include/asm/atomic.h b/arch/riscv/include/asm/atomic.h
index 5f161daefcd2..d959bbaaad41 100644
--- a/arch/riscv/include/asm/atomic.h
+++ b/arch/riscv/include/asm/atomic.h
@@ -352,7 +352,7 @@ static __always_inline int atomic_fetch_add_unless(atomic_t *v, int a, int u)
 #define atomic_fetch_add_unless atomic_fetch_add_unless
 
 #ifndef CONFIG_GENERIC_ATOMIC64
-static __always_inline long __atomic64_add_unless(atomic64_t *v, long a, long u)
+static __always_inline long atomic64_fetch_add_unless(atomic64_t *v, long a, long u)
 {
        long prev, rc;
 
@@ -369,11 +369,7 @@ static __always_inline long __atomic64_add_unless(atomic64_t *v, long a, long u)
 		: "memory");
 	return prev;
 }
-
-static __always_inline int atomic64_add_unless(atomic64_t *v, long a, long u)
-{
-	return __atomic64_add_unless(v, a, u) != u;
-}
+#define atomic64_fetch_add_unless atomic64_fetch_add_unless
 #endif
 
 /*
-- 
2.11.0


  parent reply	other threads:[~2018-06-21 12:14 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-21 12:13 [PATCHv4 00/18] atomics: API cleanups Mark Rutland
2018-06-21 12:13 ` [PATCHv4 01/18] atomics/treewide: s/__atomic_add_unless/atomic_fetch_add_unless/ Mark Rutland
2018-06-21 12:13 ` [PATCHv4 02/18] atomics/treewide: remove redundant atomic_inc_not_zero() definitions Mark Rutland
2018-06-21 12:13 ` [PATCHv4 03/18] atomics/treewide: remove atomic_inc_not_zero_hint() Mark Rutland
2018-06-21 12:13 ` [PATCHv4 04/18] atomics: make conditional ops return bool Mark Rutland
2018-06-21 12:13 ` [PATCHv4 05/18] atomics/treewide: make atomic64_inc_not_zero() optional Mark Rutland
2018-06-21 12:13 ` [PATCHv4 06/18] atomics/treewide: make atomic_fetch_add_unless() optional Mark Rutland
2018-06-21 12:13 ` [PATCHv4 07/18] atomics: prepare for atomic64_fetch_add_unless() Mark Rutland
2018-06-21 12:13 ` [PATCHv4 08/18] atomics/generic: define atomic64_fetch_add_unless() Mark Rutland
2018-06-21 12:21   ` Mark Rutland
2018-06-21 12:26     ` Ingo Molnar
2018-06-21 12:13 ` [PATCHv4 09/18] atomics/alpha: " Mark Rutland
2018-06-21 12:13 ` [PATCHv4 10/18] atomics/arc: " Mark Rutland
2018-06-21 12:13 ` [PATCHv4 11/18] atomics/arm: " Mark Rutland
2018-06-21 12:13 ` [PATCHv4 12/18] atomics/powerpc: " Mark Rutland
2018-06-21 12:13 ` Mark Rutland [this message]
2018-06-21 12:13 ` [PATCHv4 14/18] atomics/treewide: make atomic64_fetch_add_unless() optional Mark Rutland
2018-06-21 12:13 ` [PATCHv4 15/18] atomics/treewide: make test ops optional Mark Rutland
2018-06-21 12:13 ` [PATCHv4 16/18] atomics/treewide: make unconditional inc/dec " Mark Rutland
2018-06-21 12:13 ` [PATCHv4 17/18] atomics/treewide: make conditional " Mark Rutland
2018-06-21 12:13 ` [PATCHv4 18/18] atomics/treewide: clean up andnot ifdeffery Mark Rutland

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180621121321.4761-14-mark.rutland@arm.com \
    --to=mark.rutland@arm.com \
    --cc=albert@sifive.com \
    --cc=boqun.feng@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=palmer@sifive.com \
    --cc=peterz@infradead.org \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).