From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-0.8 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_PASS,URIBL_BLOCKED autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id A2780ECDFBB for ; Sat, 21 Jul 2018 17:10:23 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 5DD2E2086D for ; Sat, 21 Jul 2018 17:10:23 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 5DD2E2086D Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=bootlin.com Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-kernel-owner@vger.kernel.org Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1728144AbeGUSDg (ORCPT ); Sat, 21 Jul 2018 14:03:36 -0400 Received: from mail.bootlin.com ([62.4.15.54]:49081 "EHLO mail.bootlin.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1728076AbeGUSDf (ORCPT ); Sat, 21 Jul 2018 14:03:35 -0400 Received: by mail.bootlin.com (Postfix, from userid 110) id 03C4320737; Sat, 21 Jul 2018 19:10:10 +0200 (CEST) Received: from bbrezillon (unknown [37.173.79.60]) by mail.bootlin.com (Postfix) with ESMTPSA id D0C93206F3; Sat, 21 Jul 2018 19:10:07 +0200 (CEST) Date: Sat, 21 Jul 2018 19:10:04 +0200 From: Boris Brezillon To: Miquel Raynal Cc: Wenyou Yang , Josh Wu , Tudor Ambarus , Richard Weinberger , David Woodhouse , Brian Norris , Marek Vasut , Nicolas Ferre , Alexandre Belloni , Kamal Dasu , Masahiro Yamada , Han Xu , Harvey Hunt , Vladimir Zapolskiy , Sylvain Lemieux , Xiaolei Li , Matthias Brugger , Maxime Ripard , Chen-Yu Tsai , Marc Gonzalez , Mans Rullgard , Stefan Agner , linux-mtd@lists.infradead.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, bcm-kernel-feedback-list@broadcom.com, linux-mediatek@lists.infradead.org Subject: Re: [PATCH v4 14/35] mtd: rawnand: mtk: convert driver to nand_scan() Message-ID: <20180721191004.26fc9290@bbrezillon> In-Reply-To: <20180720151527.16038-15-miquel.raynal@bootlin.com> References: <20180720151527.16038-1-miquel.raynal@bootlin.com> <20180720151527.16038-15-miquel.raynal@bootlin.com> X-Mailer: Claws Mail 3.15.0-dirty (GTK+ 2.24.31; x86_64-pc-linux-gnu) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 20 Jul 2018 17:15:06 +0200 Miquel Raynal wrote: > Two helpers have been added to the core to make ECC-related > configuration between the detection phase and the final NAND scan. Use > these hooks and convert the driver to just use nand_scan() instead of > both nand_scan_ident() and nand_scan_tail(). > > Signed-off-by: Miquel Raynal > --- > drivers/mtd/nand/raw/mtk_nand.c | 75 ++++++++++++++++++++++++----------------- > 1 file changed, 44 insertions(+), 31 deletions(-) > > diff --git a/drivers/mtd/nand/raw/mtk_nand.c b/drivers/mtd/nand/raw/mtk_nand.c > index 7bc6be3f6ec0..967418f945ea 100644 > --- a/drivers/mtd/nand/raw/mtk_nand.c > +++ b/drivers/mtd/nand/raw/mtk_nand.c > @@ -1250,13 +1250,54 @@ static int mtk_nfc_ecc_init(struct device *dev, struct mtd_info *mtd) > return 0; > } > > +static int mtk_nfc_attach_chip(struct nand_chip *chip) > +{ > + struct mtd_info *mtd = nand_to_mtd(chip); > + struct device *dev = mtd->dev.parent; > + struct mtk_nfc *nfc = nand_get_controller_data(chip); > + struct mtk_nfc_nand_chip *mtk_nand = to_mtk_nand(chip); > + int len; > + int ret; > + > + if (chip->options & NAND_BUSWIDTH_16) { > + dev_err(dev, "16bits buswidth not supported"); > + return -EINVAL; > + } > + > + /* store bbt magic in page, cause OOB is not protected */ > + if (chip->bbt_options & NAND_BBT_USE_FLASH) > + chip->bbt_options |= NAND_BBT_NO_OOB; > + > + ret = mtk_nfc_ecc_init(dev, mtd); > + if (ret) > + return ret; > + > + ret = mtk_nfc_set_spare_per_sector(&mtk_nand->spare_per_sector, mtd); > + if (ret) > + return ret; > + > + mtk_nfc_set_fdm(&mtk_nand->fdm, mtd); > + mtk_nfc_set_bad_mark_ctl(&mtk_nand->bad_mark, mtd); > + > + len = mtd->writesize + mtd->oobsize; > + nfc->buffer = devm_kzalloc(dev, len, GFP_KERNEL); > + if (!nfc->buffer) > + return -ENOMEM; > + > + return 0; > +} > + > +static const struct nand_controller_ops mtk_nfc_controller_ops = { > + .attach_chip = mtk_nfc_attach_chip, > +}; > + > static int mtk_nfc_nand_chip_init(struct device *dev, struct mtk_nfc *nfc, > struct device_node *np) > { > struct mtk_nfc_nand_chip *chip; > struct nand_chip *nand; > struct mtd_info *mtd; > - int nsels, len; > + int nsels; > u32 tmp; > int ret; > int i; > @@ -1287,6 +1328,7 @@ static int mtk_nfc_nand_chip_init(struct device *dev, struct mtk_nfc *nfc, > > nand = &chip->nand; > nand->controller = &nfc->controller; > + nand->controller->ops = &mtk_nfc_controller_ops; Just like for the marvell driver, this assignment should be moved here [1]. Also, it looks like this driver is open-coding nand_controller_init(), probably something we should fix (in a separate patch). With this fixed: Reviewed-by: Boris Brezillon > > nand_set_flash_node(nand, np); > nand_set_controller_data(nand, nfc); > @@ -1324,36 +1366,7 @@ static int mtk_nfc_nand_chip_init(struct device *dev, struct mtk_nfc *nfc, > > mtk_nfc_hw_init(nfc); > > - ret = nand_scan_ident(mtd, nsels, NULL); > - if (ret) > - return ret; > - > - /* store bbt magic in page, cause OOB is not protected */ > - if (nand->bbt_options & NAND_BBT_USE_FLASH) > - nand->bbt_options |= NAND_BBT_NO_OOB; > - > - ret = mtk_nfc_ecc_init(dev, mtd); > - if (ret) > - return -EINVAL; > - > - if (nand->options & NAND_BUSWIDTH_16) { > - dev_err(dev, "16bits buswidth not supported"); > - return -EINVAL; > - } > - > - ret = mtk_nfc_set_spare_per_sector(&chip->spare_per_sector, mtd); > - if (ret) > - return ret; > - > - mtk_nfc_set_fdm(&chip->fdm, mtd); > - mtk_nfc_set_bad_mark_ctl(&chip->bad_mark, mtd); > - > - len = mtd->writesize + mtd->oobsize; > - nfc->buffer = devm_kzalloc(dev, len, GFP_KERNEL); > - if (!nfc->buffer) > - return -ENOMEM; > - > - ret = nand_scan_tail(mtd); > + ret = nand_scan(mtd, nsels); > if (ret) > return ret; >