linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: Leonardo Bras <leobras.c@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>,
	devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 10/15] staging: fbtft: Fixes some defines styles - Style
Date: Thu, 9 Aug 2018 11:49:53 +0200	[thread overview]
Message-ID: <20180809094953.GA22141@kroah.com> (raw)
In-Reply-To: <CADvQ+rGiF2kT62tBJjruGkQ8TbxU45PmgpW7xfrMy8xi1tOTBg@mail.gmail.com>

On Thu, Aug 09, 2018 at 06:39:55AM -0300, Leonardo Bras wrote:
> On Wed, Aug 08, 2018 at 02:22:19PM +0200, Greg Kroah-Hartman wrote:
> > On Tue, Aug 07, 2018 at 09:29:25PM -0300, Leonardo Brás wrote:
> > > Fixing some styles as recommended by checkpatch.pl.
> > >
> > > Signed-off-by: Leonardo Brás <leobras.c@gmail.com>
> > > ---
> > >  drivers/staging/fbtft/fbtft-bus.c  | 10 ++++++----
> > >  drivers/staging/fbtft/fbtft-core.c |  6 ++++--
> > >  drivers/staging/fbtft/fbtft.h      |  4 ++--
> > >  3 files changed, 12 insertions(+), 8 deletions(-)
> > >
> > > diff --git a/drivers/staging/fbtft/fbtft-bus.c
> b/drivers/staging/fbtft/fbtft-bus.c
> > > index 8ce1ff9b6c2a..20d94712cc84 100644
> > > --- a/drivers/staging/fbtft/fbtft-bus.c
> > > +++ b/drivers/staging/fbtft/fbtft-bus.c
> > > @@ -60,11 +60,13 @@ void func(struct fbtft_par *par, int len, ...)
>                           \
> > >  out:
>            \
> > >     va_end(args);
>    \
> > >  }
>        \
> > > -EXPORT_SYMBOL(func);
> > > +EXPORT_SYMBOL(func)
> >
> > why did you change this line?
> 
> checkpatch.pl recommended removing ";" from the end of a macro define,
> and attaching it after the usage of the macro.
> 
> Probably to make the macro usage more likely a function declaration.

Ah, I was confused by your initial subject/changelog, you did not
explain why you were doing what you were doing, and you lumped a bunch
of different types of changes all in a single patch, which is not
allowed.

Please only do one patch per "type" of change, this should be a patch
series.

> > >
> > > -define_fbtft_write_reg(fbtft_write_reg8_bus8, u8, u8, )
> > > -define_fbtft_write_reg(fbtft_write_reg16_bus8, __be16, u16,
> cpu_to_be16)
> > > -define_fbtft_write_reg(fbtft_write_reg16_bus16, u16, u16, )
> > > +#define no_modf /*No modifier*/
> >
> > Ick ick ick, no.
> 
> Please help me understand.
> There are 3 steps that may be bad here:
> 1. Defining no_modf as a comment.

Yes.

> 2. Defining no_modf as "nothing"

Yes.

> 3. Using no_modf (defined as nothing) as a filler to avoid not
> passing a "parameter" to the macro.

Yes.

> I understand it may be a combination of the above, but i need
> to understand it better.

Why do you want to do any of the above?  What is wrong with the existing
macro?

thanks,

greg k-h

  parent reply	other threads:[~2018-08-09 12:09 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-08-08  0:27 [PATCH v2 00/15] staging: fbtft: Fixes some issues found with checkpatch.pl Leonardo Brás
2018-08-08  0:28 ` [PATCH v2 01/15] staging: fbtft: Changes udelay(n) to usleep_range(n, n + x). - Style Leonardo Brás
2018-08-08 12:18   ` Greg Kroah-Hartman
2018-08-08  0:28 ` [PATCH v2 02/15] staging: fbtft: Puts macro arguments in parenthesis to avoid precedence issues " Leonardo Brás
2018-08-08  0:28 ` [PATCH v2 03/15] staging: fbtft: Fixes some alignment " Leonardo Brás
2018-08-08  0:28 ` [PATCH v2 04/15] staging: fbtft: Fixes some lines long lines (>80) " Leonardo Brás
2018-08-08 12:19   ` Greg Kroah-Hartman
2018-08-08  0:28 ` [PATCH v2 05/15] staging: fbtft: A bit more information on dev_err Leonardo Brás
2018-08-08  0:28 ` [PATCH v2 06/15] staging: fbtft: Changes gamma table to define Leonardo Brás
2018-08-08  0:29 ` [PATCH v2 07/15] staging: fbtft: Removes one nesting level to help readability - Style Leonardo Brás
2018-08-08  0:29 ` [PATCH v2 08/15] staging: fbtft: Adjust some empty-line problems " Leonardo Brás
2018-08-08  0:29 ` [PATCH v2 09/15] staging: fbtft: Erases some repetitive usage of function name " Leonardo Brás
2018-08-08  0:29 ` [PATCH v2 10/15] staging: fbtft: Fixes some defines styles " Leonardo Brás
2018-08-08 12:22   ` Greg Kroah-Hartman
     [not found]     ` <CADvQ+rGiF2kT62tBJjruGkQ8TbxU45PmgpW7xfrMy8xi1tOTBg@mail.gmail.com>
2018-08-09  9:49       ` Greg Kroah-Hartman [this message]
2018-08-08  0:29 ` [PATCH v2 11/15] staging: fbtft: Includes description to mutex and spinlock " Leonardo Brás
2018-08-08 12:22   ` Greg Kroah-Hartman
2018-08-08  0:29 ` [PATCH v2 12/15] staging: fbtft: Add spaces around / " Leonardo Brás
2018-08-08  0:29 ` [PATCH v2 13/15] staging: fbtft: Corrects long index line " Leonardo Brás
2018-08-08  0:30 ` [PATCH v2 14/15] staging: fbtft: Replaces (1 << n) for macro BIT(n) " Leonardo Brás
2018-08-08  0:30 ` [PATCH v2 15/15] staging: fbtft: Replaces custom debug macro with dev_dbg() Leonardo Brás
2018-08-08 12:24   ` Greg Kroah-Hartman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180809094953.GA22141@kroah.com \
    --to=gregkh@linuxfoundation.org \
    --cc=devel@driverdev.osuosl.org \
    --cc=leobras.c@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=thomas.petazzoni@free-electrons.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).