linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] ext4: avoid unused variable warning
@ 2018-10-10 14:27 Arnd Bergmann
  2018-10-10 19:26 ` Theodore Y. Ts'o
  0 siblings, 1 reply; 4+ messages in thread
From: Arnd Bergmann @ 2018-10-10 14:27 UTC (permalink / raw)
  To: Theodore Ts'o, Andreas Dilger
  Cc: Arnd Bergmann, Jan Kara, Eric Biggers, linux-ext4, linux-kernel

The two new variables are only used in an #ifdef, so they cause a
warning without CONFIG_QUOTA:

fs/ext4/super.c: In function 'parse_options':
fs/ext4/super.c:1977:26: error: unused variable 'grp_qf_name' [-Werror=unused-variable]
  char *p, *usr_qf_name, *grp_qf_name;
                          ^~~~~~~~~~~
fs/ext4/super.c:1977:12: error: unused variable 'usr_qf_name' [-Werror=unused-variable]
  char *p, *usr_qf_name, *grp_qf_name;

Fixes: 20cefcdc2040 ("ext4: fix use-after-free race in ext4_remount()'s error path")
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
---
 fs/ext4/super.c | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/fs/ext4/super.c b/fs/ext4/super.c
index e9ca8312457b..d60199510c94 100644
--- a/fs/ext4/super.c
+++ b/fs/ext4/super.c
@@ -1974,7 +1974,10 @@ static int parse_options(char *options, struct super_block *sb,
 			 int is_remount)
 {
 	struct ext4_sb_info *sbi = EXT4_SB(sb);
-	char *p, *usr_qf_name, *grp_qf_name;
+	char *p;
+#ifdef CONFIG_QUOTA
+	char *usr_qf_name, *grp_qf_name;
+#endif
 	substring_t args[MAX_OPT_ARGS];
 	int token;
 
-- 
2.18.0


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] ext4: avoid unused variable warning
  2018-10-10 14:27 [PATCH] ext4: avoid unused variable warning Arnd Bergmann
@ 2018-10-10 19:26 ` Theodore Y. Ts'o
  2018-10-10 19:43   ` Miguel Ojeda
  2018-10-10 19:43   ` Arnd Bergmann
  0 siblings, 2 replies; 4+ messages in thread
From: Theodore Y. Ts'o @ 2018-10-10 19:26 UTC (permalink / raw)
  To: Arnd Bergmann
  Cc: Andreas Dilger, Jan Kara, Eric Biggers, linux-ext4, linux-kernel,
	Miguel Ojeda

On Wed, Oct 10, 2018 at 04:27:58PM +0200, Arnd Bergmann wrote:
> The two new variables are only used in an #ifdef, so they cause a
> warning without CONFIG_QUOTA:
> 
> fs/ext4/super.c: In function 'parse_options':
> fs/ext4/super.c:1977:26: error: unused variable 'grp_qf_name' [-Werror=unused-variable]
>   char *p, *usr_qf_name, *grp_qf_name;
>                           ^~~~~~~~~~~
> fs/ext4/super.c:1977:12: error: unused variable 'usr_qf_name' [-Werror=unused-variable]
>   char *p, *usr_qf_name, *grp_qf_name;
> 
> Fixes: 20cefcdc2040 ("ext4: fix use-after-free race in ext4_remount()'s error path")
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>

Hmm, I wonder if we should do something like:

#define EXT4_UNUSED_VAR __attribute__ ((unused))

and then we could do:

	char *p, *usr_qf_name EXT4_UNUSED_VAR, *grp_qf_name EXT4_UNUSED_VAR;

More generally, I wonder if this is something we should have defined
for the whole kernel, as opposed to a one-off hack that ACPI and ext4
subsystems use.  It's a little ugly, but I think it's much nicer than
having extra #ifdefs such as:

	char *p;
#ifdef CONFIG_QUOTA
	char *usr_qf_name, *grp_qf_name;
#endif

After all, the compiler is perfectly capable of ignoring variables
which are unused.  And if it's only because of an #ifdef later in the
function, it would be nice to not have an extra #ifdef in the variable
declarations.

						- Ted

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] ext4: avoid unused variable warning
  2018-10-10 19:26 ` Theodore Y. Ts'o
  2018-10-10 19:43   ` Miguel Ojeda
@ 2018-10-10 19:43   ` Arnd Bergmann
  1 sibling, 0 replies; 4+ messages in thread
From: Arnd Bergmann @ 2018-10-10 19:43 UTC (permalink / raw)
  To: Theodore Y. Ts'o, Arnd Bergmann, Andreas Dilger, Jan Kara,
	Eric Biggers, linux-ext4, linux-kernel, Miguel Ojeda

On 10/10/18, Theodore Y. Ts'o <tytso@mit.edu> wrote:
> On Wed, Oct 10, 2018 at 04:27:58PM +0200, Arnd Bergmann wrote:
>> The two new variables are only used in an #ifdef, so they cause a
>> warning without CONFIG_QUOTA:
>>
>> fs/ext4/super.c: In function 'parse_options':
>> fs/ext4/super.c:1977:26: error: unused variable 'grp_qf_name'
>> [-Werror=unused-variable]
>>   char *p, *usr_qf_name, *grp_qf_name;
>>                           ^~~~~~~~~~~
>> fs/ext4/super.c:1977:12: error: unused variable 'usr_qf_name'
>> [-Werror=unused-variable]
>>   char *p, *usr_qf_name, *grp_qf_name;
>>
>> Fixes: 20cefcdc2040 ("ext4: fix use-after-free race in ext4_remount()'s
>> error path")
>> Signed-off-by: Arnd Bergmann <arnd@arndb.de>
>
> Hmm, I wonder if we should do something like:
>
> #define EXT4_UNUSED_VAR __attribute__ ((unused))
>
> and then we could do:
>
> 	char *p, *usr_qf_name EXT4_UNUSED_VAR, *grp_qf_name EXT4_UNUSED_VAR;
>
> More generally, I wonder if this is something we should have defined
> for the whole kernel, as opposed to a one-off hack that ACPI and ext4
> subsystems use.

I think the global __maybe_unused macro should work fine here.
I though about using that instead, but picked the #ifdef for
consistency with the other ifdef in the same function.

>  It's a little ugly, but I think it's much nicer than
> having extra #ifdefs such as:
>
> 	char *p;
> #ifdef CONFIG_QUOTA
> 	char *usr_qf_name, *grp_qf_name;
> #endif
>
> After all, the compiler is perfectly capable of ignoring variables
> which are unused.  And if it's only because of an #ifdef later in the
> function, it would be nice to not have an extra #ifdef in the variable
> declarations.

Another alternative that often results in more readable code is
to use a check like

        if (IS_ENABLED(CONFIG_QUOTA)) {
             ....
        }

around the conditional code instead of the #ifdef. This should usually
work unless the code accesses some struct members that are
also hidden in that #ifdef. I have not checked if that is the case here.

        Arnd

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] ext4: avoid unused variable warning
  2018-10-10 19:26 ` Theodore Y. Ts'o
@ 2018-10-10 19:43   ` Miguel Ojeda
  2018-10-10 19:43   ` Arnd Bergmann
  1 sibling, 0 replies; 4+ messages in thread
From: Miguel Ojeda @ 2018-10-10 19:43 UTC (permalink / raw)
  To: Ted Ts'o, Arnd Bergmann, Andreas Dilger, jack, Eric Biggers,
	Ext4 Developers List, linux-kernel

Hi Ted,

On Wed, Oct 10, 2018 at 9:27 PM Theodore Y. Ts'o <tytso@mit.edu> wrote:
>
> On Wed, Oct 10, 2018 at 04:27:58PM +0200, Arnd Bergmann wrote:
> > The two new variables are only used in an #ifdef, so they cause a
> > warning without CONFIG_QUOTA:
> >
> > fs/ext4/super.c: In function 'parse_options':
> > fs/ext4/super.c:1977:26: error: unused variable 'grp_qf_name' [-Werror=unused-variable]
> >   char *p, *usr_qf_name, *grp_qf_name;
> >                           ^~~~~~~~~~~
> > fs/ext4/super.c:1977:12: error: unused variable 'usr_qf_name' [-Werror=unused-variable]
> >   char *p, *usr_qf_name, *grp_qf_name;
> >
> > Fixes: 20cefcdc2040 ("ext4: fix use-after-free race in ext4_remount()'s error path")
> > Signed-off-by: Arnd Bergmann <arnd@arndb.de>
>
> Hmm, I wonder if we should do something like:
>
> #define EXT4_UNUSED_VAR __attribute__ ((unused))

We have __maybe_unused already, so you can go ahead! :-)

(Also __always_unused, same definition as well, but here it does not may sense).

>
> and then we could do:
>
>         char *p, *usr_qf_name EXT4_UNUSED_VAR, *grp_qf_name EXT4_UNUSED_VAR;
>
> More generally, I wonder if this is something we should have defined
> for the whole kernel, as opposed to a one-off hack that ACPI and ext4
> subsystems use.  It's a little ugly, but I think it's much nicer than
> having extra #ifdefs such as:
>
>         char *p;
> #ifdef CONFIG_QUOTA
>         char *usr_qf_name, *grp_qf_name;
> #endif
>
> After all, the compiler is perfectly capable of ignoring variables
> which are unused.  And if it's only because of an #ifdef later in the
> function, it would be nice to not have an extra #ifdef in the variable
> declarations.

Indeed, it looks clean --- I like it.

Although I am not sure how people will feel about that :-) Someone may
argue that, for consistency, we shouldn't, because inside structs we
have to use #ifdefs still.

Cheers,
Miguel

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2018-10-10 19:43 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-10-10 14:27 [PATCH] ext4: avoid unused variable warning Arnd Bergmann
2018-10-10 19:26 ` Theodore Y. Ts'o
2018-10-10 19:43   ` Miguel Ojeda
2018-10-10 19:43   ` Arnd Bergmann

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).