linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [GIT PULL] power-supply changes for 4.21
@ 2018-12-28 13:08 Sebastian Reichel
  2018-12-29  5:35 ` pr-tracker-bot
  0 siblings, 1 reply; 2+ messages in thread
From: Sebastian Reichel @ 2018-12-28 13:08 UTC (permalink / raw)
  To: Linus Torvalds; +Cc: linux-kernel, linux-pm

[-- Attachment #1: Type: text/plain, Size: 7694 bytes --]

Hi Linus,

All changes have been in linux-next for multiple weeks, no issues
were reported to me. I don't expect any problems during or after
merging this pull request. Happy New Year!

-- Sebastian

The following changes since commit 651022382c7f8da46cb4872a545ee1da6d097d2a:

  Linux 4.20-rc1 (2018-11-04 15:37:52 -0800)

are available in the Git repository at:

  ssh://git@gitolite.kernel.org/pub/scm/linux/kernel/git/sre/linux-power-supply.git tags/for-v4.21

for you to fetch changes up to 9580913966488dc78d8d2893c7427d0a84124e74:

  power: supply: bq25890: fix BAT_COMP field definition (2018-12-18 00:21:16 +0100)

----------------------------------------------------------------
power supply and reset changes for the v4.21 series

* New core support
 - battery internal resistance
 - battery OCV capacity lookup table
 - support for custom sysfs attributes
* Convert all drivers to use power-supply core support for custom sysfs attributes
* bq24190-charger: bq24196 support
* axp20x-charger: AXP813 support
* sc27xx-battery: new fuel gauge driver
* gpio-poweroff: support for specific active and inactive delays
* Misc fixes

----------------------------------------------------------------
Alexandre Belloni (1):
      power: reset: ocelot: switch the SI to boot mode

Baolin Wang (16):
      dt-bindings: power: Introduce one property to present the battery internal resistance
      power: supply: core: Add one field to present the battery internal resistance
      dt-bindings: power: Introduce properties to present the battery OCV capacity table
      power: supply: core: Add some helpers to use the battery OCV capacity table
      dt-bindings: power: Add Spreadtrum SC27XX fuel gauge unit documentation
      power: supply: Add Spreadtrum SC27XX fuel gauge unit driver
      power: supply: charger-manager: Remove unused index counting
      power: supply: charger-manager: Fix some misspelled words
      power: supply: charger-manager: Fix incorrect return value
      power: supply: charger-manager: Make code more readable
      power: supply: sc2731_charger: Add one work to charge/discharge
      power: supply: sc2731_charger: Add charger status detection
      power: supply: sc2731_charger: Avoid repeated charge/discharge
      power: supply: sc2731_charger: Free battery information
      dt-bindings: power: supply: Add nvmem properties to calibrate FGU
      power: supply: sc27xx: Add fuel gauge calibration

Brian Masney (2):
      dt-bindings: power: supply: bq24190_charger: add bq24192 and usb-otg-vbus
      power: supply: bq24190_charger: add extcon support for USB OTG

Claudiu Beznea (1):
      power: reset: at91-poweroff: move shdwc related data to one structure

Claudiu.Beznea@microchip.com (2):
      power: reset: at91-poweroff: use one poweroff function for at91-poweroff
      power: reset: at91-poweroff: remove at91_ramc_of_match

Colin Ian King (2):
      power: supply: cpcap-battery: make array cpcap_battery_irqs static, shrinks object size
      power: supply: cpcap-charger: clean an indentation issue, remove tab

Heiko Stuebner (2):
      power: reset: gpio-poweroff: add ability to specific active and inactive delays
      power: supply: bq24190_charger: add support for bq24196 variant

Jonathan Marek (2):
      power: supply: bq24190_charger: add support for bq24192 variant
      power: supply: bq24190_charger: add of_match for usb-otg-vbus regulator

Lubomir Rintel (1):
      power: supply: olpc_battery: correct the temperature units

Michał Mirosław (1):
      power: supply: bq25890: fix BAT_COMP field definition

Olliver Schinagl (2):
      power: supply: axp20x: add missing include bitops.h
      power: supply: axp288: use the BIT() macro

Oskari Lemmela (2):
      dt-bindings: power: supply: axp20x: add AXP813 AC power DT binding
      power: supply: add AC power supply driver for AXP813

Randy Dunlap (1):
      power/supply: fix sc27xx_fuel_gauge build errors

Sebastian Reichel (16):
      Merge tag 'psy-mfd-axp813-immutable-for-v4.21-signed' into psy-next
      power: supply: core: add support for custom sysfs attributes
      power: supply: bq2415x: fix race-condition in sysfs registration
      power: supply: ds2780: fix race-condition in sysfs registration
      power: supply: ds2781: fix race-condition in sysfs registration
      power: supply: lp8788: fix race-condition in sysfs registration
      power: supply: bq24190_charger: fix race-condition in sysfs registration
      power: supply: bq24257: fix race-condition in sysfs registration
      power: supply: charger-manager: simplify generation of sysfs attribute group name
      power: supply: charger-manager: fix race-condition in sysfs registration
      power: supply: pcf50633: fix race-condition in sysfs registration
      power: supply: ds2780: fix race-condition in bin attribute registration
      power: supply: ds2781: fix race-condition in bin attribute registration
      power: supply: ds2780: switch to devm_power_supply_register
      power: supply: ds2781: switch to devm_power_supply_register
      power: supply: gpio-charger: Do not use deprecated POWER_SUPPLY_TYPE_USB_*

Yuanjiang Yu (3):
      power: supply: sc27xx: Add fuel gauge low voltage alarm
      power: supply: sc27xx: Add suspend/resume interfaces
      power: supply: sc27xx: Save last battery capacity

 .../bindings/power/reset/gpio-poweroff.txt         |    2 +
 .../bindings/power/supply/axp20x_ac_power.txt      |    3 +
 .../devicetree/bindings/power/supply/battery.txt   |   17 +
 .../devicetree/bindings/power/supply/bq24190.txt   |   10 +
 .../devicetree/bindings/power/supply/sc27xx-fg.txt |   56 +
 drivers/power/reset/at91-poweroff.c                |   86 +-
 drivers/power/reset/gpio-poweroff.c                |   10 +-
 drivers/power/reset/ocelot-reset.c                 |   12 +
 drivers/power/supply/Kconfig                       |    8 +
 drivers/power/supply/Makefile                      |    1 +
 drivers/power/supply/axp20x_ac_power.c             |   94 ++
 drivers/power/supply/axp20x_usb_power.c            |    1 +
 drivers/power/supply/axp288_charger.c              |   35 +-
 drivers/power/supply/bq2415x_charger.c             |  119 +--
 drivers/power/supply/bq24190_charger.c             |   91 +-
 drivers/power/supply/bq24257_charger.c             |   15 +-
 drivers/power/supply/bq25890_charger.c             |    2 +-
 drivers/power/supply/charger-manager.c             |   89 +-
 drivers/power/supply/cpcap-battery.c               |    2 +-
 drivers/power/supply/cpcap-charger.c               |    2 +-
 drivers/power/supply/ds2780_battery.c              |   87 +-
 drivers/power/supply/ds2781_battery.c              |   82 +-
 drivers/power/supply/gpio-charger.c                |    6 +-
 drivers/power/supply/lp8788-charger.c              |   62 +-
 drivers/power/supply/olpc_battery.c                |    4 +-
 drivers/power/supply/pcf50633-charger.c            |   17 +-
 drivers/power/supply/power_supply_core.c           |  141 ++-
 drivers/power/supply/sc2731_charger.c              |   54 +-
 drivers/power/supply/sc27xx_fuel_gauge.c           | 1075 ++++++++++++++++++++
 include/linux/mfd/axp20x.h                         |    1 +
 include/linux/power/charger-manager.h              |    3 +-
 include/linux/power_supply.h                       |   23 +
 32 files changed, 1791 insertions(+), 419 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/power/supply/sc27xx-fg.txt
 create mode 100644 drivers/power/supply/sc27xx_fuel_gauge.c

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [GIT PULL] power-supply changes for 4.21
  2018-12-28 13:08 [GIT PULL] power-supply changes for 4.21 Sebastian Reichel
@ 2018-12-29  5:35 ` pr-tracker-bot
  0 siblings, 0 replies; 2+ messages in thread
From: pr-tracker-bot @ 2018-12-29  5:35 UTC (permalink / raw)
  To: Sebastian Reichel; +Cc: Linus Torvalds, linux-kernel, linux-pm

The pull request you sent on Fri, 28 Dec 2018 14:08:52 +0100:

> ssh://git@gitolite.kernel.org/pub/scm/linux/kernel/git/sre/linux-power-supply.git tags/for-v4.21

has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/579a70035949b771a63a686db8becdd9b197d986

Thank you!

-- 
Deet-doot-dot, I am a bot.
https://korg.wiki.kernel.org/userdoc/prtracker

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2018-12-29  5:35 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-12-28 13:08 [GIT PULL] power-supply changes for 4.21 Sebastian Reichel
2018-12-29  5:35 ` pr-tracker-bot

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).