linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Russell King - ARM Linux admin <linux@armlinux.org.uk>
To: Antoine Tenart <antoine.tenart@bootlin.com>
Cc: Heiner Kallweit <hkallweit1@gmail.com>,
	davem@davemloft.net, andrew@lunn.ch, f.fainelli@gmail.com,
	netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
	thomas.petazzoni@bootlin.com, maxime.chevallier@bootlin.com,
	gregory.clement@bootlin.com, miquel.raynal@bootlin.com,
	nadavh@marvell.com, stefanc@marvell.com, mw@semihalf.com
Subject: Re: [PATCH net-next v4 1/2] net: phy: marvell10g: implement suspend/resume callbacks
Date: Wed, 3 Apr 2019 10:40:28 +0100	[thread overview]
Message-ID: <20190403094028.vvyuqe6ojza2ezhv@shell.armlinux.org.uk> (raw)
In-Reply-To: <20190403084614.GC3354@kwain>

On Wed, Apr 03, 2019 at 10:46:14AM +0200, Antoine Tenart wrote:
> Hi,
> 
> On Wed, Apr 03, 2019 at 07:09:55AM +0200, Heiner Kallweit wrote:
> > On 03.04.2019 00:10, Russell King - ARM Linux admin wrote:
> > > On Tue, Apr 02, 2019 at 08:17:16PM +0200, Heiner Kallweit wrote:
> > >> On 02.04.2019 15:10, Antoine Tenart wrote:
> > >>> This patch adds the suspend/resume callbacks for Marvell 10G PHYs. The
> > >>> three PCS (base-t, base-r and 1000base-x) are set in low power (the PCS
> > >>> are powered down) when the PHY isn't used.
> > >>>
> > >>> Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
> > >>> ---
> > >>>  drivers/net/phy/marvell10g.c | 12 +++++++++++-
> > >>>  1 file changed, 11 insertions(+), 1 deletion(-)
> > >>>
> > >>> diff --git a/drivers/net/phy/marvell10g.c b/drivers/net/phy/marvell10g.c
> > >>> index 80678919641d..9ee033c8a12b 100644
> > >>> --- a/drivers/net/phy/marvell10g.c
> > >>> +++ b/drivers/net/phy/marvell10g.c
> > >>> @@ -51,6 +51,8 @@ enum {
> > >>>  	MV_AN_STAT1000		= 0x8001, /* 1000base-T status register */
> > >>>  
> > >>>  	/* Vendor2 MMD registers */
> > >>> +	MV_V2_PORT_CTRL		= 0xf001,
> > >>> +	MV_V2_PORT_CTRL_PWRDOWN = 0x0800,
> > >>
> > >> If this driver is touched again I think it would be good to change all
> > >> such constants to BIT() and GENMASK(), ideally combined with the macros
> > >> from bitfields.h. This makes it much easier to check the code against the
> > >> datasheet. Apart from that:
> > > 
> > > Specifically, which constants are you talking about?
> > > 
> > > I think there's only MV_PCS_PAIRSWAP_MASK and MV_V2_TEMP_CTRL_MASK,
> > > which would be confusing to change given that the following definitions
> > > are values for the masked field.
> > > 
> > Exactly, MV_V2_TEMP_CTRL_MASK is a good example. My personal preference is
> > to define the mask as GENMASK(15, 14) and the field values as 0 and 3.
> > Then it's aligned with the datasheet that says:
> > 15:14 Temperature Sense Enable, 11 = Disable

Sorry, I don't see that.  You still have to convert between what the
data sheet says (binary) and the values used in C code (hex or decimal).
To me, it would be natural to state the above as 0xc000 rather than
stating it as '3' in the code with a GENMASK defining a mask for the
appropriate fields, and then have to check all over the place that
the right FIELD_* macros are used.  This seems _way_ more complex than
it needs to be.

> > Macros FIELD_GET and FIELD_PREP are perfect to deal with such fields.
> 
> I agree, I didn't used that to be consistent with what was already done
> in the driver.
> 
> > > However, MV_V2_PORT_CTRL_PWRDOWN should be defined using BIT() in any
> > > case.
> 
> Shouldn't MV_PCS_PAIRSWAP_AB also be defined using BIT()?

It is this that makes me utterly detest BIT().  It seems folk just
look at the value and think "it defines a single bit, it must use
BIT()" without thinking that it might be a field.  So we end up
with people inappropriately proposing to change stuff to BIT().

So no.

> More generally, we could have all the register definitions using the 0x
> values, the masks using GENMASK() and the values using a combination of
> BIT() and (0x... << y). That would match what's usually done in other
> drivers and improve the readability. (But I also recall being told not
> to use GENMASK in net/, so it's up to you to decide).

That difference is why I don't like GENMASK().  We end up with masks
defined using GENMASK() and their bitfields defined a completely
different way - there is no consistency, and it is not obvious that
the masks and the field values are related.

In my opinion, BIT() is only marginally useful, the rest just makes
things _less_ obviously correct.

-- 
RMK's Patch system: https://www.armlinux.org.uk/developer/patches/
FTTC broadband for 0.8mile line in suburbia: sync at 12.1Mbps down 622kbps up
According to speedtest.net: 11.9Mbps down 500kbps up

  reply	other threads:[~2019-04-03  9:40 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-04-02 13:10 [PATCH net-next v4 0/2] net: phy: marvell10g: implement suspend/resume callbacks Antoine Tenart
2019-04-02 13:10 ` [PATCH net-next v4 1/2] " Antoine Tenart
2019-04-02 18:17   ` Heiner Kallweit
2019-04-02 22:10     ` Russell King - ARM Linux admin
2019-04-03  5:09       ` Heiner Kallweit
2019-04-03  8:46         ` Antoine Tenart
2019-04-03  9:40           ` Russell King - ARM Linux admin [this message]
2019-04-02 13:10 ` [PATCH net-next v4 2/2] net: phy: marvell10g: add the suspend/resume callbacks for the 88x2210 Antoine Tenart
2019-04-04  4:46 ` [PATCH net-next v4 0/2] net: phy: marvell10g: implement suspend/resume callbacks David Miller

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190403094028.vvyuqe6ojza2ezhv@shell.armlinux.org.uk \
    --to=linux@armlinux.org.uk \
    --cc=andrew@lunn.ch \
    --cc=antoine.tenart@bootlin.com \
    --cc=davem@davemloft.net \
    --cc=f.fainelli@gmail.com \
    --cc=gregory.clement@bootlin.com \
    --cc=hkallweit1@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maxime.chevallier@bootlin.com \
    --cc=miquel.raynal@bootlin.com \
    --cc=mw@semihalf.com \
    --cc=nadavh@marvell.com \
    --cc=netdev@vger.kernel.org \
    --cc=stefanc@marvell.com \
    --cc=thomas.petazzoni@bootlin.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).