linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RESEND][PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support
@ 2019-08-14 18:46 John Stultz
  2019-08-14 18:46 ` [RESEND][PATCH v3 01/26] drm: kirin: Fix for hikey620 display offset problem John Stultz
                   ` (26 more replies)
  0 siblings, 27 replies; 31+ messages in thread
From: John Stultz @ 2019-08-14 18:46 UTC (permalink / raw)
  To: lkml
  Cc: John Stultz, Rongrong Zou, Xinliang Liu, David Airlie,
	Daniel Vetter, dri-devel, Sam Ravnborg

Just wanted to resend this patch set so I didn't have to
continue carrying it forever to keep the HiKey960 board running.

This patchset contains one fix (in the front, so its easier to
eventually backport), and a series of changes from YiPing to
refactor the kirin drm driver so that it can be used on both
kirin620 based devices (like the original HiKey board) as well
as kirin960 based devices (like the HiKey960 board).

The full kirin960 drm support is still being refactored, but as
this base kirin rework was getting to be substantial, I wanted
to send out the first chunk, so that the review burden wasn't
overwhelming.

The full HiKey960 patch stack can be found here:
  https://git.linaro.org/people/john.stultz/android-dev.git/log/?h=dev/hikey960-mainline-WIP

thanks
-john

Cc: Rongrong Zou <zourongrong@gmail.com>
Cc: Xinliang Liu <z.liuxinliang@hisilicon.com>
Cc: David Airlie <airlied@linux.ie>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel <dri-devel@lists.freedesktop.org>
Cc: Sam Ravnborg <sam@ravnborg.org>

Da Lv (1):
  drm: kirin: Fix for hikey620 display offset problem

John Stultz (4):
  drm: kirin: Get rid of drmP.h includes
  drm: kirin: Remove HISI_KIRIN_DW_DSI config option
  drm: kirin: Remove unreachable return
  drm: kirin: Move workqueue to ade_hw_ctx structure

Xu YiPing (21):
  drm: kirin: Remove uncessary parameter indirection
  drm: kirin: Remove out_format from ade_crtc
  drm: kirin: Rename ade_plane to kirin_plane
  drm: kirin: Rename ade_crtc to kirin_crtc
  drm: kirin: Dynamically allocate the hw_ctx
  drm: kirin: Move request irq handle in ade hw ctx alloc
  drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to
    kirin_drm_drv.h
  drm: kirin: Reanme dc_ops to kirin_drm_data
  drm: kirin: Move ade crtc/plane help functions to driver_data
  drm: kirin: Move channel formats to driver data
  drm: kirin: Move mode config function to driver_data
  drm: kirin: Move plane number and primay plane in driver data
  drm: kirin: Move config max_width and max_height to driver data
  drm: kirin: Move drm driver to driver data
  drm: kirin: Add register connect helper functions in drm init
  drm: kirin: Rename plane_init and crtc_init
  drm: kirin: Fix dev->driver_data setting
  drm: kirin: Make driver_data variable non-global
  drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data
  drm: kirin: Pass driver data to crtc init and plane init
  drm: kirin: Move ade drm init to kirin drm drv

 drivers/gpu/drm/hisilicon/kirin/Kconfig       |  10 +-
 drivers/gpu/drm/hisilicon/kirin/Makefile      |   4 +-
 .../gpu/drm/hisilicon/kirin/kirin_ade_reg.h   |   1 +
 .../gpu/drm/hisilicon/kirin/kirin_drm_ade.c   | 360 +++++++-----------
 .../gpu/drm/hisilicon/kirin/kirin_drm_drv.c   | 257 +++++++++----
 .../gpu/drm/hisilicon/kirin/kirin_drm_drv.h   |  48 ++-
 6 files changed, 379 insertions(+), 301 deletions(-)

-- 
2.17.1


^ permalink raw reply	[flat|nested] 31+ messages in thread

end of thread, other threads:[~2019-08-19 23:25 UTC | newest]

Thread overview: 31+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-08-14 18:46 [RESEND][PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 01/26] drm: kirin: Fix for hikey620 display offset problem John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 02/26] drm: kirin: Get rid of drmP.h includes John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 03/26] drm: kirin: Remove HISI_KIRIN_DW_DSI config option John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 04/26] drm: kirin: Remove unreachable return John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 05/26] drm: kirin: Remove uncessary parameter indirection John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 06/26] drm: kirin: Remove out_format from ade_crtc John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 07/26] drm: kirin: Rename ade_plane to kirin_plane John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 08/26] drm: kirin: Rename ade_crtc to kirin_crtc John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 09/26] drm: kirin: Dynamically allocate the hw_ctx John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 10/26] drm: kirin: Move request irq handle in ade hw ctx alloc John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 11/26] drm: kirin: Move workqueue to ade_hw_ctx structure John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 12/26] drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to kirin_drm_drv.h John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 13/26] drm: kirin: Reanme dc_ops to kirin_drm_data John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 14/26] drm: kirin: Move ade crtc/plane help functions to driver_data John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 15/26] drm: kirin: Move channel formats to driver data John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 16/26] drm: kirin: Move mode config function to driver_data John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 17/26] drm: kirin: Move plane number and primay plane in driver data John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 18/26] drm: kirin: Move config max_width and max_height to " John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 19/26] drm: kirin: Move drm driver " John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 20/26] drm: kirin: Add register connect helper functions in drm init John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 21/26] drm: kirin: Rename plane_init and crtc_init John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 22/26] drm: kirin: Fix dev->driver_data setting John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 23/26] drm: kirin: Make driver_data variable non-global John Stultz
2019-08-14 18:47 ` [RESEND][PATCH v3 24/26] drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data John Stultz
2019-08-14 18:47 ` [RESEND][PATCH v3 25/26] drm: kirin: Pass driver data to crtc init and plane init John Stultz
2019-08-14 18:47 ` [RESEND][PATCH v3 26/26] drm: kirin: Move ade drm init to kirin drm drv John Stultz
2019-08-14 19:45 ` [RESEND][PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support Sam Ravnborg
2019-08-19  2:07   ` xinliang
2019-08-19  4:40     ` Sam Ravnborg
2019-08-19 23:25       ` John Stultz

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).