linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Joel Fernandes <joel@joelfernandes.org>
To: Christian Brauner <christian.brauner@ubuntu.com>
Cc: Todd Kjos <tkjos@android.com>,
	jannh@google.com, arve@android.com, christian@brauner.io,
	devel@driverdev.osuosl.org, gregkh@linuxfoundation.org,
	linux-kernel@vger.kernel.org, maco@android.com, tkjos@google.com,
	Hridya Valsaraju <hridya@google.com>
Subject: Re: [PATCH] binder: prevent UAF read in print_binder_transaction_log_entry()
Date: Wed, 9 Oct 2019 11:37:10 -0400	[thread overview]
Message-ID: <20191009153710.GC13654@google.com> (raw)
In-Reply-To: <20191009151044.t2jo3mo4acjtyhez@wittgenstein>

On Wed, Oct 09, 2019 at 05:10:45PM +0200, Christian Brauner wrote:
> On Wed, Oct 09, 2019 at 10:55:58AM -0400, Joel Fernandes wrote:
> > On Wed, Oct 09, 2019 at 04:29:11PM +0200, Christian Brauner wrote:
> > > On Wed, Oct 09, 2019 at 10:21:29AM -0400, Joel Fernandes wrote:
> > > > On Wed, Oct 09, 2019 at 12:40:12PM +0200, Christian Brauner wrote:
> > > > > On Tue, Oct 08, 2019 at 02:05:16PM -0400, Joel Fernandes wrote:
> > > > > > On Tue, Oct 08, 2019 at 03:01:59PM +0200, Christian Brauner wrote:
> > > > > > > When a binder transaction is initiated on a binder device coming from a
> > > > > > > binderfs instance, a pointer to the name of the binder device is stashed
> > > > > > > in the binder_transaction_log_entry's context_name member. Later on it
> > > > > > > is used to print the name in print_binder_transaction_log_entry(). By
> > > > > > > the time print_binder_transaction_log_entry() accesses context_name
> > > > > > > binderfs_evict_inode() might have already freed the associated memory
> > > > > > > thereby causing a UAF. Do the simple thing and prevent this by copying
> > > > > > > the name of the binder device instead of stashing a pointer to it.
> > > > > > > 
> > > > > > > Reported-by: Jann Horn <jannh@google.com>
> > > > > > > Fixes: 03e2e07e3814 ("binder: Make transaction_log available in binderfs")
> > > > > > > Link: https://lore.kernel.org/r/CAG48ez14Q0-F8LqsvcNbyR2o6gPW8SHXsm4u5jmD9MpsteM2Tw@mail.gmail.com
> > > > > > > Cc: Joel Fernandes <joel@joelfernandes.org>
> > > > > > > Cc: Todd Kjos <tkjos@android.com>
> > > > > > > Cc: Hridya Valsaraju <hridya@google.com>
> > > > > > > Signed-off-by: Christian Brauner <christian.brauner@ubuntu.com>
> > > > > > > ---
> > > > > > >  drivers/android/binder.c          | 4 +++-
> > > > > > >  drivers/android/binder_internal.h | 2 +-
> > > > > > >  2 files changed, 4 insertions(+), 2 deletions(-)
> > > > > > > 
> > > > > > > diff --git a/drivers/android/binder.c b/drivers/android/binder.c
> > > > > > > index c0a491277aca..5b9ac2122e89 100644
> > > > > > > --- a/drivers/android/binder.c
> > > > > > > +++ b/drivers/android/binder.c
> > > > > > > @@ -57,6 +57,7 @@
> > > > > > >  #include <linux/sched/signal.h>
> > > > > > >  #include <linux/sched/mm.h>
> > > > > > >  #include <linux/seq_file.h>
> > > > > > > +#include <linux/string.h>
> > > > > > >  #include <linux/uaccess.h>
> > > > > > >  #include <linux/pid_namespace.h>
> > > > > > >  #include <linux/security.h>
> > > > > > > @@ -66,6 +67,7 @@
> > > > > > >  #include <linux/task_work.h>
> > > > > > >  
> > > > > > >  #include <uapi/linux/android/binder.h>
> > > > > > > +#include <uapi/linux/android/binderfs.h>
> > > > > > >  
> > > > > > >  #include <asm/cacheflush.h>
> > > > > > >  
> > > > > > > @@ -2876,7 +2878,7 @@ static void binder_transaction(struct binder_proc *proc,
> > > > > > >  	e->target_handle = tr->target.handle;
> > > > > > >  	e->data_size = tr->data_size;
> > > > > > >  	e->offsets_size = tr->offsets_size;
> > > > > > > -	e->context_name = proc->context->name;
> > > > > > > +	strscpy(e->context_name, proc->context->name, BINDERFS_MAX_NAME);
> > > > > > 
> > > > > > Strictly speaking, proc-context->name can also be initialized for !BINDERFS
> > > > > > so the BINDERFS in the MAX_NAME macro is misleading. So probably there should
> > > > > > be a BINDER_MAX_NAME (and associated checks for whether non BINDERFS names
> > > > > > fit within the MAX.
> > > > > 
> > > > > I know but I don't think it's worth special-casing non-binderfs devices.
> > > > > First, non-binderfs devices can only be created through a KCONFIG option
> > > > > determined at compile time. For stock Android the names are the same for
> > > > > all vendors afaik.
> > > > 
> > > > I am just talking about the name of weirdly named macro here.
> > > 
> > > You might miss context here: It's named that way because currently only
> > > binderfs binder devices are bound to that limit. That's a point I made
> > > further below in my previous mail. Non-binderfs devices are not subject
> > > to that restriction and when we tried to make them subject to the same
> > > it as rejected.
> > 
> > I know that. I am saying the memcpy is happening for regular binder devices
> > as well but the macro has BINDERFS in the name. That's all. It is not a
> > significant eye sore. But is a bit odd.
> 
> Right, and I told you that we _can't_ rename it to BINDER_MAX because
> that check only happens for binderfs devices since you were suggesting
> this. If you want to rename to get rid of the this being somehow
> apparently odd then you need to introduce that check for non-binderfs
> devices too. Or just rename the macro in a follow-up patch. I don't care.

Here in this patch we are doing mem copy for regular binder device name using
a BINDERFS macro name.

> > 
> > > <snip>
> > > 
> > > > 
> > > > > Fifth, I already tried to push for validation of non-binderfs binder
> > > > > devices a while back when I wrote binderfs and was told that it's not
> > > > > needed. Hrydia tried the same and we decided the same thing. So you get
> > > > > to be the next person to send a patch. :)
> > > > 
> > > > I don't follow why we are talking about non-binderfs validation. I am just
> > > 
> > > Because above you said
> > > 
> > > > > > so the BINDERFS in the MAX_NAME macro is misleading. So probably there should
> > > > > > be a BINDER_MAX_NAME (and associated checks for whether non BINDERFS names
> > > > > > fit within the MAX.
> > > 
> > > which to me reads like you want generic checks for _all_ binder devices
> > > not just for the ones from binderfs.
> > 
> > No I am not talking about the checks at all, I am talking about the unwanted
> > mem copy you are doing for regular binder devices now. Before binderfs this
> > would not have happened, but now for regular binder devices we have to do the
> > extra mem copies which were avoided before. That was what I was talking about.
> 
> I'm sorry but I did not get this at all from:
> "So probably there should be a BINDER_MAX_NAME (and associated checks
> for whether non BINDERFS names fit within the MAX." 

Sorry for the misleading statement. That means I have to improve my
communication game, sorry it is my fault.

> > 
> > But this discussing is getting to bike shedding at this point, and since the
> > overhead is likely small, I am Ok with the change (though I don't like very
> > much the additional memcpy and the associated space wastage in the
> > transaction buffer for regular binder devices).
> 
> Feel free to send a follow-up patch handling both separately.

Ok will do once I get a chance. Thanks for working on the fix!

-  Joel


  reply	other threads:[~2019-10-09 15:37 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-10-07 20:49 UAF read in print_binder_transaction_log_entry() on ANDROID_BINDERFS kernels Jann Horn
2019-10-07 21:04 ` Todd Kjos
2019-10-07 21:16   ` Hridya Valsaraju
2019-10-07 21:05 ` Christian Brauner
2019-10-08 13:01 ` [PATCH] binder: prevent UAF read in print_binder_transaction_log_entry() Christian Brauner
2019-10-08 17:18   ` Hridya Valsaraju
2019-10-08 18:05   ` Joel Fernandes
2019-10-09 10:40     ` Christian Brauner
2019-10-09 14:21       ` Joel Fernandes
2019-10-09 14:29         ` Christian Brauner
2019-10-09 14:55           ` Joel Fernandes
2019-10-09 15:10             ` Christian Brauner
2019-10-09 15:37               ` Joel Fernandes [this message]
2019-10-09 15:56       ` Todd Kjos
2019-10-08 18:52   ` Todd Kjos

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191009153710.GC13654@google.com \
    --to=joel@joelfernandes.org \
    --cc=arve@android.com \
    --cc=christian.brauner@ubuntu.com \
    --cc=christian@brauner.io \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hridya@google.com \
    --cc=jannh@google.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maco@android.com \
    --cc=tkjos@android.com \
    --cc=tkjos@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).