linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: Borislav Petkov <bp@alien8.de>
Cc: Thomas Gleixner <tglx@linutronix.de>,
	LKML <linux-kernel@vger.kernel.org>,
	x86@kernel.org, Brian Gerst <brgerst@gmail.com>,
	Juergen Gross <jgross@suse.com>,
	Frederic Weisbecker <frederic@kernel.org>,
	Alexandre Chartre <alexandre.chartre@oracle.com>
Subject: Re: [patch part-II V2 09/13] x86/entry/common: Split hardirq tracing into lockdep and ftrace parts
Date: Tue, 10 Mar 2020 09:40:58 -0400	[thread overview]
Message-ID: <20200310094058.1239cf2f@gandalf.local.home> (raw)
In-Reply-To: <20200310112045.GD29372@zn.tnic>

On Tue, 10 Mar 2020 12:20:45 +0100
Borislav Petkov <bp@alien8.de> wrote:

> > +
> > +	/*
> > +	 * Tell the tracer about the irq state as well before enabling
> > +	 * interrupts.
> > +	 */
> > +	__trace_hardirqs_off();  
> 
> I wonder if those "__" variants should be named something else to
> denote better the difference between __trace_hardirqs_{on,off} and
> trace_hardirqs_{on,off}. Latter does the _rcuidle variant and lockdep
> annotation but
> 
> 	trace_hardirqs_{on,off}_rcuidle_lockdep()
> 
> sounds yuck.
> 
> Maybe lockdep_trace_hardirqs_{on,off}()...
> 
> Blergh, I can't think of a good name ATM.

Kernel developers are not good at naming ;-) This is one of the original
pieces of code that came in with the original addition of tracing, where we
had the "Ingo notation" of something like:

  trace() {
	[..]
	_trace();
	[..]
  }

  _trace() {
	[..]
	__trace();
	[..]
  }

  __trace() {
	[..]
	___trace();
	[..]
  }

  ___trace() {
	[..]
	____trace();
	[..]
  }

  ____trace() {
	[..]
	_____trace();
	[..]
  }

  _____trace() {
	[..]
  }

-- Steve

  reply	other threads:[~2020-03-10 13:41 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-08 22:23 [patch part-II V2 00/13] x86/entry: Consolidation - Part II (syscalls) Thomas Gleixner
2020-03-08 22:24 ` [patch part-II V2 01/13] context_tracking: Ensure that the critical path cannot be instrumented Thomas Gleixner
2020-03-09 14:22   ` Frederic Weisbecker
2020-03-09 14:40     ` Thomas Gleixner
2020-03-10 10:12   ` Alexandre Chartre
2020-03-08 22:24 ` [patch part-II V2 02/13] x86/entry: Mark enter_from_user_mode() notrace and NOKPROBE Thomas Gleixner
2020-03-09 15:14   ` Frederic Weisbecker
2020-03-09 15:40     ` Thomas Gleixner
2020-03-11 22:21       ` Frederic Weisbecker
2020-03-10 10:15   ` Alexandre Chartre
2020-03-08 22:24 ` [patch part-II V2 03/13] x86/entry/32: Remove unused label restore_nocheck Thomas Gleixner
2020-03-10 10:16   ` Alexandre Chartre
2020-03-10 13:02   ` [tip: x86/entry] " tip-bot2 for Thomas Gleixner
2020-03-08 22:24 ` [patch part-II V2 04/13] x86/entry/64: Trace irqflags unconditionally as ON when returning to user space Thomas Gleixner
2020-03-10 10:25   ` Alexandre Chartre
2020-03-10 13:02   ` [tip: x86/entry] " tip-bot2 for Thomas Gleixner
2020-03-08 22:24 ` [patch part-II V2 05/13] x86/entry/common: Consolidate syscall entry code Thomas Gleixner
2020-03-08 22:24 ` [patch part-II V2 06/13] x86/entry/common: Mark syscall entry points notrace and NOKPROBE Thomas Gleixner
2020-03-13 15:12   ` Frederic Weisbecker
2020-03-08 22:24 ` [patch part-II V2 07/13] x86/entry: Move irq tracing on syscall entry to C-code Thomas Gleixner
2020-03-13 15:16   ` Frederic Weisbecker
2020-03-13 23:17     ` Thomas Gleixner
2020-03-08 22:24 ` [patch part-II V2 08/13] tracing: Provide lockdep less trace_hardirqs_on/off() variants Thomas Gleixner
2020-03-10 10:55   ` Alexandre Chartre
2020-03-10 11:08     ` Borislav Petkov
2020-03-10 11:21       ` Alexandre Chartre
2020-03-08 22:24 ` [patch part-II V2 09/13] x86/entry/common: Split hardirq tracing into lockdep and ftrace parts Thomas Gleixner
2020-03-10 11:20   ` Borislav Petkov
2020-03-10 13:40     ` Steven Rostedt [this message]
2020-03-10 13:28   ` Alexandre Chartre
2020-03-23  9:08   ` [x86/entry/common] bae397f6e7: WARNING:at_kernel/sched/cputime.c:#get_vtime_delta kernel test robot
2020-03-08 22:24 ` [patch part-II V2 10/13] x86/entry/common: Split prepare_exit_to_usermode() and syscall_return_slowpath() Thomas Gleixner
2020-03-10 13:37   ` Alexandre Chartre
2020-03-08 22:24 ` [patch part-II V2 11/13] x86/speculation/mds: Mark mds_user_clear_cpu_buffers() __always_inline Thomas Gleixner
2020-03-10 13:48   ` Alexandre Chartre
2020-03-10 16:38     ` Thomas Gleixner
2020-03-08 22:24 ` [patch part-II V2 12/13] x86/entry: Move irq flags tracing to prepare_exit_to_usermode() Thomas Gleixner
2020-03-10 14:03   ` Alexandre Chartre
2020-03-08 22:24 ` [patch part-II V2 13/13] x86/entry/common: Split irq tracing in prepare_exit_to_usermode() Thomas Gleixner
2020-03-10 14:09   ` Alexandre Chartre

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200310094058.1239cf2f@gandalf.local.home \
    --to=rostedt@goodmis.org \
    --cc=alexandre.chartre@oracle.com \
    --cc=bp@alien8.de \
    --cc=brgerst@gmail.com \
    --cc=frederic@kernel.org \
    --cc=jgross@suse.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).