linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Wei Yang <richard.weiyang@gmail.com>
To: Wei Yang <richard.weiyang@gmail.com>
Cc: David Hildenbrand <david@redhat.com>,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	linuxppc-dev@lists.ozlabs.org, linux-hyperv@vger.kernel.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Michal Hocko <mhocko@kernel.org>,
	Oscar Salvador <osalvador@suse.de>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Baoquan He <bhe@redhat.com>
Subject: Re: [PATCH v1 3/5] drivers/base/memory: store mapping between MMOP_* and string in an array
Date: Wed, 11 Mar 2020 14:27:40 +0000	[thread overview]
Message-ID: <20200311142740.qh5it3lfaoyqzr6i@master> (raw)
In-Reply-To: <20200311142002.2htiv4llyam2svta@master>

On Wed, Mar 11, 2020 at 02:20:02PM +0000, Wei Yang wrote:
>On Wed, Mar 11, 2020 at 01:30:24PM +0100, David Hildenbrand wrote:
>>Let's use a simple array which we can reuse soon. While at it, move the
>>string->mmop conversion out of the device hotplug lock.
>>
>>Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
>>Cc: Andrew Morton <akpm@linux-foundation.org>
>>Cc: Michal Hocko <mhocko@kernel.org>
>>Cc: Oscar Salvador <osalvador@suse.de>
>>Cc: "Rafael J. Wysocki" <rafael@kernel.org>
>>Cc: Baoquan He <bhe@redhat.com>
>>Cc: Wei Yang <richard.weiyang@gmail.com>
>>Signed-off-by: David Hildenbrand <david@redhat.com>

Ok, I got the reason.

Reviewed-by: Wei Yang <richard.weiyang@gmail.com>

>>---
>> drivers/base/memory.c | 38 +++++++++++++++++++++++---------------
>> 1 file changed, 23 insertions(+), 15 deletions(-)
>>
>>diff --git a/drivers/base/memory.c b/drivers/base/memory.c
>>index e7e77cafef80..8a7f29c0bf97 100644
>>--- a/drivers/base/memory.c
>>+++ b/drivers/base/memory.c
>>@@ -28,6 +28,24 @@
>> 
>> #define MEMORY_CLASS_NAME	"memory"
>> 
>>+static const char *const online_type_to_str[] = {
>>+	[MMOP_OFFLINE] = "offline",
>>+	[MMOP_ONLINE] = "online",
>>+	[MMOP_ONLINE_KERNEL] = "online_kernel",
>>+	[MMOP_ONLINE_MOVABLE] = "online_movable",
>>+};
>>+
>>+static int memhp_online_type_from_str(const char *str)
>>+{
>>+	int i;
>>+
>>+	for (i = 0; i < ARRAY_SIZE(online_type_to_str); i++) {
>>+		if (sysfs_streq(str, online_type_to_str[i]))
>>+			return i;
>>+	}
>>+	return -EINVAL;
>>+}
>>+
>> #define to_memory_block(dev) container_of(dev, struct memory_block, dev)
>> 
>> static int sections_per_block;
>>@@ -236,26 +254,17 @@ static int memory_subsys_offline(struct device *dev)
>> static ssize_t state_store(struct device *dev, struct device_attribute *attr,
>> 			   const char *buf, size_t count)
>> {
>>+	const int online_type = memhp_online_type_from_str(buf);
>
>In your following patch, you did the same conversion. Is it possible to merge
>them into this one?
>
>> 	struct memory_block *mem = to_memory_block(dev);
>>-	int ret, online_type;
>>+	int ret;
>>+
>>+	if (online_type < 0)
>>+		return -EINVAL;
>> 
>> 	ret = lock_device_hotplug_sysfs();
>> 	if (ret)
>> 		return ret;
>> 
>>-	if (sysfs_streq(buf, "online_kernel"))
>>-		online_type = MMOP_ONLINE_KERNEL;
>>-	else if (sysfs_streq(buf, "online_movable"))
>>-		online_type = MMOP_ONLINE_MOVABLE;
>>-	else if (sysfs_streq(buf, "online"))
>>-		online_type = MMOP_ONLINE;
>>-	else if (sysfs_streq(buf, "offline"))
>>-		online_type = MMOP_OFFLINE;
>>-	else {
>>-		ret = -EINVAL;
>>-		goto err;
>>-	}
>>-
>> 	switch (online_type) {
>> 	case MMOP_ONLINE_KERNEL:
>> 	case MMOP_ONLINE_MOVABLE:
>>@@ -271,7 +280,6 @@ static ssize_t state_store(struct device *dev, struct device_attribute *attr,
>> 		ret = -EINVAL; /* should never happen */
>> 	}
>> 
>>-err:
>> 	unlock_device_hotplug();
>> 
>> 	if (ret < 0)
>>-- 
>>2.24.1
>
>-- 
>Wei Yang
>Help you, Help me

-- 
Wei Yang
Help you, Help me

  reply	other threads:[~2020-03-11 14:29 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-11 12:30 [PATCH v1 0/5] mm/memory_hotplug: allow to specify a default online_type David Hildenbrand
2020-03-11 12:30 ` [PATCH v1 1/5] drivers/base/memory: rename MMOP_ONLINE_KEEP to MMOP_ONLINE David Hildenbrand
2020-03-11 14:17   ` Wei Yang
2020-03-16 15:12   ` Michal Hocko
2020-03-16 15:17     ` David Hildenbrand
2020-03-11 12:30 ` [PATCH v1 2/5] drivers/base/memory: map MMOP_OFFLINE to 0 David Hildenbrand
2020-03-11 14:18   ` Wei Yang
2020-03-16 15:19   ` Michal Hocko
2020-03-11 12:30 ` [PATCH v1 3/5] drivers/base/memory: store mapping between MMOP_* and string in an array David Hildenbrand
2020-03-11 14:20   ` Wei Yang
2020-03-11 14:27     ` Wei Yang [this message]
2020-03-16 15:20   ` Michal Hocko
2020-03-11 12:30 ` [PATCH v1 4/5] mm/memory_hotplug: convert memhp_auto_online to store an online_type David Hildenbrand
2020-03-11 14:25   ` Wei Yang
2020-03-16 15:24   ` Michal Hocko
2020-03-16 15:34     ` David Hildenbrand
2020-03-16 15:46       ` Michal Hocko
2020-03-11 12:30 ` [PATCH v1 5/5] mm/memory_hotplug: allow to specify a default online_type David Hildenbrand
2020-03-11 14:26   ` Wei Yang
2020-03-11 15:20     ` David Hildenbrand
2020-03-11 16:55   ` Vitaly Kuznetsov
2020-03-11 17:05     ` David Hildenbrand
2020-03-16 15:31   ` Michal Hocko
2020-03-16 15:48     ` David Hildenbrand

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200311142740.qh5it3lfaoyqzr6i@master \
    --to=richard.weiyang@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=bhe@redhat.com \
    --cc=david@redhat.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-hyperv@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mhocko@kernel.org \
    --cc=osalvador@suse.de \
    --cc=rafael@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).