linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ira Weiny <ira.weiny@intel.com>
To: Dave Chinner <david@fromorbit.com>
Cc: "Darrick J. Wong" <darrick.wong@oracle.com>,
	linux-kernel@vger.kernel.org, linux-xfs@vger.kernel.org,
	Al Viro <viro@zeniv.linux.org.uk>, Jan Kara <jack@suse.cz>,
	Dan Williams <dan.j.williams@intel.com>,
	Christoph Hellwig <hch@lst.de>,
	"Theodore Y. Ts'o" <tytso@mit.edu>,
	Jeff Moyer <jmoyer@redhat.com>,
	linux-ext4@vger.kernel.org, linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH V9 10/11] fs/xfs: Update xfs_ioctl_setattr_dax_invalidate()
Date: Tue, 21 Apr 2020 16:24:59 -0700	[thread overview]
Message-ID: <20200421232459.GF3372712@iweiny-DESK2.sc.intel.com> (raw)
In-Reply-To: <20200421231343.GD27860@dread.disaster.area>

On Wed, Apr 22, 2020 at 09:13:43AM +1000, Dave Chinner wrote:
> On Tue, Apr 21, 2020 at 02:43:29PM -0700, Ira Weiny wrote:
> > On Wed, Apr 22, 2020 at 07:30:49AM +1000, Dave Chinner wrote:
> > > On Tue, Apr 21, 2020 at 01:31:40PM -0700, Darrick J. Wong wrote:
> > > > On Tue, Apr 21, 2020 at 12:17:52PM -0700, ira.weiny@intel.com wrote:
> > > > > From: Ira Weiny <ira.weiny@intel.com>

[snip]

> > > > 
> > > > That's a ... strange name.  Set cache on what?
> > > > 
> > > > Oh, this is the function that sets I_DONTCACHE if an FS_XFLAG_DAX change
> > > > could have an immediate effect on S_DAX (assuming no other users).  What
> > > > do you think of the following?
> > > > 
> > > > 	/*
> > > > 	 * If a change to FS_XFLAG_DAX will result in an change to S_DAX
> > > > 	 * the next time the incore inode is initialized, set the VFS
> > > > 	 * I_DONTCACHE flag to try to hurry that along.
> > > > 	 */
> > > > 	static void
> > > > 	xfs_ioctl_try_change_vfs_dax(...)
> > > 
> > > That doesn't seem any better. This is a preparation function now, in
> > > that it can't fail and doesn't change the outcome of the operation
> > > being performed. So, IMO, calling it something like
> > > xfs_ioctl_setattr_prepare_dax() would be a better name for it.
> > 
> > But it does potentially (after a check) set I_DONTCACHE.
> 
> That is an implementation detail - it doesn't change the outcome of
> the function, the current behaviour of the inode, or the result of
> the ioctl....

I'm confused.  This function does potentially flag the inode to not be cached.
How is that not changing the behavior of the inode?

> 
> > What about?
> > 
> > xfs_ioctl_dax_check_set_dontcache()?
> 
> Then we have to rename it again the moment we change it's
> functionality. i.e. we have exactly the same problem we have now
> where the function name describes the implementation, not the
> operational reason the function is being called...

Ok, I see what you are driving at.  You want this function to potentially do
other things and it should 'prepare' the inode for 'dax stuff'.  Is that about
it?

I'm ok with xfs_ioctl_setattr_prepare_dax() then.

Ira

> 
> Cheers,
> 
> Dave.
> -- 
> Dave Chinner
> david@fromorbit.com

  reply	other threads:[~2020-04-21 23:25 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-21 19:17 [PATCH V9 00/11] XFS - Enable per-file/per-directory DAX operations V9 ira.weiny
2020-04-21 19:17 ` [PATCH V9 01/11] fs/xfs: Remove unnecessary initialization of i_rwsem ira.weiny
2020-04-21 19:17 ` [PATCH V9 02/11] fs: Remove unneeded IS_DAX() check in io_is_direct() ira.weiny
2020-04-21 20:13   ` Darrick J. Wong
2020-04-22  8:37   ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 03/11] fs/stat: Define DAX statx attribute ira.weiny
2020-04-22 16:29   ` Darrick J. Wong
2020-04-22 18:51     ` Ira Weiny
2020-04-23  8:24       ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 04/11] fs/xfs: Change XFS_MOUNT_DAX to XFS_MOUNT_DAX_ALWAYS ira.weiny
2020-04-21 19:17 ` [PATCH V9 05/11] fs/xfs: Make DAX mount option a tri-state ira.weiny
2020-04-21 20:16   ` Darrick J. Wong
2020-04-21 21:06     ` Ira Weiny
2020-04-21 19:17 ` [PATCH V9 06/11] fs/xfs: Create function xfs_inode_should_enable_dax() ira.weiny
2020-04-21 19:17 ` [PATCH V9 07/11] fs/xfs: Combine xfs_diflags_to_linux() and xfs_diflags_to_iflags() ira.weiny
2020-04-21 19:17 ` [PATCH V9 08/11] fs: Lift XFS_IDONTCACNE to the VFS layer ira.weiny
2020-04-21 20:23   ` Darrick J. Wong
2020-04-21 21:12     ` Ira Weiny
2020-04-22  8:41   ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 09/11] fs: Introduce DCACHE_DONTCACHE ira.weiny
2020-04-21 20:25   ` Darrick J. Wong
2020-04-21 21:15     ` Ira Weiny
2020-04-22  2:34     ` Al Viro
2020-04-22  3:46       ` Ira Weiny
2020-04-22  8:46   ` Jan Kara
2020-04-22 15:19     ` Ira Weiny
2020-04-21 19:17 ` [PATCH V9 10/11] fs/xfs: Update xfs_ioctl_setattr_dax_invalidate() ira.weiny
2020-04-21 20:31   ` Darrick J. Wong
2020-04-21 21:30     ` Dave Chinner
2020-04-21 21:43       ` Ira Weiny
2020-04-21 23:13         ` Dave Chinner
2020-04-21 23:24           ` Ira Weiny [this message]
2020-04-21 19:17 ` [PATCH V9 11/11] Documentation/dax: Update Usage section ira.weiny
2020-04-21 20:34   ` Darrick J. Wong
2020-04-21 21:49     ` Ira Weiny
2020-04-22  9:47   ` Jan Kara

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200421232459.GF3372712@iweiny-DESK2.sc.intel.com \
    --to=ira.weiny@intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=hch@lst.de \
    --cc=jack@suse.cz \
    --cc=jmoyer@redhat.com \
    --cc=linux-ext4@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=tytso@mit.edu \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).