linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: x86@kernel.org, linux-kernel@vger.kernel.org,
	rostedt@goodmis.org, mhiramat@kernel.org, bristot@redhat.com,
	jbaron@akamai.com, torvalds@linux-foundation.org,
	tglx@linutronix.de, mingo@kernel.org, namit@vmware.com,
	hpa@zytor.com, luto@kernel.org, ard.biesheuvel@linaro.org,
	pbonzini@redhat.com, mathieu.desnoyers@efficios.com
Subject: Re: [PATCH v4 14/18] static_call: Add static_cond_call()
Date: Wed, 6 May 2020 19:58:52 +0200	[thread overview]
Message-ID: <20200506175852.GW3762@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <20200506172455.ho5em2mtzn7qqfjl@treble>

On Wed, May 06, 2020 at 12:24:55PM -0500, Josh Poimboeuf wrote:
> On Fri, May 01, 2020 at 10:29:03PM +0200, Peter Zijlstra wrote:
> > +++ b/arch/x86/include/asm/static_call.h
> > @@ -30,4 +30,14 @@
> >  	    ".size " STATIC_CALL_TRAMP_STR(name) ", . - " STATIC_CALL_TRAMP_STR(name) " \n" \
> >  	    ".popsection					\n")
> >  
> > +#define ARCH_DEFINE_STATIC_CALL_RETTRAMP(name)				\
> > +	asm(".pushsection .static_call.text, \"ax\"		\n"	\
> > +	    ".align 4						\n"	\
> > +	    ".globl " STATIC_CALL_TRAMP_STR(name) "		\n"	\
> > +	    STATIC_CALL_TRAMP_STR(name) ":			\n"	\
> > +	    "	ret; nop; nop; nop; nop;			\n"	\
> > +	    ".type " STATIC_CALL_TRAMP_STR(name) ", @function	\n"	\
> > +	    ".size " STATIC_CALL_TRAMP_STR(name) ", . - " STATIC_CALL_TRAMP_STR(name) " \n" \
> > +	    ".popsection					\n")
> > +
> 
> The boilerplate in these two trampoline macros is identical except for
> the actual instructions, maybe there could be a shared
> __ARCH_DEFINE_STATIC_CALL_TRAMP(name, insns) macro which does most of
> the dirty work.

I'm afraid that'll just make it less readable :/

> >  #endif /* _ASM_STATIC_CALL_H */
> > --- a/arch/x86/kernel/static_call.c
> > +++ b/arch/x86/kernel/static_call.c
> > @@ -4,19 +4,41 @@
> >  #include <linux/bug.h>
> >  #include <asm/text-patching.h>
> >  
> > -static void __static_call_transform(void *insn, u8 opcode, void *func)
> > +enum insn_type {
> > +	call = 0, /* site call */
> > +	nop = 1,  /* site cond-call */
> > +	jmp = 2,  /* tramp / site tail-call */
> > +	ret = 3,  /* tramp / site cond-tail-call */
> > +};
> 
> The lowercase enums threw me for a loop, I thought they were variables a
> few times.  Starting a new enum trend? :-)

I can UPPERCASE them I suppose, not sure where this came from.

> >  void arch_static_call_transform(void *site, void *tramp, void *func)
> > @@ -24,10 +46,10 @@ void arch_static_call_transform(void *si
> >  	mutex_lock(&text_mutex);
> >  
> >  	if (tramp)
> > -		__static_call_transform(tramp, JMP32_INSN_OPCODE, func);
> > +		__static_call_transform(tramp, jmp + !func, func);
> >  
> >  	if (IS_ENABLED(CONFIG_HAVE_STATIC_CALL_INLINE) && site)
> > -		__static_call_transform(site, CALL_INSN_OPCODE, func);
> > +		__static_call_transform(site, !func, func);
> 
> Clever enum math, but probably more robust to be ignorant of the values:
> 
> 	if (tramp)
> 		__static_call_transform(tramp, func ? jmp : ret, func);
> 
>   	if (IS_ENABLED(CONFIG_HAVE_STATIC_CALL_INLINE) && site)
> 		__static_call_transform(site, func ? call : nop, func);
> 

That is more readable, and I checked, GCC is clever enough to not
actually emit branches for that, so w00t.

> > +++ b/include/linux/static_call.h
> > @@ -16,7 +16,9 @@
> >   *
> >   *   DECLARE_STATIC_CALL(name, func);
> >   *   DEFINE_STATIC_CALL(name, func);
> > + *   DEFINE_STATIC_COND_CALL(name, typename);
> >   *   static_call(name)(args...);
> > + *   static_cond_call(name)(args...)
> >   *   static_call_update(name, func);
> 
> Missing semicolon, also an updated description/example would be useful.

Yes, I already promised Rasmus more documentation.

> On that note, what do you think about tweaking the naming from
> 
>   DEFINE_STATIC_COND_CALL(name, typename);
>   static_cond_call(name)(args...);
> 
> to
> 
>   DEFINE_STATIC_CALL_NO_FUNC(name, typename);
>   static_call_if_func(name)(args...);
> 
> ?
> 
> Seems clearer to me.  They're still STATIC_CALLs, so it seems logical to
> keep those two words together.  And NO_FUNC clarifies the initialized
> value.
> 
> Similarly RETTRAMP could be ARCH_DEFINE_STATIC_CALL_NO_FUNC.

What can I say, I'm sorta used to the old naming by now, but sure, any
other opinions before I edit things?

  reply	other threads:[~2020-05-06 17:59 UTC|newest]

Thread overview: 60+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-01 20:28 [PATCH v4 00/18] Add static_call() Peter Zijlstra
2020-05-01 20:28 ` [PATCH v4 01/18] notifier: Fix broken error handling pattern Peter Zijlstra
2020-05-01 23:35   ` Steven Rostedt
2020-05-01 20:28 ` [PATCH v4 02/18] module: Fix up module_notifier return values Peter Zijlstra
2020-05-01 20:28 ` [PATCH v4 03/18] module: Properly propagate MODULE_STATE_COMING failure Peter Zijlstra
2020-05-01 20:28 ` [PATCH v4 04/18] jump_label,module: Fix module lifetime for __jump_label_mod_text_reserved Peter Zijlstra
2020-05-01 20:28 ` [PATCH v4 05/18] compiler.h: Make __ADDRESSABLE() symbol truly unique Peter Zijlstra
2020-05-01 20:28 ` [PATCH v4 06/18] static_call: Add basic static call infrastructure Peter Zijlstra
2020-05-05 21:21   ` Josh Poimboeuf
2020-05-01 20:28 ` [PATCH v4 07/18] static_call: Add inline " Peter Zijlstra
2020-05-05 22:10   ` Josh Poimboeuf
2020-05-06 16:15     ` Peter Zijlstra
2020-05-01 20:28 ` [PATCH v4 08/18] static_call: Avoid kprobes on inline static_call()s Peter Zijlstra
2020-05-01 20:28 ` [PATCH v4 09/18] x86/static_call: Add out-of-line static call implementation Peter Zijlstra
2020-05-06 16:16   ` Peter Zijlstra
2020-05-01 20:28 ` [PATCH v4 10/18] x86/static_call: Add inline static call implementation for x86-64 Peter Zijlstra
2020-05-01 20:29 ` [PATCH v4 11/18] static_call: Simple self-test Peter Zijlstra
2020-05-01 20:29 ` [PATCH v4 12/18] tracepoint: Optimize using static_call() Peter Zijlstra
2020-05-13  8:48   ` [tracepoint] 01edfaf177: WARNING:at_kernel/static_call.c:#__static_call_update kernel test robot
2020-05-15 17:13     ` Peter Zijlstra
2020-05-01 20:29 ` [PATCH v4 13/18] x86/alternatives: Teach text_poke_bp() to emulate RET Peter Zijlstra
2020-05-01 20:29 ` [PATCH v4 14/18] static_call: Add static_cond_call() Peter Zijlstra
2020-05-02 13:08   ` Rasmus Villemoes
2020-05-03 12:58     ` Peter Zijlstra
2020-05-04  7:20       ` Rasmus Villemoes
2020-05-04 20:14         ` Peter Zijlstra
2020-05-05  7:50           ` Rasmus Villemoes
2020-05-05  9:38             ` Peter Zijlstra
2020-05-05  9:36           ` Peter Zijlstra
2020-05-05 18:13             ` Nick Desaulniers
2020-05-05 18:27               ` Nick Desaulniers
2020-05-05 18:48                 ` Linus Torvalds
2020-05-05 19:00                   ` Mathieu Desnoyers
2020-05-05 19:57                     ` Nick Desaulniers
2020-05-05 20:27                       ` Mathieu Desnoyers
2020-05-06 13:55                         ` Peter Zijlstra
2020-05-06 14:01                           ` Mathieu Desnoyers
2020-05-06 16:18                             ` Peter Zijlstra
2020-05-06 13:51               ` Peter Zijlstra
2020-05-06 16:00                 ` Peter Zijlstra
2020-05-06 17:16                 ` Linus Torvalds
2020-05-06 19:57                   ` Andy Lutomirski
2020-05-06 17:24   ` Josh Poimboeuf
2020-05-06 17:58     ` Peter Zijlstra [this message]
2020-05-06 18:09       ` Josh Poimboeuf
2020-05-06 18:16         ` Peter Zijlstra
2020-05-08 15:27     ` Peter Zijlstra
2020-05-08 15:47       ` Josh Poimboeuf
2020-05-08 16:17         ` Peter Zijlstra
2020-05-01 20:29 ` [PATCH v4 15/18] static_call: Handle tail-calls Peter Zijlstra
2020-05-06 18:10   ` Peter Zijlstra
2020-05-01 20:29 ` [PATCH v4 16/18] static_call: Allow early init Peter Zijlstra
2020-05-06 21:15   ` Josh Poimboeuf
2020-05-08 13:31     ` Peter Zijlstra
2020-05-08 14:27       ` Josh Poimboeuf
2020-05-08 15:30         ` Peter Zijlstra
2020-05-01 20:29 ` [PATCH v4 17/18] x86/perf, static_call: Optimize x86_pmu methods Peter Zijlstra
2020-05-01 20:29 ` [PATCH v4 18/18] objtool: Clean up elf_write() condition Peter Zijlstra
2020-05-06 17:32 ` [PATCH v4 00/18] Add static_call() Josh Poimboeuf
2020-05-06 18:05   ` Peter Zijlstra

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200506175852.GW3762@hirez.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=ard.biesheuvel@linaro.org \
    --cc=bristot@redhat.com \
    --cc=hpa@zytor.com \
    --cc=jbaron@akamai.com \
    --cc=jpoimboe@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@kernel.org \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=mhiramat@kernel.org \
    --cc=mingo@kernel.org \
    --cc=namit@vmware.com \
    --cc=pbonzini@redhat.com \
    --cc=rostedt@goodmis.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).