linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jiri Olsa <jolsa@redhat.com>
To: Ian Rogers <irogers@google.com>
Cc: Jiri Olsa <jolsa@kernel.org>,
	Arnaldo Carvalho de Melo <acme@kernel.org>,
	lkml <linux-kernel@vger.kernel.org>,
	Ingo Molnar <mingo@kernel.org>,
	Namhyung Kim <namhyung@kernel.org>,
	Alexander Shishkin <alexander.shishkin@linux.intel.com>,
	Peter Zijlstra <a.p.zijlstra@chello.nl>,
	Michael Petlan <mpetlan@redhat.com>,
	Andi Kleen <ak@linux.intel.com>, Kajol Jain <kjain@linux.ibm.com>,
	John Garry <john.garry@huawei.com>,
	"Paul A. Clarke" <pc@us.ibm.com>,
	Stephane Eranian <eranian@google.com>
Subject: Re: [PATCH 06/10] perf tools: Collect other metrics in struct egroup
Date: Mon, 29 Jun 2020 00:06:01 +0200	[thread overview]
Message-ID: <20200628220601.GR2988321@krava> (raw)
In-Reply-To: <CAP-5=fWJGGPCx4Rk_5UXLjDjQ3fLzzPO-gnRtPGV2GWoNLzL=w@mail.gmail.com>

On Fri, Jun 26, 2020 at 02:48:02PM -0700, Ian Rogers wrote:
> On Fri, Jun 26, 2020 at 12:47 PM Jiri Olsa <jolsa@kernel.org> wrote:
> >
> > Collecting other metrics in struct egroup object,
> > so we can process them later on.
> >
> > The change will parse or 'other' metric names out of
> > expression and 'resolve' them.
> >
> > Every used expression needs to have 'metric:' prefix,
> > like:
> >   cache_miss_cycles = metric:dcache_miss_cpi + metric:icache_miss_cycles
> >
> > All 'other' metrics are disolved into one context,
> > meaning all 'other' metrics events and addded to
> > the parent context.
> >
> > Signed-off-by: Jiri Olsa <jolsa@kernel.org>
> > ---
> >  .../arch/x86/skylake/skl-metrics.json         |   2 +-
> >  tools/perf/util/expr.c                        |  11 ++
> >  tools/perf/util/expr.h                        |   1 +
> >  tools/perf/util/metricgroup.c                 | 158 ++++++++++++++++--
> >  4 files changed, 157 insertions(+), 15 deletions(-)
> >
> > diff --git a/tools/perf/pmu-events/arch/x86/skylake/skl-metrics.json b/tools/perf/pmu-events/arch/x86/skylake/skl-metrics.json
> > index 8704efeb8d31..71e5a2b471ac 100644
> > --- a/tools/perf/pmu-events/arch/x86/skylake/skl-metrics.json
> > +++ b/tools/perf/pmu-events/arch/x86/skylake/skl-metrics.json
> > @@ -57,7 +57,7 @@
> >      },
> >      {
> >          "BriefDescription": "Instructions Per Cycle (per Logical Processor)",
> > -        "MetricExpr": "INST_RETIRED.ANY / CPU_CLK_UNHALTED.THREAD",
> > +        "MetricExpr": "1/metric:CPI",
> >          "MetricGroup": "TopDownL1",
> >          "MetricName": "IPC"
> >      },
> > diff --git a/tools/perf/util/expr.c b/tools/perf/util/expr.c
> > index aa14c7111ecc..cd73dae4588c 100644
> > --- a/tools/perf/util/expr.c
> > +++ b/tools/perf/util/expr.c
> > @@ -150,3 +150,14 @@ int expr__find_other(const char *expr, const char *one,
> >
> >         return ret;
> >  }
> > +
> > +#define METRIC "metric:"
> > +
> > +bool expr__is_metric(const char *name, const char **metric)
> > +{
> > +       int ret = !strncmp(name, METRIC, sizeof(METRIC) - 1);
> > +
> > +       if (ret && metric)
> > +               *metric = name + sizeof(METRIC) - 1;
> > +       return ret;
> > +}
> 
> Should expr.l recognize metric:... as a different kind of token rather
> than an ID?

hm, we still want it to be returned as ID token, and the processing
code needs a way to distinguish between event and metric, so I'd think
we need to keep it, but I'll double check

thanks,
jirka


  reply	other threads:[~2020-06-28 22:06 UTC|newest]

Thread overview: 48+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-26 19:47 [RFC 00/10] perf tools: Add support to reuse metric Jiri Olsa
2020-06-26 19:47 ` [PATCH 01/10] perf tools: Rename expr__add_id to expr__add_val Jiri Olsa
2020-06-26 20:01   ` Ian Rogers
2020-06-28 21:49     ` Jiri Olsa
2020-06-29 15:48       ` Ian Rogers
2020-06-26 19:47 ` [PATCH 02/10] perf tools: Add struct expr_parse_data to keep expr value Jiri Olsa
2020-06-26 20:04   ` Ian Rogers
2020-06-28 21:24     ` Jiri Olsa
2020-06-29 15:49       ` Ian Rogers
2020-06-26 19:47 ` [PATCH 03/10] perf tools: Add expr__add_id function Jiri Olsa
2020-06-26 20:07   ` Ian Rogers
2020-06-28 21:38     ` Jiri Olsa
2020-06-26 19:47 ` [PATCH 04/10] perf tools: Change expr__get_id to return struct expr_parse_data Jiri Olsa
2020-06-26 20:25   ` Ian Rogers
2020-06-26 19:47 ` [PATCH 05/10] perf tools: Add expr__del_id function Jiri Olsa
2020-06-26 20:55   ` Ian Rogers
2020-06-28 21:52     ` Jiri Olsa
2020-06-26 19:47 ` [PATCH 06/10] perf tools: Collect other metrics in struct egroup Jiri Olsa
2020-06-26 21:06   ` Ian Rogers
2020-06-28 22:04     ` Jiri Olsa
2020-06-26 21:48   ` Ian Rogers
2020-06-28 22:06     ` Jiri Olsa [this message]
2020-06-29 15:54       ` Ian Rogers
2020-06-26 19:47 ` [PATCH 07/10] perf tools: Collect other metrics in struct metric_expr Jiri Olsa
2020-06-26 21:10   ` Ian Rogers
2020-06-28 21:55     ` Jiri Olsa
2020-06-29 15:55       ` Ian Rogers
2020-06-26 19:47 ` [PATCH 08/10] perf tools: Add other metrics to hash data Jiri Olsa
2020-06-26 21:16   ` Ian Rogers
2020-06-28 21:56     ` Jiri Olsa
2020-06-26 19:47 ` [PATCH 09/10] perf tools: Compute other metrics Jiri Olsa
2020-06-26 21:24   ` Ian Rogers
2020-06-28 21:59     ` Jiri Olsa
2020-06-29 16:35       ` Ian Rogers
2020-06-29 19:23         ` Jiri Olsa
2020-06-26 19:47 ` [PATCH 10/10] perf tests: Add cache_miss_cycles to metric parse test Jiri Olsa
2020-06-26 21:40   ` Ian Rogers
2020-06-28 22:00     ` Jiri Olsa
2020-06-26 21:25 ` [RFC 00/10] perf tools: Add support to reuse metric Andi Kleen
2020-06-26 21:44   ` Ian Rogers
2020-06-26 21:57     ` Andi Kleen
2020-06-27 12:48       ` Arnaldo Carvalho de Melo
2020-06-27 23:25         ` Ian Rogers
2020-06-28 22:17         ` Jiri Olsa
2020-06-29 12:02       ` Michael Petlan
2020-06-27 12:46     ` Arnaldo Carvalho de Melo
2020-06-27  8:13 ` John Garry
2020-06-29 21:33   ` Andi Kleen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200628220601.GR2988321@krava \
    --to=jolsa@redhat.com \
    --cc=a.p.zijlstra@chello.nl \
    --cc=acme@kernel.org \
    --cc=ak@linux.intel.com \
    --cc=alexander.shishkin@linux.intel.com \
    --cc=eranian@google.com \
    --cc=irogers@google.com \
    --cc=john.garry@huawei.com \
    --cc=jolsa@kernel.org \
    --cc=kjain@linux.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=mpetlan@redhat.com \
    --cc=namhyung@kernel.org \
    --cc=pc@us.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).