Hi all, Today's linux-next merge of the akpm-current tree got a conflict in: drivers/s390/crypto/ap_bus.h between commit: 74ecbef7b908 ("s390/zcrypt: code beautification and struct field renames") from the s390 tree and commit: a0062965cc01 ("mm, treewide: rename kzfree() to kfree_sensitive()") from the akpm-current tree. I fixed it up (see below) and can carry the fix as necessary. This is now fixed as far as linux-next is concerned, but any non trivial conflicts should be mentioned to your upstream maintainer when your tree is submitted for merging. You may also want to consider cooperating with the maintainer of the conflicting tree to minimise any particularly complex conflicts. -- Cheers, Stephen Rothwell diff --cc drivers/s390/crypto/ap_bus.h index 1a1d5e3c8d45,823de10479bd..000000000000 --- a/drivers/s390/crypto/ap_bus.h +++ b/drivers/s390/crypto/ap_bus.h @@@ -219,8 -218,8 +219,8 @@@ static inline void ap_init_message(stru */ static inline void ap_release_message(struct ap_message *ap_msg) { - kzfree(ap_msg->msg); - kzfree(ap_msg->private); - kfree_sensitive(ap_msg->message); ++ kfree_sensitive(ap_msg->msg); + kfree_sensitive(ap_msg->private); } /*