From: Dan Carpenter <dan.carpenter@oracle.com>
To: George Acosta <acostag.ubuntu@gmail.com>
Cc: Matt Porter <mporter@kernel.crashing.org>,
Alexandre Bounine <alex.bou9@gmail.com>,
Andrew Morton <akpm@linux-foundation.org>,
John Hubbard <jhubbard@nvidia.com>,
"Gustavo A. R. Silva" <gustavoars@kernel.org>,
Madhuparna Bhowmik <madhuparnabhowmik10@gmail.com>,
Kees Cook <keescook@chromium.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] rapidio: fix get device imbalance on error
Date: Fri, 21 Aug 2020 11:14:49 +0300 [thread overview]
Message-ID: <20200821081449.GI5493@kadam> (raw)
In-Reply-To: <20200821034458.22472-1-acostag.ubuntu@gmail.com>
On Thu, Aug 20, 2020 at 10:44:57PM -0500, George Acosta wrote:
> Fix the imbalance in mport_cdev_open.
> Call put_device in error path to balance the
> refcount that increased by the get_device.
>
> Fixes: e8de370188d0 ("rapidio: add mport char device driver")
> Signed-off-by: George Acosta <acostag.ubuntu@gmail.com>
> ---
> drivers/rapidio/devices/rio_mport_cdev.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/rapidio/devices/rio_mport_cdev.c b/drivers/rapidio/devices/rio_mport_cdev.c
> index c07ceec3c6d4..3b68e00eb40f 100644
> --- a/drivers/rapidio/devices/rio_mport_cdev.c
> +++ b/drivers/rapidio/devices/rio_mport_cdev.c
> @@ -1908,6 +1908,7 @@ static int mport_cdev_open(struct inode *inode, struct file *filp)
> sizeof(struct rio_event) * MPORT_EVENT_DEPTH,
> GFP_KERNEL);
> if (ret < 0) {
> + put_device(&chdev->dev);
> dev_err(&chdev->dev, DRV_NAME ": kfifo_alloc failed\n");
> ret = -ENOMEM;
> goto err_fifo;
> --
If we ever hit this error path then the:
list_add_tail(&priv->list, &chdev->file_list);
needs to be removed from the list as well or it lead to a use after
free. Probably just move the list_add_tail() after the kfifo_alloc()
has succeeded. We need to remove it from the list in mport_cdev_release()
as well...
The error handling in this function is kind of rubbish.
1) Get rid of the out label and return directly (more readable).
1b) Use "return 0;" instead of "retur ret;" for the success path.
2) Name the labels after what they do not where they "come from". In
other words do.
err_priv:
kfree(priv);
3) Create a label to call put_device:
err_device:
put_device(&chdev->dev);
Change all the error paths to use the goto instead of calling
put_device() before the goto.
regards,
dan carpenter
prev parent reply other threads:[~2020-08-21 8:15 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-08-21 3:44 [PATCH] rapidio: fix get device imbalance on error George Acosta
2020-08-21 8:14 ` Dan Carpenter [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200821081449.GI5493@kadam \
--to=dan.carpenter@oracle.com \
--cc=acostag.ubuntu@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=alex.bou9@gmail.com \
--cc=gustavoars@kernel.org \
--cc=jhubbard@nvidia.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=madhuparnabhowmik10@gmail.com \
--cc=mporter@kernel.crashing.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).