linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: William Breathitt Gray <vilhelm.gray@gmail.com>
To: Syed Nayyar Waris <syednwaris@gmail.com>
Cc: Michal Simek <michal.simek@xilinx.com>,
	Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Arnd Bergmann <arnd@kernel.org>,
	Linus Walleij <linus.walleij@linaro.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	"open list:GPIO SUBSYSTEM" <linux-gpio@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Bartosz Golaszewski <bgolaszewski@baylibre.com>,
	Linux ARM <linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCH v12 4/4] gpio: xilinx: Utilize generic bitmap_get_value and _set_value
Date: Tue, 10 Nov 2020 12:43:16 -0500	[thread overview]
Message-ID: <20201110174316.GA12192@shinobu> (raw)
In-Reply-To: <CACG_h5p84sKjDnK5xYRNjGnRzwsbjZ-76P-cC13LKx=7x=4KqQ@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 3613 bytes --]

On Tue, Nov 10, 2020 at 10:52:42PM +0530, Syed Nayyar Waris wrote:
> On Tue, Nov 10, 2020 at 6:05 PM William Breathitt Gray
> <vilhelm.gray@gmail.com> wrote:
> >
> > On Tue, Nov 10, 2020 at 11:02:43AM +0100, Michal Simek wrote:
> > >
> > >
> > > On 09. 11. 20 18:31, William Breathitt Gray wrote:
> > > > On Mon, Nov 09, 2020 at 07:22:20PM +0200, Andy Shevchenko wrote:
> > > >> On Mon, Nov 09, 2020 at 12:11:40PM -0500, William Breathitt Gray wrote:
> > > >>> On Mon, Nov 09, 2020 at 10:15:29PM +0530, Syed Nayyar Waris wrote:
> > > >>>> On Mon, Nov 09, 2020 at 03:41:53PM +0100, Arnd Bergmann wrote:
> > > >>
> > > >> ...
> > > >>
> > > >>>>  static inline void bitmap_set_value(unsigned long *map,
> > > >>>> -                                    unsigned long value,
> > > >>>> +                                    unsigned long value, const size_t length,
> > > >>>>                                      unsigned long start, unsigned long nbits)
> > > >>>>  {
> > > >>>>          const size_t index = BIT_WORD(start);
> > > >>>> @@ -15,6 +15,10 @@ static inline void bitmap_set_value(unsigned long *map,
> > > >>>>          } else {
> > > >>>>                  map[index + 0] &= ~BITMAP_FIRST_WORD_MASK(start);
> > > >>>>                  map[index + 0] |= value << offset;
> > > >>>> +
> > > >>>> +               if (index + 1 >= length)
> > > >>>> +                       __builtin_unreachable();
> > > >>>> +
> > > >>>>                  map[index + 1] &= ~BITMAP_LAST_WORD_MASK(start + nbits);
> > > >>>>                  map[index + 1] |= value >> space;
> > > >>>>          }
> > > >>>
> > > >>> Hi Syed,
> > > >>>
> > > >>> Let's rename 'length' to 'nbits' as Arnd suggested, and rename 'nbits'
> > > >>> to value_width.
> > > >>
> > > >> length here is in longs. I guess this is the point of entire patch.
> > > >
> > > > Ah yes, this should become 'const unsigned long nbits' and represent the
> > > > length of the bitmap in bits and not longs.
> 
> Hi William, Andy and All,
> 
> Thank You for reviewing. I was looking into the review comments and I
> have a question on the above.
> 
> Actually, in bitmap_set_value(), the intended comparison is to be made
> between 'index + 1' and 'length' (which is now renamed as 'nbits').
> That is, the comparison would look-like as follows:
> if (index + 1 >= nbits)
> 
> The 'index' is getting populated with BIT_WORD(start).
> The 'index' variable in above is the actual index of the bitmap array,
> while in previous mail it is suggested to use 'nbits' which represent
> the length of the bitmap in bits and not longs.
> 
> Isn't it comparing two different things? index of array (not the
> bit-wise-length) on left hand side and nbits (bit-wise-length) on
> right hand side?
> 
> Have I misunderstood something? If yes, request to clarify.
> 
> Or do I have to first divide 'nbits' by BITS_PER_LONG and then compare
> it with 'index + 1'? Something like this?
> 
> Regards
> Syed Nayyar Waris

The array elements of the bitmap memory region are abstracted away for
the covenience of the users of the bitmap_* functions; the driver
authors are able to treat their bitmaps as just a set of contiguous bits
and not worry about where the division between array elements happen.

So to match the interface of the other bitmap_* functions, you should
take in nbits and figure out the actual array length by dividing by
BITS_PER_LONG inside bitmap_set_value(). Then you can use your
conditional check (index + 1 >= length) like you have been doing so far.

William Breathitt Gray

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  reply	other threads:[~2020-11-10 17:43 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-10-18 21:37 [PATCH v12 0/4] Introduce the for_each_set_clump macro Syed Nayyar Waris
2020-10-18 21:38 ` [PATCH v12 1/4] bitops: " Syed Nayyar Waris
2020-10-18 21:39 ` [PATCH v12 2/4] lib/test_bitmap.c: Add for_each_set_clump test cases Syed Nayyar Waris
2020-10-18 21:40 ` [PATCH v12 3/4] gpio: thunderx: Utilize for_each_set_clump macro Syed Nayyar Waris
2020-11-05  9:10   ` Linus Walleij
2020-10-18 21:41 ` [PATCH v12 4/4] gpio: xilinx: Utilize generic bitmap_get_value and _set_value Syed Nayyar Waris
2020-10-29 22:44   ` Arnd Bergmann
2020-11-01 15:00     ` William Breathitt Gray
2020-11-01 20:08       ` Arnd Bergmann
2020-11-09 12:34         ` Syed Nayyar Waris
2020-11-09 13:13           ` Arnd Bergmann
2020-11-09 13:41           ` William Breathitt Gray
2020-11-09 14:38             ` William Breathitt Gray
2020-11-09 14:48               ` Syed Nayyar Waris
2020-11-09 15:18                 ` William Breathitt Gray
2020-11-09 14:41             ` Arnd Bergmann
2020-11-09 16:45               ` Syed Nayyar Waris
2020-11-09 17:11                 ` William Breathitt Gray
2020-11-09 17:22                   ` Andy Shevchenko
2020-11-09 17:31                     ` William Breathitt Gray
2020-11-10 10:02                       ` Michal Simek
2020-11-10 12:35                         ` William Breathitt Gray
2020-11-10 17:22                           ` Syed Nayyar Waris
2020-11-10 17:43                             ` William Breathitt Gray [this message]
2020-11-10 22:00                               ` Syed Nayyar Waris
2020-11-13 16:52                                 ` Syed Nayyar Waris
2020-11-20 13:26                                   ` Arnd Bergmann
2020-11-20 13:45                                     ` William Breathitt Gray

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201110174316.GA12192@shinobu \
    --to=vilhelm.gray@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=arnd@kernel.org \
    --cc=bgolaszewski@baylibre.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=michal.simek@xilinx.com \
    --cc=syednwaris@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).