From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-11.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE, SPF_PASS,USER_AGENT_GIT autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 8839CC4361B for ; Thu, 10 Dec 2020 00:26:15 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 4539722B2E for ; Thu, 10 Dec 2020 00:26:15 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1731266AbgLJAZR (ORCPT ); Wed, 9 Dec 2020 19:25:17 -0500 Received: from lucky1.263xmail.com ([211.157.147.132]:48750 "EHLO lucky1.263xmail.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1727278AbgLJAYC (ORCPT ); Wed, 9 Dec 2020 19:24:02 -0500 Received: from localhost (unknown [192.168.167.13]) by lucky1.263xmail.com (Postfix) with ESMTP id CB99BEF3DB; Thu, 10 Dec 2020 08:21:41 +0800 (CST) X-MAIL-GRAY: 0 X-MAIL-DELIVERY: 1 X-ADDR-CHECKED4: 1 X-ANTISPAM-LEVEL: 2 X-ABS-CHECKED: 0 Received: from localhost.localdomain (unknown [58.22.7.114]) by smtp.263.net (postfix) whith ESMTP id P20466T140379108411136S1607559696395890_; Thu, 10 Dec 2020 08:21:41 +0800 (CST) X-IP-DOMAINF: 1 X-UNIQUE-TAG: <5d8d0dffcde47a00d2b54d99d5a6c5a5> X-RL-SENDER: yifeng.zhao@rock-chips.com X-SENDER: zyf@rock-chips.com X-LOGIN-NAME: yifeng.zhao@rock-chips.com X-FST-TO: miquel.raynal@bootlin.com X-SENDER-IP: 58.22.7.114 X-ATTACHMENT-NUM: 0 X-System-Flag: 0 From: Yifeng Zhao To: miquel.raynal@bootlin.com, richard@nod.at, vigneshr@ti.com, robh+dt@kernel.org Cc: devicetree@vger.kernel.org, linux-mtd@lists.infradead.org, heiko@sntech.de, linux-rockchip@lists.infradead.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, Yifeng Zhao Subject: [PATCH v16 0/8] Add Rockchip NFC drivers for RK3308 and others Date: Thu, 10 Dec 2020 08:21:30 +0800 Message-Id: <20201210002134.5686-1-yifeng.zhao@rock-chips.com> X-Mailer: git-send-email 2.17.1 Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Rockchp's NFC(Nand Flash Controller) has four versions: V600, V622, V800 and V900.This series patch can support all four versions. Changes in v16: - Fix some comments about 'ret' variable. Changes in v15: - Use a buffer pointer nfc->page_buf instead of the original two pointers. - Fix coding style. - Fix some comments. Changes in v14: - Add oob_read and oob_write hook api. - Support timing config and ecc config for each chips. - Fix some comments. Changes in v13: - The nfc->buffer will realloc while the page size of the second mtd is large than the first one. - Fix coding style. - Fix some comments. Changes in v12: - Fix some warnings while make dt_binding_check - Drop a allOf defined Changes in v11: - Fix compile error. Changes in v10: - Fix compile error on master v5.9-rc7. Changes in v9: - The nfc->buffer will realloc while the page size of the second mtd is large than the first one - Fix coding style. - Remove struct rk_nfc_clk. - Prepend some function with rk_nfc_. - Replace function readl_poll_timeout_atomic with readl_relaxed_poll_timeout. - Remove function rk_nfc_read_byte and rk_nfc_write_byte. - Don't select the die if 'check_only == true' in function rk_nfc_exec_op. - Modify function rk_nfc_write_page and rk_nfc_write_page_raw. Changes in v8: - Fix a error while make dt_binding_check Changes in v7: - Fix some wrong define - Rebase to linux-next. - Fix coding style. - Reserved 4 bytes at the beginning of the oob area. - Page raw read and write included ecc data. Changes in v6: - Fix some wrong define - Modified the definition of compatible - The mtd->name set by NAND label property. - Add some comments. - Fix compile error. Changes in v5: - Fix some wrong define. - Add boot-medium define. - Remove some compatible define. - Add boot blocks support with different ECC for bootROM. - Rename rockchip-nand.c to rockchip-nand-controller.c. - Unification of other variable names. - Remove some compatible define. Changes in v4: - The compatible define with rkxx_nfc. - Add assigned-clocks. - Fix some wrong defineChanges in. - Define platform data structure for the register offsets. - The compatible define with rkxx_nfc. - Use SET_SYSTEM_SLEEP_PM_OPS to define PM_OPS. - Use exec_op instead of legacy hooks. Changes in v3: - Change the title for the dt-bindings. Changes in v2: - Fix compile error. - Include header files sorted by file name. Yifeng Zhao (8): dt-bindings: mtd: Describe Rockchip RK3xxx NAND flash controller mtd: rawnand: rockchip: NFC drivers for RK3308, RK2928 and others MAINTAINERS: add maintainers to ROCKCHIP NFC arm64: dts: rockchip: Add NFC node for RK3308 SoC arm64: dts: rockchip: Add NFC node for PX30 SoC arm: dts: rockchip: Add NFC node for RV1108 SoC arm: dts: rockchip: Add NFC node for RK2928 and other SoCs arm: dts: rockchip: Add NFC node for RK3036 SoC .../mtd/rockchip,nand-controller.yaml | 161 ++ MAINTAINERS | 4 +- arch/arm/boot/dts/rk3036.dtsi | 52 + arch/arm/boot/dts/rk3xxx.dtsi | 9 + arch/arm/boot/dts/rv1108.dtsi | 11 + arch/arm64/boot/dts/rockchip/px30.dtsi | 15 + arch/arm64/boot/dts/rockchip/rk3308.dtsi | 15 + drivers/mtd/nand/raw/Kconfig | 12 + drivers/mtd/nand/raw/Makefile | 1 + .../mtd/nand/raw/rockchip-nand-controller.c | 1495 +++++++++++++++++ 10 files changed, 1773 insertions(+), 2 deletions(-) create mode 100644 Documentation/devicetree/bindings/mtd/rockchip,nand-controller.yaml create mode 100644 drivers/mtd/nand/raw/rockchip-nand-controller.c -- 2.17.1