linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* linux-next: manual merge of the drm tree with the pci tree
@ 2020-12-08  2:27 Stephen Rothwell
  2020-12-08 11:47 ` Mika Westerberg
  2020-12-14 20:39 ` Stephen Rothwell
  0 siblings, 2 replies; 4+ messages in thread
From: Stephen Rothwell @ 2020-12-08  2:27 UTC (permalink / raw)
  To: Dave Airlie, DRI, Bjorn Helgaas
  Cc: Daniel Vetter, Linux Kernel Mailing List,
	Linux Next Mailing List, Mika Westerberg, Qinglang Miao

[-- Attachment #1: Type: text/plain, Size: 1355 bytes --]

Hi all,

Today's linux-next merge of the drm tree got a conflict in:

  drivers/gpu/vga/vga_switcheroo.c

between commit:

  99efde6c9bb7 ("PCI/PM: Rename pci_wakeup_bus() to pci_resume_bus()")

from the pci tree and commit:

  9572e6693cd7 ("vga_switcheroo: simplify the return expression of vga_switcheroo_runtime_resume")

from the drm tree.

I fixed it up (see below) and can carry the fix as necessary. This
is now fixed as far as linux-next is concerned, but any non trivial
conflicts should be mentioned to your upstream maintainer when your tree
is submitted for merging.  You may also want to consider cooperating
with the maintainer of the conflicting tree to minimise any particularly
complex conflicts.

-- 
Cheers,
Stephen Rothwell

diff --cc drivers/gpu/vga/vga_switcheroo.c
index 8843b078ad4e,1401fd52f37a..000000000000
--- a/drivers/gpu/vga/vga_switcheroo.c
+++ b/drivers/gpu/vga/vga_switcheroo.c
@@@ -1039,12 -1038,8 +1038,8 @@@ static int vga_switcheroo_runtime_resum
  	mutex_lock(&vgasr_mutex);
  	vga_switcheroo_power_switch(pdev, VGA_SWITCHEROO_ON);
  	mutex_unlock(&vgasr_mutex);
 -	pci_wakeup_bus(pdev->bus);
 +	pci_resume_bus(pdev->bus);
- 	ret = dev->bus->pm->runtime_resume(dev);
- 	if (ret)
- 		return ret;
- 
- 	return 0;
+ 	return dev->bus->pm->runtime_resume(dev);
  }
  
  /**

[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: linux-next: manual merge of the drm tree with the pci tree
  2020-12-08  2:27 linux-next: manual merge of the drm tree with the pci tree Stephen Rothwell
@ 2020-12-08 11:47 ` Mika Westerberg
  2020-12-14 20:39 ` Stephen Rothwell
  1 sibling, 0 replies; 4+ messages in thread
From: Mika Westerberg @ 2020-12-08 11:47 UTC (permalink / raw)
  To: Stephen Rothwell
  Cc: Dave Airlie, DRI, Bjorn Helgaas, Daniel Vetter,
	Linux Kernel Mailing List, Linux Next Mailing List,
	Qinglang Miao

Hi,

On Tue, Dec 08, 2020 at 01:27:54PM +1100, Stephen Rothwell wrote:
> Hi all,
> 
> Today's linux-next merge of the drm tree got a conflict in:
> 
>   drivers/gpu/vga/vga_switcheroo.c
> 
> between commit:
> 
>   99efde6c9bb7 ("PCI/PM: Rename pci_wakeup_bus() to pci_resume_bus()")
> 
> from the pci tree and commit:
> 
>   9572e6693cd7 ("vga_switcheroo: simplify the return expression of vga_switcheroo_runtime_resume")
> 
> from the drm tree.
> 
> I fixed it up (see below) and can carry the fix as necessary. This
> is now fixed as far as linux-next is concerned, but any non trivial
> conflicts should be mentioned to your upstream maintainer when your tree
> is submitted for merging.  You may also want to consider cooperating
> with the maintainer of the conflicting tree to minimise any particularly
> complex conflicts.

Thanks for the fix Stephen! Looks correct to me.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: linux-next: manual merge of the drm tree with the pci tree
  2020-12-08  2:27 linux-next: manual merge of the drm tree with the pci tree Stephen Rothwell
  2020-12-08 11:47 ` Mika Westerberg
@ 2020-12-14 20:39 ` Stephen Rothwell
  1 sibling, 0 replies; 4+ messages in thread
From: Stephen Rothwell @ 2020-12-14 20:39 UTC (permalink / raw)
  To: Dave Airlie, DRI, Bjorn Helgaas
  Cc: Daniel Vetter, Linux Kernel Mailing List,
	Linux Next Mailing List, Mika Westerberg, Qinglang Miao

[-- Attachment #1: Type: text/plain, Size: 1627 bytes --]

Hi all,

On Tue, 8 Dec 2020 13:27:54 +1100 Stephen Rothwell <sfr@canb.auug.org.au> wrote:
> 
> Today's linux-next merge of the drm tree got a conflict in:
> 
>   drivers/gpu/vga/vga_switcheroo.c
> 
> between commit:
> 
>   99efde6c9bb7 ("PCI/PM: Rename pci_wakeup_bus() to pci_resume_bus()")
> 
> from the pci tree and commit:
> 
>   9572e6693cd7 ("vga_switcheroo: simplify the return expression of vga_switcheroo_runtime_resume")
> 
> from the drm tree.
> 
> I fixed it up (see below) and can carry the fix as necessary. This
> is now fixed as far as linux-next is concerned, but any non trivial
> conflicts should be mentioned to your upstream maintainer when your tree
> is submitted for merging.  You may also want to consider cooperating
> with the maintainer of the conflicting tree to minimise any particularly
> complex conflicts.
> 
> -- 
> Cheers,
> Stephen Rothwell
> 
> diff --cc drivers/gpu/vga/vga_switcheroo.c
> index 8843b078ad4e,1401fd52f37a..000000000000
> --- a/drivers/gpu/vga/vga_switcheroo.c
> +++ b/drivers/gpu/vga/vga_switcheroo.c
> @@@ -1039,12 -1038,8 +1038,8 @@@ static int vga_switcheroo_runtime_resum
>   	mutex_lock(&vgasr_mutex);
>   	vga_switcheroo_power_switch(pdev, VGA_SWITCHEROO_ON);
>   	mutex_unlock(&vgasr_mutex);
>  -	pci_wakeup_bus(pdev->bus);
>  +	pci_resume_bus(pdev->bus);
> - 	ret = dev->bus->pm->runtime_resume(dev);
> - 	if (ret)
> - 		return ret;
> - 
> - 	return 0;
> + 	return dev->bus->pm->runtime_resume(dev);
>   }
>   
>   /**

This is now a conflict between the pci tree and Linus' tree.

-- 
Cheers,
Stephen Rothwell

[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* linux-next: manual merge of the drm tree with the pci tree
@ 2012-07-22  1:04 Stephen Rothwell
  0 siblings, 0 replies; 4+ messages in thread
From: Stephen Rothwell @ 2012-07-22  1:04 UTC (permalink / raw)
  To: Dave Airlie; +Cc: linux-next, linux-kernel, Alex Williamson, Bjorn Helgaas

[-- Attachment #1: Type: text/plain, Size: 1454 bytes --]

Hi Dave,

Today's linux-next merge of the drm tree got a conflict in
include/linux/pci_regs.h between commit a0dee2ed0cdc ("PCI: misc pci_reg
additions") from the  tree and commit cdcac9cd7741 ("pci_regs: define
LNKSTA2 pcie cap + bits") from the drm tree.

Just context changes.  I fixed it up (see below) and can carry the fix as
necessary (though I suspect that we may not need both of
PCI_CAP_EXP_ENDPOINT_SIZEOF_V2 and  PCI_EXP_LNKCAP2).
-- 
Cheers,
Stephen Rothwell                    sfr@canb.auug.org.au

diff --cc include/linux/pci_regs.h
index 53274bf,7f04132..0000000
--- a/include/linux/pci_regs.h
+++ b/include/linux/pci_regs.h
@@@ -542,7 -521,11 +542,12 @@@
  #define  PCI_EXP_OBFF_MSGA_EN	0x2000	/* OBFF enable with Message type A */
  #define  PCI_EXP_OBFF_MSGB_EN	0x4000	/* OBFF enable with Message type B */
  #define  PCI_EXP_OBFF_WAKE_EN	0x6000	/* OBFF using WAKE# signaling */
 +#define PCI_CAP_EXP_ENDPOINT_SIZEOF_V2	44	/* v2 endpoints end here */
+ #define PCI_EXP_LNKCAP2		44	/* Link Capability 2 */
+ #define  PCI_EXP_LNKCAP2_SLS_2_5GB 0x01	/* Current Link Speed 2.5GT/s */
+ #define  PCI_EXP_LNKCAP2_SLS_5_0GB 0x02	/* Current Link Speed 5.0GT/s */
+ #define  PCI_EXP_LNKCAP2_SLS_8_0GB 0x04	/* Current Link Speed 8.0GT/s */
+ #define  PCI_EXP_LNKCAP2_CROSSLINK 0x100 /* Crosslink supported */
  #define PCI_EXP_LNKCTL2		48	/* Link Control 2 */
  #define PCI_EXP_SLTCTL2		56	/* Slot Control 2 */
  

[-- Attachment #2: Type: application/pgp-signature, Size: 836 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-12-14 20:40 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-08  2:27 linux-next: manual merge of the drm tree with the pci tree Stephen Rothwell
2020-12-08 11:47 ` Mika Westerberg
2020-12-14 20:39 ` Stephen Rothwell
  -- strict thread matches above, loose matches on Subject: below --
2012-07-22  1:04 Stephen Rothwell

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).