linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Heikki Krogerus <heikki.krogerus@linux.intel.com>
To: Daniel Scally <djrscally@gmail.com>
Cc: linux-kernel@vger.kernel.org, linux-acpi@vger.kernel.org,
	linux-media@vger.kernel.org, devel@acpica.org, rjw@rjwysocki.net,
	lenb@kernel.org, gregkh@linuxfoundation.org, mchehab@kernel.org,
	sergey.senozhatsky@gmail.com, yong.zhi@intel.com,
	sakari.ailus@linux.intel.com, bingbu.cao@intel.com,
	tian.shu.qiu@intel.com, robert.moore@intel.com,
	erik.kaneda@intel.com, pmladek@suse.com, rostedt@goodmis.org,
	andriy.shevchenko@linux.intel.com, linux@rasmusvillemoes.dk,
	laurent.pinchart+renesas@ideasonboard.com,
	jacopo+renesas@jmondi.org,
	kieran.bingham+renesas@ideasonboard.com,
	hverkuil-cisco@xs4all.nl, m.felsch@pengutronix.de,
	niklas.soderlund+renesas@ragnatech.se,
	prabhakar.mahadev-lad.rj@bp.renesas.com, slongerbeam@gmail.com,
	Andy Shevchenko <andy.shevchenko@gmail.com>,
	Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Subject: Re: [PATCH v5 07/15] device property: Define format macros for ports and endpoints
Date: Thu, 7 Jan 2021 16:06:17 +0200	[thread overview]
Message-ID: <20210107140617.GG940479@kuha.fi.intel.com> (raw)
In-Reply-To: <20210107132838.396641-8-djrscally@gmail.com>

On Thu, Jan 07, 2021 at 01:28:30PM +0000, Daniel Scally wrote:
> OF, ACPI and software_nodes all implement graphs including nodes for ports
> and endpoints. These are all intended to be named with a common schema,
> as "port@n" and "endpoint@n" where n is an unsigned int representing the
> index of the node. To ensure commonality across the subsystems, provide a
> set of macros to define the format.
> 
> Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>
> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
> Signed-off-by: Daniel Scally <djrscally@gmail.com>

Reviewed-by: Heikki Krogerus <heikki.krogerus@linux.intel.com>

> ---
> Changes in v5:
> 
> 	- Changed commit subject
> 
>  include/linux/fwnode.h | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/include/linux/fwnode.h b/include/linux/fwnode.h
> index fde4ad97564c..77414e431e89 100644
> --- a/include/linux/fwnode.h
> +++ b/include/linux/fwnode.h
> @@ -50,6 +50,13 @@ struct fwnode_endpoint {
>  	const struct fwnode_handle *local_fwnode;
>  };
>  
> +/*
> + * ports and endpoints defined as software_nodes should all follow a common
> + * naming scheme; use these macros to ensure commonality.
> + */
> +#define SWNODE_GRAPH_PORT_NAME_FMT		"port@%u"
> +#define SWNODE_GRAPH_ENDPOINT_NAME_FMT		"endpoint@%u"
> +
>  #define NR_FWNODE_REFERENCE_ARGS	8
>  
>  /**
> -- 
> 2.25.1

-- 
heikki

  reply	other threads:[~2021-01-07 14:08 UTC|newest]

Thread overview: 47+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-07 13:28 [PATCH v5 00/15] Add functionality to ipu3-cio2 driver allowing software_node connections to sensors on platforms designed for Windows Daniel Scally
2021-01-07 13:28 ` [PATCH v5 01/15] software_node: Fix refcounts in software_node_get_next_child() Daniel Scally
2021-01-07 13:45   ` Heikki Krogerus
2021-01-10 15:09   ` Greg KH
2021-01-07 13:28 ` [PATCH v5 02/15] media: ipu3-cio2: Add headers that ipu3-cio2.h is direct user of Daniel Scally
2021-01-07 13:28 ` [PATCH v5 03/15] device property: Return true in fwnode_device_is_available for NULL ops Daniel Scally
2021-01-07 13:47   ` Heikki Krogerus
2021-01-10 15:09   ` Greg KH
2021-01-07 13:28 ` [PATCH v5 04/15] device property: Call fwnode_graph_get_endpoint_by_id() for fwnode->secondary Daniel Scally
2021-01-10 15:09   ` Greg KH
2021-01-07 13:28 ` [PATCH v5 05/15] software_node: Enforce parent before child ordering of nodes arrays Daniel Scally
2021-01-07 14:04   ` Heikki Krogerus
2021-01-10 15:09   ` Greg KH
2021-01-07 13:28 ` [PATCH v5 06/15] software_node: unregister software_nodes in reverse order Daniel Scally
2021-01-07 14:05   ` Heikki Krogerus
2021-01-10 15:09   ` Greg KH
2021-01-07 13:28 ` [PATCH v5 07/15] device property: Define format macros for ports and endpoints Daniel Scally
2021-01-07 14:06   ` Heikki Krogerus [this message]
2021-01-09  2:05   ` Laurent Pinchart
2021-01-12 19:30     ` Rafael J. Wysocki
2021-01-12 19:29   ` Rafael J. Wysocki
2021-01-07 13:28 ` [PATCH v5 08/15] software_node: Add support for fwnode_graph*() family of functions Daniel Scally
2021-01-10 15:08   ` Greg KH
2021-01-07 13:28 ` [PATCH v5 09/15] lib/test_printf.c: Use helper function to unwind array of software_nodes Daniel Scally
2021-01-09  2:01   ` Laurent Pinchart
     [not found]     ` <CAHp75VeLiMdzXL3Awhco-w6JwJhZNVao_uj7F6bmuty_aW0SNQ@mail.gmail.com>
2021-01-10 11:16       ` Laurent Pinchart
2021-01-10 15:38         ` Andy Shevchenko
2021-01-10 15:52           ` Laurent Pinchart
2021-01-13 13:23     ` Sakari Ailus
2021-01-27  9:25       ` Geert Uytterhoeven
2021-01-07 13:28 ` [PATCH v5 10/15] ipu3-cio2: Add T: entry to MAINTAINERS Daniel Scally
2021-01-07 13:28 ` [PATCH v5 11/15] ipu3-cio2: Rename ipu3-cio2.c Daniel Scally
2021-01-07 13:28 ` [PATCH v5 12/15] media: v4l2-core: v4l2-async: Check sd->fwnode->secondary in match_fwnode() Daniel Scally
2021-01-07 13:28 ` [PATCH v5 13/15] ACPI / bus: Add acpi_dev_get_next_match_dev() and helper macro Daniel Scally
2021-01-09  1:54   ` Laurent Pinchart
2021-01-12 19:26     ` Rafael J. Wysocki
2021-01-12 19:25   ` Rafael J. Wysocki
2021-01-07 13:28 ` [PATCH v5 14/15] media: v4l2-fwnode: Include v4l2_fwnode_bus_type Daniel Scally
2021-01-07 13:28 ` [PATCH v5 15/15] ipu3-cio2: Add cio2-bridge to ipu3-cio2 driver Daniel Scally
2021-01-07 14:05   ` Andy Shevchenko
2021-01-07 14:05     ` Andy Shevchenko
2021-01-07 14:07   ` Daniel Scally
2021-01-09  2:08 ` [PATCH v5 00/15] Add functionality to ipu3-cio2 driver allowing software_node connections to sensors on platforms designed for Windows Laurent Pinchart
2021-01-10 15:08   ` Greg Kroah-Hartman
2021-01-12 19:34 ` Rafael J. Wysocki
2021-01-12 23:35   ` Daniel Scally
2021-01-13 11:42     ` Sakari Ailus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210107140617.GG940479@kuha.fi.intel.com \
    --to=heikki.krogerus@linux.intel.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=andy.shevchenko@gmail.com \
    --cc=bingbu.cao@intel.com \
    --cc=devel@acpica.org \
    --cc=djrscally@gmail.com \
    --cc=erik.kaneda@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hverkuil-cisco@xs4all.nl \
    --cc=jacopo+renesas@jmondi.org \
    --cc=kieran.bingham+renesas@ideasonboard.com \
    --cc=laurent.pinchart+renesas@ideasonboard.com \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux@rasmusvillemoes.dk \
    --cc=m.felsch@pengutronix.de \
    --cc=mchehab@kernel.org \
    --cc=niklas.soderlund+renesas@ragnatech.se \
    --cc=pmladek@suse.com \
    --cc=prabhakar.mahadev-lad.rj@bp.renesas.com \
    --cc=rjw@rjwysocki.net \
    --cc=robert.moore@intel.com \
    --cc=rostedt@goodmis.org \
    --cc=sakari.ailus@linux.intel.com \
    --cc=sergey.senozhatsky@gmail.com \
    --cc=slongerbeam@gmail.com \
    --cc=tian.shu.qiu@intel.com \
    --cc=yong.zhi@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).