linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro
@ 2021-05-28  6:30 YueHaibing
  2021-05-28 12:55 ` Jarkko Nikula
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: YueHaibing @ 2021-05-28  6:30 UTC (permalink / raw)
  To: peter.ujfalusi, jarkko.nikula, lgirdwood, broonie, perex, tiwai
  Cc: alsa-devel, linux-omap, linux-kernel, YueHaibing

Use DEVICE_ATTR_RW() helper instead of plain DEVICE_ATTR(),
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <yuehaibing@huawei.com>
---
 sound/soc/ti/omap-mcbsp.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/sound/soc/ti/omap-mcbsp.c b/sound/soc/ti/omap-mcbsp.c
index db47981768c5..4479d74f0a45 100644
--- a/sound/soc/ti/omap-mcbsp.c
+++ b/sound/soc/ti/omap-mcbsp.c
@@ -539,7 +539,7 @@ static ssize_t prop##_store(struct device *dev,				\
 	return size;							\
 }									\
 									\
-static DEVICE_ATTR(prop, 0644, prop##_show, prop##_store)
+static DEVICE_ATTR_RW(prop)
 
 THRESHOLD_PROP_BUILDER(max_tx_thres);
 THRESHOLD_PROP_BUILDER(max_rx_thres);
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro
  2021-05-28  6:30 [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro YueHaibing
@ 2021-05-28 12:55 ` Jarkko Nikula
  2021-05-31  7:41 ` Péter Ujfalusi
  2021-06-01 17:38 ` Mark Brown
  2 siblings, 0 replies; 4+ messages in thread
From: Jarkko Nikula @ 2021-05-28 12:55 UTC (permalink / raw)
  To: YueHaibing, peter.ujfalusi, lgirdwood, broonie, perex, tiwai
  Cc: alsa-devel, linux-omap, linux-kernel

On 5/28/21 9:30 AM, YueHaibing wrote:
> Use DEVICE_ATTR_RW() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.
> 
> Signed-off-by: YueHaibing <yuehaibing@huawei.com>
> ---
>  sound/soc/ti/omap-mcbsp.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
Acked-by: Jarkko Nikula <jarkko.nikula@bitmer.com>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro
  2021-05-28  6:30 [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro YueHaibing
  2021-05-28 12:55 ` Jarkko Nikula
@ 2021-05-31  7:41 ` Péter Ujfalusi
  2021-06-01 17:38 ` Mark Brown
  2 siblings, 0 replies; 4+ messages in thread
From: Péter Ujfalusi @ 2021-05-31  7:41 UTC (permalink / raw)
  To: YueHaibing, jarkko.nikula, lgirdwood, broonie, perex, tiwai
  Cc: alsa-devel, linux-omap, linux-kernel



On 28/05/2021 09:30, YueHaibing wrote:
> Use DEVICE_ATTR_RW() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.

Acked-by: Peter Ujfalusi <peter.ujfalusi@gmail.com>

> Signed-off-by: YueHaibing <yuehaibing@huawei.com>
> ---
>  sound/soc/ti/omap-mcbsp.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/sound/soc/ti/omap-mcbsp.c b/sound/soc/ti/omap-mcbsp.c
> index db47981768c5..4479d74f0a45 100644
> --- a/sound/soc/ti/omap-mcbsp.c
> +++ b/sound/soc/ti/omap-mcbsp.c
> @@ -539,7 +539,7 @@ static ssize_t prop##_store(struct device *dev,				\
>  	return size;							\
>  }									\
>  									\
> -static DEVICE_ATTR(prop, 0644, prop##_show, prop##_store)
> +static DEVICE_ATTR_RW(prop)
>  
>  THRESHOLD_PROP_BUILDER(max_tx_thres);
>  THRESHOLD_PROP_BUILDER(max_rx_thres);
> 

-- 
Péter

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro
  2021-05-28  6:30 [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro YueHaibing
  2021-05-28 12:55 ` Jarkko Nikula
  2021-05-31  7:41 ` Péter Ujfalusi
@ 2021-06-01 17:38 ` Mark Brown
  2 siblings, 0 replies; 4+ messages in thread
From: Mark Brown @ 2021-06-01 17:38 UTC (permalink / raw)
  To: tiwai, YueHaibing, lgirdwood, perex, jarkko.nikula, peter.ujfalusi
  Cc: Mark Brown, alsa-devel, linux-omap, linux-kernel

On Fri, 28 May 2021 14:30:33 +0800, YueHaibing wrote:
> Use DEVICE_ATTR_RW() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.

Applied to

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next

Thanks!

[1/1] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro
      commit: b1b384de0a9be2d2913c8a308f381da0b9184e91

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-06-01 17:39 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-28  6:30 [PATCH -next] ASoC: ti: omap-mcbsp: use DEVICE_ATTR_RW macro YueHaibing
2021-05-28 12:55 ` Jarkko Nikula
2021-05-31  7:41 ` Péter Ujfalusi
2021-06-01 17:38 ` Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).