linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/1] PNP: use DEVICE_ATTR_RO macro
@ 2021-06-02  8:15 Zhen Lei
  2021-06-07 14:25 ` Rafael J. Wysocki
  0 siblings, 1 reply; 2+ messages in thread
From: Zhen Lei @ 2021-06-02  8:15 UTC (permalink / raw)
  To: Rafael J . Wysocki, linux-acpi, linux-kernel; +Cc: Zhen Lei

Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.

Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com>
---
 drivers/pnp/card.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/pnp/card.c b/drivers/pnp/card.c
index 2430c14f472d26a..d40ed8621571b0a 100644
--- a/drivers/pnp/card.c
+++ b/drivers/pnp/card.c
@@ -181,8 +181,8 @@ struct pnp_card *pnp_alloc_card(struct pnp_protocol *protocol, int id, char *pnp
 	return card;
 }
 
-static ssize_t pnp_show_card_name(struct device *dmdev,
-				  struct device_attribute *attr, char *buf)
+static ssize_t name_show(struct device *dmdev,
+			 struct device_attribute *attr, char *buf)
 {
 	char *str = buf;
 	struct pnp_card *card = to_pnp_card(dmdev);
@@ -191,10 +191,10 @@ static ssize_t pnp_show_card_name(struct device *dmdev,
 	return (str - buf);
 }
 
-static DEVICE_ATTR(name, S_IRUGO, pnp_show_card_name, NULL);
+static DEVICE_ATTR_RO(name);
 
-static ssize_t pnp_show_card_ids(struct device *dmdev,
-				 struct device_attribute *attr, char *buf)
+static ssize_t card_id_show(struct device *dmdev,
+			    struct device_attribute *attr, char *buf)
 {
 	char *str = buf;
 	struct pnp_card *card = to_pnp_card(dmdev);
@@ -207,7 +207,7 @@ static ssize_t pnp_show_card_ids(struct device *dmdev,
 	return (str - buf);
 }
 
-static DEVICE_ATTR(card_id, S_IRUGO, pnp_show_card_ids, NULL);
+static DEVICE_ATTR_RO(card_id);
 
 static int pnp_interface_attach_card(struct pnp_card *card)
 {
-- 
2.26.0.106.g9fadedd



^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH 1/1] PNP: use DEVICE_ATTR_RO macro
  2021-06-02  8:15 [PATCH 1/1] PNP: use DEVICE_ATTR_RO macro Zhen Lei
@ 2021-06-07 14:25 ` Rafael J. Wysocki
  0 siblings, 0 replies; 2+ messages in thread
From: Rafael J. Wysocki @ 2021-06-07 14:25 UTC (permalink / raw)
  To: Zhen Lei; +Cc: Rafael J . Wysocki, linux-acpi, linux-kernel

On Wed, Jun 2, 2021 at 10:15 AM Zhen Lei <thunder.leizhen@huawei.com> wrote:
>
> Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
> the code a bit shorter and easier to read.
>
> Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com>
> ---
>  drivers/pnp/card.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/pnp/card.c b/drivers/pnp/card.c
> index 2430c14f472d26a..d40ed8621571b0a 100644
> --- a/drivers/pnp/card.c
> +++ b/drivers/pnp/card.c
> @@ -181,8 +181,8 @@ struct pnp_card *pnp_alloc_card(struct pnp_protocol *protocol, int id, char *pnp
>         return card;
>  }
>
> -static ssize_t pnp_show_card_name(struct device *dmdev,
> -                                 struct device_attribute *attr, char *buf)
> +static ssize_t name_show(struct device *dmdev,
> +                        struct device_attribute *attr, char *buf)
>  {
>         char *str = buf;
>         struct pnp_card *card = to_pnp_card(dmdev);
> @@ -191,10 +191,10 @@ static ssize_t pnp_show_card_name(struct device *dmdev,
>         return (str - buf);
>  }
>
> -static DEVICE_ATTR(name, S_IRUGO, pnp_show_card_name, NULL);
> +static DEVICE_ATTR_RO(name);
>
> -static ssize_t pnp_show_card_ids(struct device *dmdev,
> -                                struct device_attribute *attr, char *buf)
> +static ssize_t card_id_show(struct device *dmdev,
> +                           struct device_attribute *attr, char *buf)
>  {
>         char *str = buf;
>         struct pnp_card *card = to_pnp_card(dmdev);
> @@ -207,7 +207,7 @@ static ssize_t pnp_show_card_ids(struct device *dmdev,
>         return (str - buf);
>  }
>
> -static DEVICE_ATTR(card_id, S_IRUGO, pnp_show_card_ids, NULL);
> +static DEVICE_ATTR_RO(card_id);
>
>  static int pnp_interface_attach_card(struct pnp_card *card)
>  {
> --

Applied as 5.14 material, thanks!

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-06-07 14:26 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-02  8:15 [PATCH 1/1] PNP: use DEVICE_ATTR_RO macro Zhen Lei
2021-06-07 14:25 ` Rafael J. Wysocki

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).