From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-10.3 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE, SPF_PASS,USER_AGENT_SANE_2 autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 182C8C47096 for ; Thu, 3 Jun 2021 21:27:15 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id EC812613D8 for ; Thu, 3 Jun 2021 21:27:14 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S230054AbhFCV27 (ORCPT ); Thu, 3 Jun 2021 17:28:59 -0400 Received: from mail.kernel.org ([198.145.29.99]:50490 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S229620AbhFCV25 (ORCPT ); Thu, 3 Jun 2021 17:28:57 -0400 Received: from gandalf.local.home (cpe-66-24-58-225.stny.res.rr.com [66.24.58.225]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPSA id 157A46120F; Thu, 3 Jun 2021 21:27:10 +0000 (UTC) Date: Thu, 3 Jun 2021 17:27:09 -0400 From: Steven Rostedt To: Daniel Bristot de Oliveira Cc: linux-kernel@vger.kernel.org, Phil Auld , Sebastian Andrzej Siewior , Kate Carcia , Jonathan Corbet , Ingo Molnar , Peter Zijlstra , Thomas Gleixner , Alexandre Chartre , Clark Willaims , John Kacur , Juri Lelli , linux-doc@vger.kernel.org Subject: Re: [PATCH V3 6/9] trace/hwlat: Use the generic function to read/write width and window Message-ID: <20210603172709.25c322a1@gandalf.local.home> In-Reply-To: References: X-Mailer: Claws Mail 3.17.8 (GTK+ 2.24.33; x86_64-pc-linux-gnu) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 14 May 2021 22:51:15 +0200 Daniel Bristot de Oliveira wrote: > @@ -733,16 +624,18 @@ static ssize_t hwlat_mode_write(struct file *filp, const char __user *ubuf, > return ret; > } > > -static const struct file_operations width_fops = { > - .open = tracing_open_generic, > - .read = hwlat_read, > - .write = hwlat_width_write, > +static struct trace_ull_config hwlat_width = { > + .lock = &hwlat_data.lock, > + .val = &hwlat_data.sample_width, > + .max = &hwlat_data.sample_window, > + .min = NULL, > }; > > -static const struct file_operations window_fops = { > - .open = tracing_open_generic, > - .read = hwlat_read, > - .write = hwlat_window_write, > +static struct trace_ull_config hwlat_window = { Yeah, the naming convention needs to be changed, because ull_config is meaningless, and this code makes no sense. I know what it is doing, but if I didn't, I'd have no clue what it was doing by reading it. :-p -- Steve > + .lock = &hwlat_data.lock, > + .val = &hwlat_data.sample_window, > + .max = NULL, > + .min = &hwlat_data.sample_width, > }; > > static const struct file_operations thread_mode_fops = { > @@ -775,15 +668,15 @@ static int init_tracefs(void) > > hwlat_sample_window = tracefs_create_file("window", 0640, > top_dir, > - &hwlat_data.sample_window, > - &window_fops); > + &hwlat_window, > + &trace_ull_config_fops); > if (!hwlat_sample_window) > goto err; > > hwlat_sample_width = tracefs_create_file("width", 0644, > top_dir, > - &hwlat_data.sample_width, > - &width_fops); > + &hwlat_width, > + &trace_ull_config_fops); > if (!hwlat_sample_width) > goto err; >