linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Pavel Machek <pavel@ucw.cz>
To: Amy Parker <apark0006@student.cerritos.edu>
Cc: linux-leds@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] swap led_brightness from enum to typedef
Date: Mon, 19 Jul 2021 14:08:32 +0200	[thread overview]
Message-ID: <20210719120832.GB20484@duo.ucw.cz> (raw)
In-Reply-To: <9b5902665dcc4c0fca7546987303e348d8657f59.1626383424.git.apark0006@student.cerritos.edu>

[-- Attachment #1: Type: text/plain, Size: 1876 bytes --]

Hi!

> This commit changes how led_brightness, declared in header file
> include/linux/leds.h, works throughout the kernel, and updates other
> files in accordance.
> 
> The TODO located at drivers/leds/TODO requests:
> 
> * Get rid of led_brightness
> 
> It is really an integer, as maximum is configurable. Get rid of it, or
> make it into typedef or something.
> 
> This patch changes the declaration of led_brightness from an enum to a
> typedef. In order to hold the currently existing enum values, macro
> definitions are provided. Files which use led_brightness are updated to
> conform to the new types.

Hmm... thanks.

But I can't really pull this through the LED tree as it touches other
people's code.


> index bfa60fa1d812..e1d771513b98 100644
> --- a/drivers/leds/TODO
> +++ b/drivers/leds/TODO
> @@ -1,7 +1,7 @@
>  -*- org -*-
>  
>  * On/off LEDs should have max_brightness of 1
> -* Get rid of enum led_brightness
> +* Get rid of led_brightness
>  
>  It is really an integer, as maximum is configurable. Get rid of it, or
>  make it into typedef or something.

You can delete this.

Probably new type should be called led_brightness_t. And probably it
should be typedef for the enum _for now_, so that we can switch users
gradually.

It should also be more than u8, I believe someone has more than 255
levels at this point.

> +++ b/include/linux/leds.h
> @@ -26,12 +26,11 @@ struct device_node;
>   */
>  
>  /* This is obsolete/useless. We now support variable maximum brightness. */
> -enum led_brightness {
> -	LED_OFF		= 0,
> -	LED_ON		= 1,
> -	LED_HALF	= 127,
> -	LED_FULL	= 255,
> -};
> +typedef u8 led_brightness;
> +#define LED_OFF 0
> +#define LED_ON 1
> +#define LED_HALF 127
> +#define LED_FULL 255
>

Best regards,
									Pavel

-- 
http://www.livejournal.com/~pavelmachek

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 195 bytes --]

  parent reply	other threads:[~2021-07-19 12:08 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-15 21:18 [PATCH 0/2] leds: change led_brightness definition from enum to typedef Amy Parker
2021-07-15 21:18 ` [PATCH 1/2] swap led_brightness " Amy Parker
2021-07-16  0:41   ` kernel test robot
2021-07-16  2:14   ` kernel test robot
2021-07-16  3:11     ` Amy Parker
2021-07-16 21:07       ` Amy Parker
2021-07-16 21:43         ` Randy Dunlap
2021-07-19 12:05           ` Pavel Machek
2021-07-19  7:16   ` Geert Uytterhoeven
2021-07-19  8:40     ` Geert Uytterhoeven
2021-08-03 21:38       ` Pavel Machek
2021-07-19  8:05   ` Dan Carpenter
2021-07-19  8:21   ` Dan Carpenter
2021-07-19 12:08   ` Pavel Machek [this message]
2021-07-15 21:18 ` [PATCH 2/2] drivers/leds/TODO: update TODO to reflect changes Amy Parker

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210719120832.GB20484@duo.ucw.cz \
    --to=pavel@ucw.cz \
    --cc=apark0006@student.cerritos.edu \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).