linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/7] sections: Unify kernel sections range check and use
@ 2021-07-28  8:13 Kefeng Wang
  2021-07-28  8:13 ` [PATCH v2 1/7] kallsyms: Remove arch specific text and data check Kefeng Wang
                   ` (6 more replies)
  0 siblings, 7 replies; 16+ messages in thread
From: Kefeng Wang @ 2021-07-28  8:13 UTC (permalink / raw)
  To: arnd, linux-arch, linux-kernel, linuxppc-dev, rostedt, mingo,
	davem, ast, ryabinin.a.a
  Cc: mpe, benh, paulus, Kefeng Wang, linux-s390, iommu, bpf

There are three head files(kallsyms.h, kernel.h and sections.h) which
include the kernel sections range check, let's make some cleanup and
unify them.

1. cleanup arch specific text/data check and fix address boundary check
   in kallsyms.h
2. make all the basic/core kernel range check function into sections.h
3. update all the callers, and use the helper in sections.h to simplify
   the code

After this series, we have 5 APIs about kernel sections range check in
sections.h

 * is_kernel_core_data()	--- come from core_kernel_data() in kernel.h
 * is_kernel_rodata()		--- already in sections.h
 * is_kernel_text()		--- come from kallsyms.h
 * is_kernel_inittext()		--- come from kernel.h and kallsyms.h
 * is_kernel()			--- come from kallsyms.h


Cc: linuxppc-dev@lists.ozlabs.org
Cc: linux-s390@vger.kernel.org
Cc: linux-arch@vger.kernel.org 
Cc: iommu@lists.linux-foundation.org
Cc: bpf@vger.kernel.org 

v2:
- add ACK/RW to patch2, and drop inappropriate fix tag
- keep 'core' to check kernel data, suggestted by Steven Rostedt
  <rostedt@goodmis.org>, rename is_kernel_data() to is_kernel_core_data()
- drop patch8 which is merged
- drop patch9 which is resend independently

v1:
https://lore.kernel.org/linux-arch/20210626073439.150586-1-wangkefeng.wang@huawei.com

Kefeng Wang (7):
  kallsyms: Remove arch specific text and data check
  kallsyms: Fix address-checks for kernel related range
  sections: Move and rename core_kernel_data() to is_kernel_core_data()
  sections: Move is_kernel_inittext() into sections.h
  kallsyms: Rename is_kernel() and is_kernel_text()
  sections: Add new is_kernel() and is_kernel_text()
  powerpc/mm: Use is_kernel_text() and is_kernel_inittext() helper

 arch/powerpc/mm/pgtable_32.c   |  7 +---
 arch/x86/kernel/unwind_orc.c   |  2 +-
 arch/x86/net/bpf_jit_comp.c    |  2 +-
 include/asm-generic/sections.h | 71 ++++++++++++++++++++++++++--------
 include/linux/kallsyms.h       | 21 +++-------
 include/linux/kernel.h         |  2 -
 kernel/cfi.c                   |  2 +-
 kernel/extable.c               | 33 ++--------------
 kernel/locking/lockdep.c       |  3 --
 kernel/trace/ftrace.c          |  2 +-
 mm/kasan/report.c              |  2 +-
 net/sysctl_net.c               |  2 +-
 12 files changed, 72 insertions(+), 77 deletions(-)

-- 
2.26.2


^ permalink raw reply	[flat|nested] 16+ messages in thread

end of thread, other threads:[~2021-07-29 11:06 UTC | newest]

Thread overview: 16+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-28  8:13 [PATCH v2 0/7] sections: Unify kernel sections range check and use Kefeng Wang
2021-07-28  8:13 ` [PATCH v2 1/7] kallsyms: Remove arch specific text and data check Kefeng Wang
2021-07-28  8:13 ` [PATCH v2 2/7] kallsyms: Fix address-checks for kernel related range Kefeng Wang
2021-07-28 14:46   ` Steven Rostedt
2021-07-29  2:03     ` Kefeng Wang
2021-07-28  8:13 ` [PATCH v2 3/7] sections: Move and rename core_kernel_data() to is_kernel_core_data() Kefeng Wang
2021-07-28  8:13 ` [PATCH v2 4/7] sections: Move is_kernel_inittext() into sections.h Kefeng Wang
2021-07-28  8:13 ` [PATCH v2 5/7] kallsyms: Rename is_kernel() and is_kernel_text() Kefeng Wang
2021-07-28 15:28   ` Steven Rostedt
2021-07-29  2:00     ` Kefeng Wang
2021-07-29  4:05       ` Steven Rostedt
2021-07-29 11:06         ` Kefeng Wang
2021-07-28  8:13 ` [PATCH v2 6/7] sections: Add new " Kefeng Wang
2021-07-28 15:32   ` Steven Rostedt
2021-07-29  2:02     ` Kefeng Wang
2021-07-28  8:13 ` [PATCH v2 7/7] powerpc/mm: Use is_kernel_text() and is_kernel_inittext() helper Kefeng Wang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).