Hi all, Today's linux-next merge of the akpm-current tree got a conflict in: arch/s390/kernel/setup.c between commit: e035389b73b1 ("s390/setup: use virtual address for STSI instruction") from the s390 tree and commits: 0d52db59796e ("memblock: rename memblock_free to memblock_phys_free") 13ab40b0e60e ("memblock: use memblock_free for freeing virtual pointers") from the akpm-current tree. I fixed it up (thanks, Vasily for the heads up and resolution) and can carry the fix as necessary. This is now fixed as far as linux-next is concerned, but any non trivial conflicts should be mentioned to your upstream maintainer when your tree is submitted for merging. You may also want to consider cooperating with the maintainer of the conflicting tree to minimise any particularly complex conflicts. -- Cheers, Stephen Rothwell diff --cc arch/s390/kernel/setup.c index e738a45057ac,8a378d426239..000000000000 --- a/arch/s390/kernel/setup.c +++ b/arch/s390/kernel/setup.c @@@ -878,12 -884,14 +879,12 @@@ static void __init setup_randomness(voi { struct sysinfo_3_2_2 *vmms; - vmms = (struct sysinfo_3_2_2 *) memblock_phys_alloc(PAGE_SIZE, - PAGE_SIZE); + vmms = memblock_alloc(PAGE_SIZE, PAGE_SIZE); if (!vmms) panic("Failed to allocate memory for sysinfo structure\n"); - if (stsi(vmms, 3, 2, 2) == 0 && vmms->count) add_device_randomness(&vmms->vm, sizeof(vmms->vm[0]) * vmms->count); - memblock_free_ptr(vmms, PAGE_SIZE); - memblock_phys_free((unsigned long)vmms, PAGE_SIZE); ++ memblock_free(vmms, PAGE_SIZE); } /*