linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Francesco Dolcini <francesco.dolcini@toradex.com>
To: Lee Jones <lee.jones@linaro.org>,
	Maxime Coquelin <mcoquelin.stm32@gmail.com>,
	Alexandre Torgue <alexandre.torgue@foss.st.com>,
	Rob Herring <robh+dt@kernel.org>,
	Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>
Cc: Francesco Dolcini <francesco.dolcini@toradex.com>,
	linux-stm32@st-md-mailman.stormreply.com,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
	Ahmad Fatoum <a.fatoum@pengutronix.de>
Subject: [PATCH v2 2/5] mfd: stmpe: Probe sub-function by compatible
Date: Tue, 12 Jul 2022 18:33:42 +0200	[thread overview]
Message-ID: <20220712163345.445811-3-francesco.dolcini@toradex.com> (raw)
In-Reply-To: <20220712163345.445811-1-francesco.dolcini@toradex.com>

Use sub-function of_compatible during probe, instead of using the node
name. The code should not rely on the node names during probe, in
addition to that the previously hard-coded node names are not compliant
to the latest naming convention (they are not generic and they use
underscores), and it was broken by mistake already once [1].

[1] commit 56086b5e804f ("ARM: dts: imx6qdl-apalis: Avoid underscore in node name")

Suggested-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
Signed-off-by: Francesco Dolcini <francesco.dolcini@toradex.com>
---
v2:
 - remove define usage for compatible strings
 - moved rotator removal from probe to a separate patch
---
 drivers/mfd/stmpe.c | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/drivers/mfd/stmpe.c b/drivers/mfd/stmpe.c
index 4aa4ac2ff406..987e251d90ae 100644
--- a/drivers/mfd/stmpe.c
+++ b/drivers/mfd/stmpe.c
@@ -1362,17 +1362,16 @@ static void stmpe_of_probe(struct stmpe_platform_data *pdata,
 	pdata->autosleep = (pdata->autosleep_timeout) ? true : false;
 
 	for_each_available_child_of_node(np, child) {
-		if (of_node_name_eq(child, "stmpe_gpio")) {
+		if (of_device_is_compatible(child, stmpe_gpio_cell.of_compatible))
 			pdata->blocks |= STMPE_BLOCK_GPIO;
-		} else if (of_node_name_eq(child, "stmpe_keypad")) {
+		else if (of_device_is_compatible(child, stmpe_keypad_cell.of_compatible))
 			pdata->blocks |= STMPE_BLOCK_KEYPAD;
-		} else if (of_node_name_eq(child, "stmpe_touchscreen")) {
+		else if (of_device_is_compatible(child, stmpe_ts_cell.of_compatible))
 			pdata->blocks |= STMPE_BLOCK_TOUCHSCREEN;
-		} else if (of_node_name_eq(child, "stmpe_adc")) {
+		else if (of_device_is_compatible(child, stmpe_adc_cell.of_compatible))
 			pdata->blocks |= STMPE_BLOCK_ADC;
-		} else if (of_node_name_eq(child, "stmpe_pwm")) {
+		else if (of_device_is_compatible(child, stmpe_pwm_cell.of_compatible))
 			pdata->blocks |= STMPE_BLOCK_PWM;
-		}
 	}
 }
 
-- 
2.25.1


  parent reply	other threads:[~2022-07-12 16:34 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-12 16:33 [PATCH v2 0/5] mfd: stmpe: Probe sub-function by compatible Francesco Dolcini
2022-07-12 16:33 ` [PATCH v2 1/5] mfd: stmpe: Remove rotator block from probe Francesco Dolcini
2022-08-08 15:17   ` Lee Jones
2022-07-12 16:33 ` Francesco Dolcini [this message]
2022-07-18  9:20   ` [PATCH v2 2/5] mfd: stmpe: Probe sub-function by compatible Linus Walleij
2022-08-08 15:18   ` Lee Jones
2022-07-12 16:33 ` [PATCH v2 3/5] dt-bindings: gpio: stmpe: Remove node name requirement Francesco Dolcini
2022-07-12 21:23   ` Krzysztof Kozlowski
2022-07-13  7:43   ` Bartosz Golaszewski
2022-07-18 10:43   ` Francesco Dolcini
2022-08-09 13:48   ` Francesco Dolcini
2022-08-31 19:57     ` Bartosz Golaszewski
2022-07-12 16:33 ` [PATCH v2 4/5] dt-bindings: iio: adc: " Francesco Dolcini
2022-07-12 21:23   ` Krzysztof Kozlowski
2022-07-13 16:24   ` Jonathan Cameron
2022-08-09 13:46   ` Francesco Dolcini
2022-08-09 15:37     ` Lee Jones
2022-08-13 15:05       ` Jonathan Cameron
2022-07-12 16:33 ` [PATCH v2 5/5] dt-bindings: input: touchscreen: " Francesco Dolcini
2022-07-12 21:23   ` Krzysztof Kozlowski
2022-08-09 13:50   ` Francesco Dolcini
2022-09-05  7:22   ` Francesco Dolcini
2022-09-06  3:15   ` Dmitry Torokhov
2022-08-09  7:54 ` [PATCH v2 0/5] mfd: stmpe: Probe sub-function by compatible Francesco Dolcini
2022-08-09 13:38   ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220712163345.445811-3-francesco.dolcini@toradex.com \
    --to=francesco.dolcini@toradex.com \
    --cc=a.fatoum@pengutronix.de \
    --cc=alexandre.torgue@foss.st.com \
    --cc=devicetree@vger.kernel.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=lee.jones@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-stm32@st-md-mailman.stormreply.com \
    --cc=mcoquelin.stm32@gmail.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).