linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Maxime Ripard <maxime@cerno.tech>
To: David Gow <davidgow@google.com>
Cc: "Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
	"Daniel Vetter" <daniel@ffwll.ch>,
	"David Airlie" <airlied@gmail.com>,
	"Thomas Zimmermann" <tzimmermann@suse.de>,
	linaro-mm-sig@lists.linaro.org,
	"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
	linux-kselftest@vger.kernel.org,
	"Maíra Canal" <mairacanal@riseup.net>,
	linux-media@vger.kernel.org,
	"Javier Martinez Canillas" <javierm@redhat.com>,
	kunit-dev@googlegroups.com, dri-devel@lists.freedesktop.org,
	"Brendan Higgins" <brendan.higgins@linux.dev>,
	linux-kernel@vger.kernel.org,
	"Dave Stevenson" <dave.stevenson@raspberrypi.com>
Subject: Re: [PATCH 00/24] drm: Introduce Kunit Tests to VC4
Date: Thu, 24 Nov 2022 15:01:03 +0100	[thread overview]
Message-ID: <20221124140103.saf2fyal75dscoot@houat> (raw)
In-Reply-To: <CABVgOSmtiPMd+GB40_o=eDPg3cKVA3qPNbbYFoRJvJRxQBDj5A@mail.gmail.com>

Hi David,

On Thu, Nov 24, 2022 at 04:31:14PM +0800, David Gow wrote:
> On Wed, Nov 23, 2022 at 11:28 PM Maxime Ripard <maxime@cerno.tech> wrote:
> >
> > Hi,
> >
> > This series introduce Kunit tests to the vc4 KMS driver, but unlike what we
> > have been doing so far in KMS, it actually tests the atomic modesetting code.
> >
> > In order to do so, I've had to improve a fair bit on the Kunit helpers already
> > found in the tree in order to register a full blown and somewhat functional KMS
> > driver.
> >
> > It's of course relying on a mock so that we can test it anywhere. The mocking
> > approach created a number of issues, the main one being that we need to create
> > a decent mock in the first place, see patch 22. The basic idea is that I
> > created some structures to provide a decent approximation of the actual
> > hardware, and that would support both major architectures supported by vc4.
> >
> > This is of course meant to evolve over time and support more tests, but I've
> > focused on testing the HVS FIFO assignment code which is fairly tricky (and the
> > tests have actually revealed one more bug with our current implementation). I
> > used to have a userspace implementation of those tests, where I would copy and
> > paste the kernel code and run the tests on a regular basis. It's was obviously
> > fairly suboptimal, so it seemed like the perfect testbed for that series.
>
> Thanks very much for this! I'm really excited to see these sorts of
> tests being written.
> 
> I was able to successfully run these under qemu with:
> ./tools/testing/kunit/kunit.py run --kunitconfig
> drivers/gpu/drm/vc4/tests --arch arm64
> --cross_compile=aarch64-linux-gnu-
> (and also with clang, using --make_options LLVM=1 instead of the
> --cross_compile flag)
> 
> On the other hand, they don't compile as a module:
> ERROR: modpost: missing MODULE_LICENSE() in drivers/gpu/drm/vc4/tests/vc4_mock.o
> ERROR: modpost: missing MODULE_LICENSE() in
> drivers/gpu/drm/vc4/tests/vc4_mock_crtc.o
> ERROR: modpost: missing MODULE_LICENSE() in
> drivers/gpu/drm/vc4/tests/vc4_mock_output.o
> ERROR: modpost: missing MODULE_LICENSE() in
> drivers/gpu/drm/vc4/tests/vc4_mock_plane.o
> ERROR: modpost: missing MODULE_LICENSE() in
> drivers/gpu/drm/vc4/tests/vc4_test_pv_muxing.o
> ERROR: modpost: missing MODULE_LICENSE() in
> drivers/gpu/drm/tests/drm_managed_test.o
> ERROR: modpost: "vc4_drm_driver"
> [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> ERROR: modpost: "vc5_drm_driver"
> [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> ERROR: modpost: "drm_kunit_helper_alloc_device"
> [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> ERROR: modpost: "__drm_kunit_helper_alloc_drm_device_with_driver"
> [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> ERROR: modpost: "__vc4_hvs_alloc"
> [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> ERROR: modpost: "vc4_dummy_plane"
> [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> ERROR: modpost: "vc4_mock_pv" [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> ERROR: modpost: "vc4_dummy_output"
> [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> ERROR: modpost: "vc4_kms_load" [drivers/gpu/drm/vc4/tests/vc4_mock.ko]
> undefined!
> ERROR: modpost: "vc4_txp_crtc_data"
> [drivers/gpu/drm/vc4/tests/vc4_mock.ko] undefined!
> WARNING: modpost: suppressed 17 unresolved symbol warnings because
> there were too many)

Thanks I'll fix it

> Most of those are just the need to export some symbols. There's some
> work underway to support conditionally exporting symbols only if KUnit
> is enabled, which may help:
> https://lore.kernel.org/linux-kselftest/20221102175959.2921063-1-rmoar@google.com/

That's awesome :)

The current solution to include the test implementation is not ideal, so
it's great to see a nicer solution being worked on.

> Otherwise, I suspect the better short-term solution would just be to
> require that the tests are built-in (or at least compiled into
> whatever of the drm/vc4 modules makes most sense).
> 
> The only other thing which has me a little confused is the naming of
> some of the functions, specifically with the __ prefix. Is it just for
> internal functions (many of them aren't static, but maybe they could
> use the VISIBLE_IF_KUNIT macro if that makes sense), or for versions
> of functions which accept extra arguments?

It was for internal functions that would definitely benefit from
VISIBLE_IF_KUNIT indeed

> Not a big deal (and maybe it's a DRM naming convention I'm ignorant
> of), but I couldn't quite find a pattern on my first read through.
> 
> But on the whole, these look good from a KUnit point-of-view. It's
> really to see some solid mocking and driver testing, too. There would
> be ways to avoid passing the 'struct kunit' around in more places (or
> to store extra data as a kunit_resource), but I think it's better
> overall to pass it around like you have in this case -- it's certainly
> more compatible with things which might span threads (e.g. the
> workqueues).

One thing I'm really unsure about and would like your input on is
basically the entire device instantiation code in drm_kunit_helpers.c

It's a little fishy since it will allocate a platform_device while the
driver might expect some other bus device. And the code to bind the
driver based around probe and workqueues seems like a hack.

This is something that would benefit from having proper functions in
kunit to allocate a proper device for a given test. This is already
something that other unit test suites seems to get wrong, and I'm sure
there's some bugs somewhere in the helpers I did for DRM. What do you
think?

Maxime

  reply	other threads:[~2022-11-24 14:04 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20221123-rpi-kunit-tests-v1-0-051a0bb60a16@cerno.tech>
2022-11-24  8:31 ` [PATCH 00/24] drm: Introduce Kunit Tests to VC4 David Gow
2022-11-24 14:01   ` Maxime Ripard [this message]
     [not found] ` <20221123-rpi-kunit-tests-v1-2-051a0bb60a16@cerno.tech>
2022-11-25  8:57   ` [PATCH 02/24] drm/tests: helpers: Remove the name parameter Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-3-051a0bb60a16@cerno.tech>
2022-11-25  9:06   ` [PATCH 03/24] drm/tests: helpers: Create the device in another function Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-4-051a0bb60a16@cerno.tech>
2022-11-25  9:25   ` [PATCH 04/24] drm/tests: helpers: Switch to a platform_device Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-5-051a0bb60a16@cerno.tech>
2022-11-25 10:19   ` [PATCH 05/24] drm/tests: helpers: Make sure the device is bound Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-6-051a0bb60a16@cerno.tech>
2022-11-25 10:46   ` [PATCH 06/24] drm/tests: kunit: Allow for a custom device struct to be allocated Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-7-051a0bb60a16@cerno.tech>
2022-11-25 10:48   ` [PATCH 07/24] drm/tests: helpers: Allow to pass a custom drm_driver Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-8-051a0bb60a16@cerno.tech>
2022-11-25 10:52   ` [PATCH 08/24] drm/tests: Add a test for DRM managed actions Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-9-051a0bb60a16@cerno.tech>
2022-11-25 10:54   ` [PATCH 09/24] drm/atomic: Constify the old/new state accessors Javier Martinez Canillas
2022-11-28 11:04   ` (subset) " Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-11-051a0bb60a16@cerno.tech>
2022-11-25 11:01   ` [PATCH 11/24] drm/vc4: Constify container_of wrappers Javier Martinez Canillas
2022-11-28 11:04   ` (subset) " Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-12-051a0bb60a16@cerno.tech>
2022-11-25 11:04   ` [PATCH 12/24] drm/vc4: Move HVS state to main header Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-17-051a0bb60a16@cerno.tech>
2022-11-25 11:13   ` [PATCH 17/24] drm/vc4: crtc: Pass the device and data in vc4_crtc_init Javier Martinez Canillas
2022-11-28 11:05   ` (subset) " Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-18-051a0bb60a16@cerno.tech>
2022-11-25 11:29   ` [PATCH 18/24] drm/vc4: crtc: Introduce a lower-level crtc init helper Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-19-051a0bb60a16@cerno.tech>
2022-11-25 11:30   ` [PATCH 19/24] drm/vc4: crtc: Make encoder lookup helper public Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-21-051a0bb60a16@cerno.tech>
2022-11-25 11:41   ` [PATCH 21/24] drm/vc4: hvs: Provide a function to initialize the HVS structure Javier Martinez Canillas
     [not found] ` <20221123-rpi-kunit-tests-v1-1-051a0bb60a16@cerno.tech>
2022-11-25  8:50   ` [PATCH 01/24] drm/tests: helpers: Rename the device init helper Javier Martinez Canillas
2022-11-25 14:10   ` Maíra Canal
2022-11-25 14:33     ` Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-10-051a0bb60a16@cerno.tech>
2022-11-25 11:00   ` [PATCH 10/24] drm/vc4: kms: Sort the CRTCs by output before assigning them Javier Martinez Canillas
2022-11-28 11:04   ` (subset) " Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-13-051a0bb60a16@cerno.tech>
2022-11-25 11:05   ` [PATCH 13/24] drm/vc4: kms: Constify the HVS old/new state helpers Javier Martinez Canillas
2022-11-28 11:04   ` (subset) " Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-14-051a0bb60a16@cerno.tech>
2022-11-25 11:07   ` [PATCH 14/24] drm/vc4: txp: Reorder the variable assignments Javier Martinez Canillas
2022-11-28 11:04   ` (subset) " Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-15-051a0bb60a16@cerno.tech>
2022-11-25 11:11   ` [PATCH 15/24] drm/vc4: Add TXP encoder type Javier Martinez Canillas
2022-11-28 11:04   ` (subset) " Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-16-051a0bb60a16@cerno.tech>
2022-11-25 11:12   ` [PATCH 16/24] drm/vc4: txp: Initialise the CRTC before the encoder and connector Javier Martinez Canillas
2022-11-28 11:04   ` (subset) " Maxime Ripard
     [not found] ` <20221123-rpi-kunit-tests-v1-20-051a0bb60a16@cerno.tech>
2022-11-25 11:32   ` [PATCH 20/24] drm/vc4: crtc: Provide a CRTC name Javier Martinez Canillas
2022-11-28 11:05   ` (subset) " Maxime Ripard

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20221124140103.saf2fyal75dscoot@houat \
    --to=maxime@cerno.tech \
    --cc=airlied@gmail.com \
    --cc=brendan.higgins@linux.dev \
    --cc=daniel@ffwll.ch \
    --cc=dave.stevenson@raspberrypi.com \
    --cc=davidgow@google.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=javierm@redhat.com \
    --cc=kunit-dev@googlegroups.com \
    --cc=linaro-mm-sig@lists.linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mairacanal@riseup.net \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).