linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jacob Pan <jacob.jun.pan@linux.intel.com>
To: Robin Murphy <robin.murphy@arm.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
	iommu@lists.linux.dev, Jason Gunthorpe <jgg@nvidia.com>,
	Lu Baolu <baolu.lu@linux.intel.com>,
	Joerg Roedel <joro@8bytes.org>,
	Jean-Philippe Brucker <jean-philippe@linaro.com>,
	Dave Hansen <dave.hansen@intel.com>,
	Thomas Gleixner <tglx@linutronix.de>, X86 Kernel <x86@kernel.org>,
	bp@alien8.de, "H. Peter Anvin" <hpa@zytor.com>,
	Peter Zijlstra <peterz@infradead.org>,
	corbet@lwn.net, vkoul@kernel.org, dmaengine@vger.kernel.org,
	linux-doc@vger.kernel.org, Will Deacon <will@kernel.org>,
	David Woodhouse <dwmw2@infradead.org>,
	Raj Ashok <ashok.raj@intel.com>,
	"Tian, Kevin" <kevin.tian@intel.com>, Yi Liu <yi.l.liu@intel.com>,
	"Yu, Fenghua" <fenghua.yu@intel.com>,
	Dave Jiang <dave.jiang@intel.com>,
	Kirill Shutemov <kirill.shutemov@linux.intel.com>,
	Tony Luck <tony.luck@intel.com>,
	jacob.jun.pan@linux.intel.com
Subject: Re: [PATCH v5 2/7] iommu/sva: Move PASID helpers to sva code
Date: Fri, 10 Mar 2023 13:36:28 -0800	[thread overview]
Message-ID: <20230310133628.290c0efa@jacob-builder> (raw)
In-Reply-To: <30923327-6c08-f0c1-1b52-c1d818f3a3a2@arm.com>

Hi Robin,

On Fri, 10 Mar 2023 20:00:52 +0000, Robin Murphy <robin.murphy@arm.com>
wrote:

> On 2023-03-09 22:21, Jacob Pan wrote:
> > Preparing to remove IOASID infrastructure, PASID management will be
> > under SVA code. Decouple mm code from IOASID. Use iommu-help.h instead
> > of iommu.h to prevent circular inclusion.
> > 
> > Signed-off-by: Jacob Pan <jacob.jun.pan@linux.intel.com>
> > ---
> > v5:
> > 	- move definition of helpers to iommu code to be consistent with
> > 	  declarations. (Kevin)
> > 	- fix patch partitioning bug (Baolu)
> > v4:
> > 	- delete and open code mm_set_pasid
> > 	- keep mm_init_pasid() as inline for fork performance
> > ---
> >   drivers/iommu/iommu-sva.c    | 10 +++++++++-
> >   include/linux/ioasid.h       |  2 +-
> >   include/linux/iommu-helper.h | 12 ++++++++++++  
> 
> Eww, can we not? iommu-helper is very much just parts of a specific type 
> of bitmap-based IOVA allocator used by some crusty old arch-specific 
> IOMMU code and SWIOTLB. It is unrelated to the iommu.h IOMMU API, and 
> dragging that stuff into modern SVA-related matters seems bizarrely 
> inappropriate. Could we just move the mm_pasid stuff into ioasid.h here, 
> then maybe rename it to iommu-sva.h at the end if eradicating the old 
> name really matters?
thanks for explaining the history behind iommu-helper.h, having a new
include/linux/iommu-sva.h would probably be cleaner.

my original intent for using iommu-helper.h was to avoid problems by mm.h
#include iommu.h. So I just needed a separate small header. let me do
without iommu-helper.h.

Thanks,

Jacob

  reply	other threads:[~2023-03-10 21:32 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-03-09 22:21 [PATCH v5 0/7] Remove VT-d virtual command interface and IOASID Jacob Pan
2023-03-09 22:21 ` Jacob Pan
2023-03-09 22:21 ` [PATCH v5 1/7] iommu/vt-d: Remove virtual command interface Jacob Pan
2023-03-09 22:21 ` [PATCH v5 2/7] iommu/sva: Move PASID helpers to sva code Jacob Pan
2023-03-10  1:43   ` Jason Gunthorpe
2023-03-10 19:23     ` Jacob Pan
2023-03-10 20:00   ` Robin Murphy
2023-03-10 21:36     ` Jacob Pan [this message]
2023-03-09 22:21 ` [PATCH v5 3/7] iommu/sva: Remove PASID to mm lookup function Jacob Pan
2023-03-10  3:44   ` Baolu Lu
2023-03-09 22:21 ` [PATCH v5 4/7] iommu/sva: Stop using ioasid_set for SVA Jacob Pan
2023-03-10  5:07   ` Baolu Lu
2023-03-10 17:52     ` Jacob Pan
2023-03-09 22:21 ` [PATCH v5 5/7] iommu/sva: Use GFP_KERNEL for pasid allocation Jacob Pan
2023-03-09 22:21 ` [PATCH v5 6/7] iommu/ioasid: Rename INVALID_IOASID Jacob Pan
2023-03-09 22:21 ` [PATCH v5 7/7] iommu: Remove ioasid infrastructure Jacob Pan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230310133628.290c0efa@jacob-builder \
    --to=jacob.jun.pan@linux.intel.com \
    --cc=ashok.raj@intel.com \
    --cc=baolu.lu@linux.intel.com \
    --cc=bp@alien8.de \
    --cc=corbet@lwn.net \
    --cc=dave.hansen@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=dmaengine@vger.kernel.org \
    --cc=dwmw2@infradead.org \
    --cc=fenghua.yu@intel.com \
    --cc=hpa@zytor.com \
    --cc=iommu@lists.linux.dev \
    --cc=jean-philippe@linaro.com \
    --cc=jgg@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peterz@infradead.org \
    --cc=robin.murphy@arm.com \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=vkoul@kernel.org \
    --cc=will@kernel.org \
    --cc=x86@kernel.org \
    --cc=yi.l.liu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).