linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: John Stultz <jstultz@google.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
	Joel Fernandes <joelaf@google.com>,
	Qais Yousef <qyousef@google.com>, Ingo Molnar <mingo@redhat.com>,
	Juri Lelli <juri.lelli@redhat.com>,
	Vincent Guittot <vincent.guittot@linaro.org>,
	Dietmar Eggemann <dietmar.eggemann@arm.com>,
	Valentin Schneider <vschneid@redhat.com>,
	Steven Rostedt <rostedt@goodmis.org>,
	Ben Segall <bsegall@google.com>,
	Zimuzo Ezeozue <zezeozue@google.com>,
	Mel Gorman <mgorman@suse.de>,
	Daniel Bristot de Oliveira <bristot@redhat.com>,
	Will Deacon <will@kernel.org>, Waiman Long <longman@redhat.com>,
	Boqun Feng <boqun.feng@gmail.com>,
	"Paul E . McKenney" <paulmck@kernel.org>
Subject: Re: [PATCH v3 08/14] sched: Replace rq->curr access w/ rq_curr(rq)
Date: Sat, 22 Apr 2023 12:42:05 +0200	[thread overview]
Message-ID: <20230422104205.GF1214746@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <20230411042511.1606592-9-jstultz@google.com>

On Tue, Apr 11, 2023 at 04:25:05AM +0000, John Stultz wrote:
> +static inline struct task_struct *rq_curr(struct rq *rq)
> +{
> +	return rq->curr_exec;
> +}
> +
> +static inline struct task_struct *rq_curr_rcu(struct rq *rq)
> +{
> +	return rcu_dereference(rq->curr_exec);
> +}
> +
> +static inline struct task_struct *rq_curr_once(struct rq *rq)
> +{
> +	return READ_ONCE(rq->curr_exec);
> +}
> +
> +static inline void rq_set_curr(struct rq *rq, struct task_struct *task)
> +{
> +	rcu_assign_pointer(rq->curr_exec, task);
> +}
> +
> +/*
> + *  XXX jstultz: seems like rcu_assign_pointer above would also
> + *               work for this, but trying to match usage.
> + */
> +static inline void rq_set_curr_rcu_init(struct rq *rq, struct task_struct *task)
> +{
> +	RCU_INIT_POINTER(rq->curr_exec, task);
> +}

> +static inline struct task_struct *rq_selected(struct rq *rq)
> +{
> +       return rq->curr_sched;
> +}
> +
> +static inline struct task_struct *rq_selected_rcu(struct rq *rq)
> +{
> +       return rcu_dereference(rq->curr_sched);
> +}
> +
> +static inline struct task_struct *rq_selected_once(struct rq *rq)
> +{
> +       return READ_ONCE(rq->curr_sched);
> +}
> +
> +static inline void rq_set_selected(struct rq *rq, struct task_struct *t)
> +{
> +       rcu_assign_pointer(rq->curr_sched, t);
> +}

How is any of that helping? That's just making it harder to read.

Can we please just keep it rq->curr and rq->proxy and stop this wrapper
fettish.

  parent reply	other threads:[~2023-04-22 10:42 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-04-11  4:24 [PATCH v3 00/14] Generalized Priority Inheritance via Proxy Execution v3 John Stultz
2023-04-11  4:24 ` [PATCH v3 01/14] locking/ww_mutex: Remove wakeups from under mutex::wait_lock John Stultz
2023-04-11  4:24 ` [PATCH v3 02/14] locking/mutex: make mutex::wait_lock irq safe John Stultz
2023-04-11  4:25 ` [PATCH v3 03/14] locking/mutex: Rework task_struct::blocked_on John Stultz
2023-04-11  4:25 ` [PATCH v3 04/14] locking/mutex: Add task_struct::blocked_lock to serialize changes to the blocked_on state John Stultz
2023-04-11  4:25 ` [PATCH v3 05/14] locking/mutex: Add p->blocked_on wrappers John Stultz
2023-04-11  4:25 ` [PATCH v3 06/14] locking/mutex: Expose mutex_owner() John Stultz
2023-04-22 10:36   ` Peter Zijlstra
2023-04-25 14:53     ` John Stultz
2023-04-11  4:25 ` [PATCH v3 07/14] sched: Unify runtime accounting across classes John Stultz
2023-04-11  4:25 ` [PATCH v3 08/14] sched: Replace rq->curr access w/ rq_curr(rq) John Stultz
2023-04-11 14:07   ` kernel test robot
2023-04-11 20:04     ` John Stultz
2023-04-22 10:42   ` Peter Zijlstra [this message]
2023-04-25 14:47     ` John Stultz
2023-04-11  4:25 ` [PATCH v3 09/14] sched: Split scheduler execution context John Stultz
2023-04-22 10:13   ` Peter Zijlstra
2023-04-22 10:14   ` Peter Zijlstra
2023-04-25 14:52     ` John Stultz
2023-04-11  4:25 ` [PATCH v3 10/14] sched: Unnest ttwu_runnable in prep for proxy-execution John Stultz
2023-04-11  4:25 ` [PATCH v3 11/14] sched: Add proxy execution John Stultz
2023-04-11  4:25 ` [PATCH v3 12/14] sched/rt: Fix proxy/current (push,pull)ability John Stultz
2023-04-11  4:25 ` [PATCH v3 13/14] sched: Attempt to fix rt/dl load balancing via chain level balance John Stultz
2023-04-11  4:25 ` [PATCH v3 14/14] sched: Fix runtime accounting w/ proxy-execution John Stultz
2023-04-22 11:54 ` [PATCH v3 00/14] Generalized Priority Inheritance via Proxy Execution v3 Peter Zijlstra

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230422104205.GF1214746@hirez.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=boqun.feng@gmail.com \
    --cc=bristot@redhat.com \
    --cc=bsegall@google.com \
    --cc=dietmar.eggemann@arm.com \
    --cc=joelaf@google.com \
    --cc=jstultz@google.com \
    --cc=juri.lelli@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=longman@redhat.com \
    --cc=mgorman@suse.de \
    --cc=mingo@redhat.com \
    --cc=paulmck@kernel.org \
    --cc=qyousef@google.com \
    --cc=rostedt@goodmis.org \
    --cc=vincent.guittot@linaro.org \
    --cc=vschneid@redhat.com \
    --cc=will@kernel.org \
    --cc=zezeozue@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).