From: Yury Norov <yury.norov@gmail.com>
To: Jakub Kicinski <kuba@kernel.org>,
netdev@vger.kernel.org, linux-rdma@vger.kernel.org,
linux-kernel@vger.kernel.org
Cc: Yury Norov <yury.norov@gmail.com>,
Saeed Mahameed <saeedm@nvidia.com>,
Pawel Chmielewski <pawel.chmielewski@intel.com>,
Leon Romanovsky <leon@kernel.org>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Paolo Abeni <pabeni@redhat.com>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Rasmus Villemoes <linux@rasmusvillemoes.dk>,
Ingo Molnar <mingo@redhat.com>,
Peter Zijlstra <peterz@infradead.org>,
Juri Lelli <juri.lelli@redhat.com>,
Vincent Guittot <vincent.guittot@linaro.org>,
Dietmar Eggemann <dietmar.eggemann@arm.com>,
Steven Rostedt <rostedt@goodmis.org>,
Ben Segall <bsegall@google.com>, Mel Gorman <mgorman@suse.de>,
Daniel Bristot de Oliveira <bristot@redhat.com>,
Valentin Schneider <vschneid@redhat.com>,
Tariq Toukan <tariqt@nvidia.com>, Gal Pressman <gal@nvidia.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Heiko Carstens <hca@linux.ibm.com>,
Barry Song <baohua@kernel.org>
Subject: [PATCH v2 0/8] sched/topology: add for_each_numa_cpu() macro
Date: Sun, 30 Apr 2023 10:18:01 -0700 [thread overview]
Message-ID: <20230430171809.124686-1-yury.norov@gmail.com> (raw)
for_each_cpu() is widely used in kernel, and it's beneficial to create
a NUMA-aware version of the macro.
Recently added for_each_numa_hop_mask() works, but switching existing
codebase to it is not an easy process.
This series adds for_each_numa_cpu(), which is designed to be similar to
the for_each_cpu(). It allows to convert existing code to NUMA-aware as
simple as adding a hop iterator variable and passing it inside new macro.
for_each_numa_cpu() takes care of the rest.
At the moment, we have 2 users of NUMA-aware enumerators. One is
Melanox's in-tree driver, and another is Intel's in-review driver:
https://lore.kernel.org/lkml/20230216145455.661709-1-pawel.chmielewski@intel.com/
Both real-life examples follow the same pattern:
for_each_numa_hop_mask(cpus, prev, node) {
for_each_cpu_andnot(cpu, cpus, prev) {
if (cnt++ == max_num)
goto out;
do_something(cpu);
}
prev = cpus;
}
With the new macro, it has a more standard look, like this:
for_each_numa_cpu(cpu, hop, node, cpu_possible_mask) {
if (cnt++ == max_num)
break;
do_something(cpu);
}
Straight conversion of existing for_each_cpu() codebase to NUMA-aware
version with for_each_numa_hop_mask() is difficult because it doesn't
take a user-provided cpu mask, and eventually ends up with open-coded
double loop. With for_each_numa_cpu() it shouldn't be a brainteaser.
Consider the NUMA-ignorant example:
cpumask_t cpus = get_mask();
int cnt = 0, cpu;
for_each_cpu(cpu, cpus) {
if (cnt++ == max_num)
break;
do_something(cpu);
}
Converting it to NUMA-aware version would be as simple as:
cpumask_t cpus = get_mask();
int node = get_node();
int cnt = 0, hop, cpu;
for_each_numa_cpu(cpu, hop, node, cpus) {
if (cnt++ == max_num)
break;
do_something(cpu);
}
The latter looks more verbose and avoids from open-coding that annoying
double loop. Another advantage is that it works with a 'hop' parameter with
the clear meaning of NUMA distance, and doesn't make people not familiar
to enumerator internals bothering with current and previous masks machinery.
v2: https://lore.kernel.org/netdev/ZD3l6FBnUh9vTIGc@yury-ThinkPad/T/
v3:
- fix sched_numa_find_{next,nth}_cpu() when CONFIG_NUMA is off to
only traverse online CPUs;
- don't export sched_domains_numa_levels for testing purposes. In
the test, use for_each_node() macro;
- extend the test for for_each_node();
- in comments, mention that only online CPUs are traversed;
- rebase on top of 6.3.
Yury Norov (8):
sched: fix sched_numa_find_nth_cpu() in non-NUMA case
lib/find: add find_next_and_andnot_bit()
sched/topology: introduce sched_numa_find_next_cpu()
sched/topology: add for_each_numa_{,online}_cpu() macro
net: mlx5: switch comp_irqs_request() to using for_each_numa_cpu
lib/cpumask: update comment to cpumask_local_spread()
sched: drop for_each_numa_hop_mask()
lib: test for_each_numa_cpus()
drivers/net/ethernet/mellanox/mlx5/core/eq.c | 16 ++---
include/linux/find.h | 43 ++++++++++++
include/linux/topology.h | 40 ++++++-----
kernel/sched/topology.c | 53 ++++++++-------
lib/cpumask.c | 7 +-
lib/find_bit.c | 12 ++++
lib/test_bitmap.c | 70 +++++++++++++++++++-
7 files changed, 183 insertions(+), 58 deletions(-)
--
2.37.2
next reply other threads:[~2023-04-30 17:18 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-04-30 17:18 Yury Norov [this message]
2023-04-30 17:18 ` [PATCH v3 1/8] sched: fix sched_numa_find_nth_cpu() in non-NUMA case Yury Norov
2023-04-30 17:18 ` [PATCH v3 2/8] lib/find: add find_next_and_andnot_bit() Yury Norov
2023-04-30 17:18 ` [PATCH v3 3/8] sched/topology: introduce sched_numa_find_next_cpu() Yury Norov
2023-04-30 17:18 ` [PATCH v3 4/8] sched/topology: add for_each_numa_{,online}_cpu() macro Yury Norov
2023-04-30 17:18 ` [PATCH v3 5/8] net: mlx5: switch comp_irqs_request() to using for_each_numa_cpu Yury Norov
2023-04-30 17:18 ` [PATCH v3 6/8] lib/cpumask: update comment to cpumask_local_spread() Yury Norov
2023-04-30 17:18 ` [PATCH v3 7/8] sched: drop for_each_numa_hop_mask() Yury Norov
2023-04-30 17:18 ` [PATCH v3 8/8] lib: test for_each_numa_cpus() Yury Norov
2023-07-22 15:47 ` Guenter Roeck
2023-07-27 2:11 ` Yury Norov
2023-05-02 16:59 ` [PATCH v2 0/8] sched/topology: add for_each_numa_cpu() macro Valentin Schneider
2023-05-02 21:58 ` Yury Norov
2023-05-03 10:00 ` Valentin Schneider
2023-05-31 15:43 ` Yury Norov
2023-05-31 17:01 ` Jakub Kicinski
2023-05-31 17:08 ` Yury Norov
2023-05-31 17:36 ` Jakub Kicinski
-- strict thread matches above, loose matches on Subject: below --
2023-04-20 5:19 Yury Norov
2023-04-15 5:06 Yury Norov
2023-04-17 11:11 ` Peter Zijlstra
2023-04-18 0:51 ` Yury Norov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230430171809.124686-1-yury.norov@gmail.com \
--to=yury.norov@gmail.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=baohua@kernel.org \
--cc=bristot@redhat.com \
--cc=bsegall@google.com \
--cc=davem@davemloft.net \
--cc=dietmar.eggemann@arm.com \
--cc=edumazet@google.com \
--cc=gal@nvidia.com \
--cc=gregkh@linuxfoundation.org \
--cc=hca@linux.ibm.com \
--cc=juri.lelli@redhat.com \
--cc=kuba@kernel.org \
--cc=leon@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rdma@vger.kernel.org \
--cc=linux@rasmusvillemoes.dk \
--cc=mgorman@suse.de \
--cc=mingo@redhat.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=pawel.chmielewski@intel.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=saeedm@nvidia.com \
--cc=tariqt@nvidia.com \
--cc=vincent.guittot@linaro.org \
--cc=vschneid@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).