linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Daniel Bristot de Oliveira <bristot@redhat.com>
To: Borislav Petkov <bp@alien8.de>
Cc: linux-kernel@vger.kernel.org,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, "H. Peter Anvin" <hpa@zytor.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Pavel Tatashin <pasha.tatashin@oracle.com>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	"Steven Rostedt (VMware)" <rostedt@goodmis.org>,
	Zhou Chengming <zhouchengming1@huawei.com>,
	Jiri Kosina <jkosina@suse.cz>,
	Josh Poimboeuf <jpoimboe@redhat.com>,
	"Peter Zijlstra (Intel)" <peterz@infradead.org>,
	Chris von Recklinghausen <crecklin@redhat.com>,
	Jason Baron <jbaron@akamai.com>, Scott Wood <swood@redhat.com>,
	Marcelo Tosatti <mtosatti@redhat.com>,
	Clark Williams <williams@redhat.com>,
	x86@kernel.org
Subject: Re: [PATCH V2 1/9] jump_label: Add for_each_label_entry helper
Date: Wed, 19 Dec 2018 08:38:03 +0100	[thread overview]
Message-ID: <21a12942-2813-9b8a-9051-582070b5eda5@redhat.com> (raw)
In-Reply-To: <20181218211923.GM7485@zn.tnic>

On 12/18/18 10:19 PM, Borislav Petkov wrote:
> On Tue, Dec 18, 2018 at 05:46:30PM +0100, Daniel Bristot de Oliveira wrote:
>> This patch adds the helper:
>> 	for_each_label_entry(key, entry, stop)
>>
>> For the "for each jump label entry" for defined as:
>> 	for (; (entry < stop) && (jump_entry_key(entry) == key); entry++)
>>
>> Simplifying the reading and usage.
> 
> Please avoid writing "This patch" in a commit message and also what it
> does - that should be obvious. Instead say something like:
> 
> "Add a helper macro to make jump entry iteration code more readable."
> 
> or so.

Right! I will change it!

> But then, IINM, this macro is being used only once. Isn't that a bit too
> much? I mean, you could just as well do:
> 
> 	# iterate over each jump entry
> 	for (; (entry < stop) && (jump_entry_key(entry) == key); entry++) {
> 
> and have it even more readable without introducing macro which is not
> going to be used elsewhere. Or is it going to...?

It is also used in the patch 9. But I can remove it, no problem.

Thoughts?

Thanks!

-- Daniel


  reply	other threads:[~2018-12-19  7:38 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-12-18 16:46 [PATCH V2 0/9] x86/jump_label: Bound IPIs sent when updating a static key Daniel Bristot de Oliveira
2018-12-18 16:46 ` [PATCH V2 1/9] jump_label: Add for_each_label_entry helper Daniel Bristot de Oliveira
2018-12-18 21:19   ` Borislav Petkov
2018-12-19  7:38     ` Daniel Bristot de Oliveira [this message]
2018-12-19 10:37       ` Borislav Petkov
2018-12-18 16:46 ` [PATCH V2 2/9] jump_label: Add the jump_label_can_update_check() helper Daniel Bristot de Oliveira
2018-12-18 16:46 ` [PATCH V2 3/9] x86/jump_label: Move checking code away from __jump_label_transform() Daniel Bristot de Oliveira
2018-12-19  8:43   ` Jiri Kosina
2018-12-19  8:49     ` Thomas Gleixner
2018-12-19 10:14       ` Daniel Bristot de Oliveira
2018-12-18 16:46 ` [PATCH V2 4/9] x86/jump_label: Add __jump_label_set_jump_code() helper Daniel Bristot de Oliveira
2018-12-18 16:46 ` [PATCH V2 5/9] x86/alternative: Split text_poke_bp() into tree steps Daniel Bristot de Oliveira
2018-12-18 17:25   ` Steven Rostedt
2018-12-19  8:44   ` Jiri Kosina
2018-12-18 16:46 ` [PATCH V2 6/9] jump_label: Sort entries of the same key by the code Daniel Bristot de Oliveira
2018-12-18 16:46 ` [PATCH V2 7/9] x86/alternative: Batch of patch operations Daniel Bristot de Oliveira
2018-12-18 17:31   ` Steven Rostedt
2018-12-18 19:27     ` Daniel Bristot de Oliveira
2018-12-18 16:46 ` [PATCH V2 8/9] x86/jump_label: Batch jump label updates Daniel Bristot de Oliveira
2018-12-18 16:46 ` [PATCH V2 9/9] jump_label: Batch up if arch supports it Daniel Bristot de Oliveira
2018-12-18 17:35   ` Steven Rostedt
2018-12-18 19:33     ` Daniel Bristot de Oliveira
2018-12-18 20:32       ` Steven Rostedt
2018-12-18 21:06         ` Daniel Bristot de Oliveira

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=21a12942-2813-9b8a-9051-582070b5eda5@redhat.com \
    --to=bristot@redhat.com \
    --cc=bp@alien8.de \
    --cc=crecklin@redhat.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hpa@zytor.com \
    --cc=jbaron@akamai.com \
    --cc=jkosina@suse.cz \
    --cc=jpoimboe@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mhiramat@kernel.org \
    --cc=mingo@redhat.com \
    --cc=mtosatti@redhat.com \
    --cc=pasha.tatashin@oracle.com \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=swood@redhat.com \
    --cc=tglx@linutronix.de \
    --cc=williams@redhat.com \
    --cc=x86@kernel.org \
    --cc=zhouchengming1@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).