linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Rocky Liao <rjliao@codeaurora.org>
To: Matthias Kaehlcke <mka@chromium.org>
Cc: marcel@holtmann.org, johan.hedberg@gmail.com,
	linux-kernel@vger.kernel.org, linux-bluetooth@vger.kernel.org,
	linux-arm-msm@vger.kernel.org,
	linux-bluetooth-owner@vger.kernel.org
Subject: Re: [PATCH v2 1/3] Bluetooth: hci_qca: Add qca_power_on() API to support both wcn399x and Rome power up
Date: Thu, 09 Jan 2020 11:37:15 +0800	[thread overview]
Message-ID: <24228a5c46c0fc811735e48b1efdcb4f@codeaurora.org> (raw)
In-Reply-To: <671e08d94aa70dc315fbaae0ba3429e4@codeaurora.org>

在 2020-01-09 11:22,Rocky Liao 写道:
> Hi Matt,
> 
> 在 2020-01-09 02:34,Matthias Kaehlcke 写道:
>> Hi Rocky,
>> 
>> On Wed, Jan 08, 2020 at 05:08:02PM +0800, Rocky Liao wrote:
>>> This patch adds a unified API qca_power_on() to support both wcn399x 
>>> and
>>> Rome power on. For wcn399x it calls the qca_wcn3990_init() to init 
>>> the
>>> regulators, and for Rome it pulls up the bt_en GPIO to power up the 
>>> btsoc.
>>> 
>>> Signed-off-by: Rocky Liao <rjliao@codeaurora.org>
>>> ---
>>> 
>>> Changes in v2: None
>>> 
>>>  drivers/bluetooth/hci_qca.c | 21 +++++++++++++++++++++
>>>  1 file changed, 21 insertions(+)
>>> 
>>> diff --git a/drivers/bluetooth/hci_qca.c 
>>> b/drivers/bluetooth/hci_qca.c
>>> index 9392cc7f9908..f6555bd1adbc 100644
>>> --- a/drivers/bluetooth/hci_qca.c
>>> +++ b/drivers/bluetooth/hci_qca.c
>>> @@ -1532,6 +1532,27 @@ static int qca_wcn3990_init(struct hci_uart 
>>> *hu)
>>>  	return 0;
>>>  }
>>> 
>>> +static int qca_power_on(struct hci_dev *hdev)
>>> +{
>>> +	struct hci_uart *hu = hci_get_drvdata(hdev);
>>> +	enum qca_btsoc_type soc_type = qca_soc_type(hu);
>>> +	struct qca_serdev *qcadev;
>>> +	int ret = 0;
>>> +
>>> +	if (qca_is_wcn399x(soc_type)) {
>> 
>> Why not include the qca_regulator_enable() call from qca_open() here?
>> It is clearly part of power on.
>> 
> OK
> 
qca_wcn3990_init() already have the qca_regulator_enable() call, so we 
just
need to remove it from qca_open().

>>> +		ret = qca_wcn3990_init(hu);
>>> +	} else {
>>> +		if (hu->serdev) {
>> 
>> nit: you could save a level of indentation (and IMO improve
>> readability) by doing:
>> 
>>      	       if (!hu->serdev)
>> 	            	return 0;
>> 
> OK
> 
>>> +			qcadev = serdev_device_get_drvdata(hu->serdev);
>>> +			gpiod_set_value_cansleep(qcadev->bt_en, 1);
>>> +			/* Controller needs time to bootup. */
>>> +			msleep(150);
>>> +		}
>>> +	}
>>> +
>>> +	return ret;
>>> +}
>>> +
>> 
>> I think common practice would be to combine the 3 patches of this 
>> series
>> into one. The new function doesn't really add any new functionality, 
>> but
>> is a refactoring. This is more evident if you see in a single diff 
>> that
>> the pieces in qca_power_on() are removed elsewhere.
> OK

  reply	other threads:[~2020-01-09  3:37 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-07  5:26 [PATCH v1] Bluetooth: hci_qca: Add qca_power_on() API to support both wcn399x and Rome power up Rocky Liao
2020-01-07 17:31 ` Matthias Kaehlcke
2020-01-08  3:02   ` Rocky Liao
2020-01-08  9:08 ` [PATCH v2 1/3] " Rocky Liao
2020-01-08  9:08   ` [PATCH v2 2/3] Bluetooth: hci_qca: Move the power on from open() to setup() for QCA Rome Rocky Liao
2020-01-08  9:08   ` [PATCH v2 3/3] Bluetooth: hci_qca: Use unified API qca_power_on() to power up wcn399x Rocky Liao
2020-01-08 18:34   ` [PATCH v2 1/3] Bluetooth: hci_qca: Add qca_power_on() API to support both wcn399x and Rome power up Matthias Kaehlcke
2020-01-09  3:22     ` Rocky Liao
2020-01-09  3:37       ` Rocky Liao [this message]
2020-01-09  5:14 ` [PATCH v3] " Rocky Liao
2020-01-09 19:05   ` Matthias Kaehlcke
2020-01-10  3:07     ` Rocky Liao
2020-01-10  3:32 ` [PATCH v4] " Rocky Liao
2020-01-11  0:31   ` Matthias Kaehlcke
2020-01-13  3:53     ` Rocky Liao
2020-01-13  4:29 ` Rocky Liao
2020-01-13  4:31   ` Rocky Liao
2020-01-13  4:31   ` Rocky Liao
2020-01-13  4:30 ` [PATCH v5] " Rocky Liao
2020-01-14 13:55   ` Marcel Holtmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=24228a5c46c0fc811735e48b1efdcb4f@codeaurora.org \
    --to=rjliao@codeaurora.org \
    --cc=johan.hedberg@gmail.com \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-bluetooth-owner@vger.kernel.org \
    --cc=linux-bluetooth@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marcel@holtmann.org \
    --cc=mka@chromium.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).