linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ziji Hu <huziji@marvell.com>
To: Ulf Hansson <ulf.hansson@linaro.org>,
	Gregory CLEMENT <gregory.clement@free-electrons.com>
Cc: Adrian Hunter <adrian.hunter@intel.com>,
	"linux-mmc@vger.kernel.org" <linux-mmc@vger.kernel.org>,
	Jason Cooper <jason@lakedaemon.net>, Andrew Lunn <andrew@lunn.ch>,
	Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>,
	Thomas Petazzoni <thomas.petazzoni@free-electrons.com>,
	"linux-arm-kernel@lists.infradead.org" 
	<linux-arm-kernel@lists.infradead.org>,
	Mike Turquette <mturquette@baylibre.com>,
	Stephen Boyd <sboyd@codeaurora.org>,
	linux-clk <linux-clk@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Rob Herring <robh+dt@kernel.org>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	Jimmy Xu <zmxu@marvell.com>, Jisheng Zhang <jszhang@marvell.com>,
	Nadav Haklai <nadavh@marvell.com>, Ryan Gao <ygao@marvell.com>,
	Doug Jones <dougj@marvell.com>, Victor Gu <xigu@marvell.com>,
	"Wei(SOCP) Liu" <liuw@marvell.com>,
	Wilson Ding <dingwei@marvell.com>,
	Yehuda Yitschak <yehuday@marvell.com>,
	Marcin Wojtas <mw@semihalf.com>, Hanna Hawa <hannah@marvell.com>,
	Kostya Porotchkin <kostap@marvell.com>
Subject: Re: [PATCH v6 09/14] mmc: sdhci-xenon: Add support to PHYs of Marvell Xenon SDHC
Date: Wed, 15 Mar 2017 22:31:53 +0800	[thread overview]
Message-ID: <288b58dc-cce7-11c3-e946-7bf0ea5a4863@marvell.com> (raw)
In-Reply-To: <CAPDyKFrQb3NA53o6z9go0+RxxvstwWdeLHpiXtKaXOksxrov3g@mail.gmail.com>

Hi Ulf,

On 2017/3/15 21:39, Ulf Hansson wrote:
> On 14 February 2017 at 18:01, Gregory CLEMENT
> <gregory.clement@free-electrons.com> wrote:
>> From: Hu Ziji <huziji@marvell.com>
>>
<snip>
>> +
>> +       /*
>> +        * FIXME: should depends on the specific board timing.
>> +        */
>> +       if ((timing == MMC_TIMING_MMC_HS400) ||
>> +           (timing == MMC_TIMING_MMC_HS200) ||
>> +           (timing == MMC_TIMING_UHS_SDR50) ||
>> +           (timing == MMC_TIMING_UHS_SDR104) ||
>> +           (timing == MMC_TIMING_UHS_DDR50) ||
>> +           (timing == MMC_TIMING_UHS_SDR25) ||
>> +           (timing == MMC_TIMING_MMC_DDR52)) {
>> +               reg = sdhci_readl(host, phy_regs->timing_adj);
>> +               reg &= ~XENON_OUTPUT_QSN_PHASE_SELECT;
>> +               sdhci_writel(host, reg, phy_regs->timing_adj);
>> +       }
>> +
<snip>
>> +
>> +       reg = sdhci_readl(host, phy_regs->func_ctrl);
>> +       if ((timing == MMC_TIMING_UHS_DDR50) ||
>> +           (timing == MMC_TIMING_MMC_HS400) ||
>> +           (timing == MMC_TIMING_MMC_DDR52))
>> +               reg |= (XENON_DQ_DDR_MODE_MASK << XENON_DQ_DDR_MODE_SHIFT) |
>> +                      XENON_CMD_DDR_MODE;
>> +       else
>> +               reg &= ~((XENON_DQ_DDR_MODE_MASK << XENON_DQ_DDR_MODE_SHIFT) |
>> +                        XENON_CMD_DDR_MODE);
<snip>
> 
> Again you are checking the MMC_TIMING_* in several if statements.
> Perhaps you can use switch statement instead and build a couple of
> different register variables, that you use when reading/writing
> afterwards.
> 

	Sorry. I don't quite understand your comment.
	Do you mean combine all the related  register settings
	under a specific MMC_TIMING_*?

	swhich (timing) {
	case MMC_TIMING_HS400:
		config reg_1;
		config reg_2;
		...
	case MMC_TIMING_HS200:
		config reg_2;
		config reg_3
		..
	case ...
	};

	I have a little concern that there might be a lot
	of duplicate register settings. Some PHY operations are
	irrelevant to the speed mode. They have to be executed in
	a particular sequence in all speed modes.

>> +}
>> +
>> +static int emmc_phy_parse_param_dt(struct sdhci_host *host,
>> +                                  struct device_node *np,
>> +                                  struct emmc_phy_params *params)
>> +{
>> +       u32 value;
>> +
>> +       if (of_property_read_bool(np, "marvell,xenon-phy-slow-mode"))
>> +               params->slow_mode = true;
>> +       else
>> +               params->slow_mode = false;
>> +
>> +       if (!of_property_read_u32(np, "marvell,xenon-phy-znr", &value))
>> +               params->znr = value & XENON_ZNR_MASK;
>> +       else
>> +               params->znr = XENON_ZNR_DEF_VALUE;
>> +
>> +       if (!of_property_read_u32(np, "marvell,xenon-phy-zpr", &value))
>> +               params->zpr = value & XENON_ZPR_MASK;
>> +       else
>> +               params->zpr = XENON_ZPR_DEF_VALUE;
>> +
>> +       if (!of_property_read_u32(np, "marvell,xenon-phy-nr-success-tun",
>> +                                 &value))
>> +               params->nr_tun_times = value & XENON_TUN_CONSECUTIVE_TIMES_MASK;
>> +       else
>> +               params->nr_tun_times = XENON_TUN_CONSECUTIVE_TIMES;
>> +
>> +       if (!of_property_read_u32(np, "marvell,xenon-phy-tun-step-divider",
>> +                                 &value))
>> +               params->tun_step_divider = value & 0xFF;
>> +       else
>> +               params->tun_step_divider = XENON_TUNING_STEP_DIVIDER;
>> +
>> +       return 0;
> 
> Instead of all these if-else, let's start by assigning default values
> instead. This makes the code more readable.
> 
	Sure. I'll change it.
	
>> +}
>> +
>> +/*
>> + * Setting PHY when card is working in High Speed Mode.
>> + * HS400 set data strobe line.
>> + * HS200/SDR104 set tuning config to prepare for tuning.
>> + */
>> +static int xenon_hs_delay_adj(struct sdhci_host *host)
>> +{
>> +       int ret = 0;
>> +
>> +       if (WARN_ON(host->clock <= XENON_DEFAULT_SDCLK_FREQ))
>> +               return -EINVAL;
>> +
>> +       if (host->timing == MMC_TIMING_MMC_HS400) {
>> +               emmc_phy_strobe_delay_adj(host);
>> +               return 0;
>> +       }
>> +
>> +       if ((host->timing == MMC_TIMING_MMC_HS200) ||
>> +           (host->timing == MMC_TIMING_UHS_SDR104))
>> +               return emmc_phy_config_tuning(host);
>> +
>> +       /*
>> +        * DDR Mode requires driver to scan Sampling Fixed Delay Line,
>> +        * to find out a perfect operation sampling point.
>> +        * It is hard to implement such a scan in host driver since initiating
>> +        * commands by host driver is not safe.
>> +        * Thus so far just keep PHY Sampling Fixed Delay in default value
>> +        * in DDR mode.
>> +        *
>> +        * If any timing issue occurs in DDR mode on Marvell products,
>> +        * please contact maintainer to ask for internal support in Marvell.
>> +        */
>> +       if ((host->timing == MMC_TIMING_MMC_DDR52) ||
>> +           (host->timing == MMC_TIMING_UHS_DDR50))
>> +               dev_warn_once(mmc_dev(host->mmc), "Timing issue might occur in DDR mode\n");
> 
> Please consider a to convert to use a switch statment instead of the
> several if statements.
> 

	It is a good idea to use switch here.

>> +       return ret;
>> +}
>> +
> 
<snip>
>> +int xenon_phy_parse_dt(struct device_node *np, struct sdhci_host *host)
>> +{
>> +       const char *phy_type = NULL;
>> +
>> +       if (!of_property_read_string(np, "marvell,xenon-phy-type", &phy_type))
>> +               return add_xenon_phy(np, host, phy_type);
>> +
>> +       dev_info(mmc_dev(host->mmc), "Fail to get Xenon PHY type. Use default eMMC 5.1 PHY\n");
> 
> Isn't there already a dev_err() being printed for this case. You
> probably only need one.

	By default, "emmc 5.1 phy" is used on most of our products.
	Thus this dt property is an optional one.
	I can remove this dev_info.

> 
>> +       return add_xenon_phy(np, host, "emmc 5.1 phy");
>> +}
> 
> [...]
> 
> Kind regards
> Uffe
> 

  reply	other threads:[~2017-03-15 14:33 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-02-14 17:01 [PATCH v6 00/14] mmc: Add support to Marvell Xenon SD Host Controller Gregory CLEMENT
2017-02-14 17:01 ` [PATCH v6 01/14] clk: apn806: Add eMMC clock to system controller driver Gregory CLEMENT
2017-02-14 17:01 ` [PATCH v6 02/14] clk: apn806: Turn the eMMC clock as optional for dts backwards compatible Gregory CLEMENT
2017-02-14 17:01 ` [PATCH v6 03/14] mmc: core: Add mmc-card dt sub-node parse in core layer Gregory CLEMENT
2017-03-15 12:43   ` Ulf Hansson
2017-03-15 13:46     ` Ziji Hu
2017-03-22 17:11     ` Gregory CLEMENT
2017-02-14 17:01 ` [PATCH v6 04/14] mmc: sdhci: Export sdhci_set_ios() from sdhci.c Gregory CLEMENT
2017-03-22 14:48   ` Adrian Hunter
2017-02-14 17:01 ` [PATCH v6 05/14] mmc: sdhci: Export sdhci_start_signal_voltage_switch() in sdhci.c Gregory CLEMENT
2017-03-22 14:49   ` Adrian Hunter
2017-02-14 17:01 ` [PATCH v6 06/14] mmc: sdhci: Export sdhci_enable_sdio_irq() from sdhci.c Gregory CLEMENT
2017-03-22 14:49   ` Adrian Hunter
2017-02-14 17:01 ` [PATCH v6 07/14] dt: bindings: Add bindings for Marvell Xenon SD Host Controller Gregory CLEMENT
2017-02-22 21:44   ` Rob Herring
2017-03-15 12:48   ` Ulf Hansson
2017-03-23  5:32     ` [EXT] " Ziji Hu
2017-02-14 17:01 ` [PATCH v6 08/14] mmc: sdhci-xenon: Add Marvell Xenon SDHC core functionality Gregory CLEMENT
2017-03-15 13:11   ` Ulf Hansson
2017-03-15 13:58     ` Ziji Hu
2017-03-16  2:24       ` Jisheng Zhang
2017-03-22 14:32   ` Adrian Hunter
2017-02-14 17:01 ` [PATCH v6 09/14] mmc: sdhci-xenon: Add support to PHYs of Marvell Xenon SDHC Gregory CLEMENT
2017-03-15 13:39   ` Ulf Hansson
2017-03-15 14:31     ` Ziji Hu [this message]
2017-03-22 14:33   ` Adrian Hunter
2017-02-14 17:01 ` [PATCH v6 10/14] mmc: sdhci-xenon: Add SoC PHY PAD voltage control Gregory CLEMENT
2017-03-22 14:47   ` Adrian Hunter
2017-02-14 17:01 ` [PATCH v6 11/14] MAINTAINERS: add entry for Marvell Xenon MMC Host Controller drivers Gregory CLEMENT
2017-02-14 17:01 ` [PATCH v6 12/14] arm64: dts: marvell: add eMMC support for Armada 37xx Gregory CLEMENT
2017-02-14 17:01 ` [PATCH v6 13/14] arm64: dts: marvell: add sdhci support for Armada 7K/8K Gregory CLEMENT
2017-02-14 17:01 ` [PATCH v6 14/14] arm64: configs: enable SDHCI driver for Xenon Gregory CLEMENT
2017-02-20 16:59 ` [PATCH v6 00/14] mmc: Add support to Marvell Xenon SD Host Controller Gregory CLEMENT
2017-02-20 19:32   ` Ulf Hansson
2017-02-27  9:41     ` Ziji Hu
2017-03-10 10:15     ` Gregory CLEMENT
2017-02-20 17:07 ` Russell King - ARM Linux

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=288b58dc-cce7-11c3-e946-7bf0ea5a4863@marvell.com \
    --to=huziji@marvell.com \
    --cc=adrian.hunter@intel.com \
    --cc=andrew@lunn.ch \
    --cc=devicetree@vger.kernel.org \
    --cc=dingwei@marvell.com \
    --cc=dougj@marvell.com \
    --cc=gregory.clement@free-electrons.com \
    --cc=hannah@marvell.com \
    --cc=jason@lakedaemon.net \
    --cc=jszhang@marvell.com \
    --cc=kostap@marvell.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-clk@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mmc@vger.kernel.org \
    --cc=liuw@marvell.com \
    --cc=mturquette@baylibre.com \
    --cc=mw@semihalf.com \
    --cc=nadavh@marvell.com \
    --cc=robh+dt@kernel.org \
    --cc=sboyd@codeaurora.org \
    --cc=sebastian.hesselbarth@gmail.com \
    --cc=thomas.petazzoni@free-electrons.com \
    --cc=ulf.hansson@linaro.org \
    --cc=xigu@marvell.com \
    --cc=yehuday@marvell.com \
    --cc=ygao@marvell.com \
    --cc=zmxu@marvell.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).