linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Kirill Tkhai <ktkhai@virtuozzo.com>
To: Vladimir Davydov <vdavydov.dev@gmail.com>
Cc: akpm@linux-foundation.org, shakeelb@google.com,
	viro@zeniv.linux.org.uk, hannes@cmpxchg.org, mhocko@kernel.org,
	tglx@linutronix.de, pombredanne@nexb.com,
	stummala@codeaurora.org, gregkh@linuxfoundation.org,
	sfr@canb.auug.org.au, guro@fb.com, mka@chromium.org,
	penguin-kernel@I-love.SAKURA.ne.jp, chris@chris-wilson.co.uk,
	longman@redhat.com, minchan@kernel.org, ying.huang@intel.com,
	mgorman@techsingularity.net, jbacik@fb.com, linux@roeck-us.net,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	willy@infradead.org, lirongqing@baidu.com,
	aryabinin@virtuozzo.com
Subject: Re: [PATCH v6 12/17] mm: Set bit in memcg shrinker bitmap on first list_lru item apearance
Date: Mon, 21 May 2018 12:31:34 +0300	[thread overview]
Message-ID: <2a0ca70d-12bb-8087-9897-9cb33f676177@virtuozzo.com> (raw)
In-Reply-To: <20180520075558.6ls4yzrkou63orkb@esperanza>

On 20.05.2018 10:55, Vladimir Davydov wrote:
> On Fri, May 18, 2018 at 11:43:42AM +0300, Kirill Tkhai wrote:
>> Introduce set_shrinker_bit() function to set shrinker-related
>> bit in memcg shrinker bitmap, and set the bit after the first
>> item is added and in case of reparenting destroyed memcg's items.
>>
>> This will allow next patch to make shrinkers be called only,
>> in case of they have charged objects at the moment, and
>> to improve shrink_slab() performance.
>>
>> Signed-off-by: Kirill Tkhai <ktkhai@virtuozzo.com>
>> ---
>>  include/linux/memcontrol.h |   14 ++++++++++++++
>>  mm/list_lru.c              |   22 ++++++++++++++++++++--
>>  2 files changed, 34 insertions(+), 2 deletions(-)
>>
>> diff --git a/include/linux/memcontrol.h b/include/linux/memcontrol.h
>> index e51c6e953d7a..7ae1b94becf3 100644
>> --- a/include/linux/memcontrol.h
>> +++ b/include/linux/memcontrol.h
>> @@ -1275,6 +1275,18 @@ static inline int memcg_cache_id(struct mem_cgroup *memcg)
>>  
>>  extern int memcg_expand_shrinker_maps(int new_id);
>>  
>> +static inline void memcg_set_shrinker_bit(struct mem_cgroup *memcg,
>> +					  int nid, int shrinker_id)
>> +{
> 
>> +	if (shrinker_id >= 0 && memcg && memcg != root_mem_cgroup) {
> 
> Nit: I'd remove these checks from this function and require the caller
> to check that shrinker_id >= 0 and memcg != NULL or root_mem_cgroup.
> See below how the call sites would look then.
> 
>> +		struct memcg_shrinker_map *map;
>> +
>> +		rcu_read_lock();
>> +		map = rcu_dereference(memcg->nodeinfo[nid]->shrinker_map);
>> +		set_bit(shrinker_id, map->map);
>> +		rcu_read_unlock();
>> +	}
>> +}
>>  #else
>>  #define for_each_memcg_cache_index(_idx)	\
>>  	for (; NULL; )
>> @@ -1297,6 +1309,8 @@ static inline void memcg_put_cache_ids(void)
>>  {
>>  }
>>  
>> +static inline void memcg_set_shrinker_bit(struct mem_cgroup *memcg,
>> +					  int nid, int shrinker_id) { }
>>  #endif /* CONFIG_MEMCG_KMEM */
>>  
>>  #endif /* _LINUX_MEMCONTROL_H */
>> diff --git a/mm/list_lru.c b/mm/list_lru.c
>> index cab8fad7f7e2..7df71ab0de1c 100644
>> --- a/mm/list_lru.c
>> +++ b/mm/list_lru.c
>> @@ -31,6 +31,11 @@ static void list_lru_unregister(struct list_lru *lru)
>>  	mutex_unlock(&list_lrus_mutex);
>>  }
>>  
>> +static int lru_shrinker_id(struct list_lru *lru)
>> +{
>> +	return lru->shrinker_id;
>> +}
>> +
>>  static inline bool list_lru_memcg_aware(struct list_lru *lru)
>>  {
>>  	/*
>> @@ -94,6 +99,11 @@ static void list_lru_unregister(struct list_lru *lru)
>>  {
>>  }
>>  
>> +static int lru_shrinker_id(struct list_lru *lru)
>> +{
>> +	return -1;
>> +}
>> +
>>  static inline bool list_lru_memcg_aware(struct list_lru *lru)
>>  {
>>  	return false;
>> @@ -119,13 +129,17 @@ bool list_lru_add(struct list_lru *lru, struct list_head *item)
>>  {
>>  	int nid = page_to_nid(virt_to_page(item));
>>  	struct list_lru_node *nlru = &lru->node[nid];
>> +	struct mem_cgroup *memcg;
>>  	struct list_lru_one *l;
>>  
>>  	spin_lock(&nlru->lock);
>>  	if (list_empty(item)) {
>> -		l = list_lru_from_kmem(nlru, item, NULL);
>> +		l = list_lru_from_kmem(nlru, item, &memcg);
>>  		list_add_tail(item, &l->list);
>> -		l->nr_items++;
>> +		/* Set shrinker bit if the first element was added */
>> +		if (!l->nr_items++)
>> +			memcg_set_shrinker_bit(memcg, nid,
>> +					       lru_shrinker_id(lru));
> 
> This would turn into
> 
> 	if (!l->nr_items++ && memcg)
> 		memcg_set_shrinker_bit(memcg, nid, lru_shrinker_id(lru));
> 
> Note, you don't need to check that lru_shrinker_id(lru) is >= 0 here as
> the fact that memcg != NULL guarantees that. Also, memcg can't be
> root_mem_cgroup here as kmem objects allocated for the root cgroup go
> unaccounted.
> 
>>  		nlru->nr_items++;
>>  		spin_unlock(&nlru->lock);
>>  		return true;
>> @@ -520,6 +534,7 @@ static void memcg_drain_list_lru_node(struct list_lru *lru, int nid,
>>  	struct list_lru_node *nlru = &lru->node[nid];
>>  	int dst_idx = dst_memcg->kmemcg_id;
>>  	struct list_lru_one *src, *dst;
>> +	bool set;
>>  
>>  	/*
>>  	 * Since list_lru_{add,del} may be called under an IRQ-safe lock,
>> @@ -531,7 +546,10 @@ static void memcg_drain_list_lru_node(struct list_lru *lru, int nid,
>>  	dst = list_lru_from_memcg_idx(nlru, dst_idx);
>>  
>>  	list_splice_init(&src->list, &dst->list);
>> +	set = (!dst->nr_items && src->nr_items);
>>  	dst->nr_items += src->nr_items;
>> +	if (set)
>> +		memcg_set_shrinker_bit(dst_memcg, nid, lru_shrinker_id(lru));
> 
> This would turn into
> 
> 	if (set && dst_idx >= 0)
> 		memcg_set_shrinker_bit(dst_memcg, nid, lru_shrinker_id(lru));
> 
> Again, the shrinker is guaranteed to be memcg aware in this function and
> dst_memcg != NULL.
> 
> IMHO such a change would make the code a bit more straightforward.

IMHO, this makes the code less readable. Using single generic function with
generic check is easier, then using two different checks for different places.
Next a person, who will modify the logic, does not have to think about particulars
of strange checks in list_lru_add() and memcg_drain_list_lru_node(), if he/she
does not involved in the change of maps logic. Memory cgroup is already fell
into many corner cases, let's do not introduce them in new places.

>>  	src->nr_items = 0;
>>  
>>  	spin_unlock_irq(&nlru->lock);

Kirill

  reply	other threads:[~2018-05-21  9:31 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-18  8:41 [PATCH v6 00/17] Improve shrink_slab() scalability (old complexity was O(n^2), new is O(n)) Kirill Tkhai
2018-05-18  8:41 ` [PATCH v6 01/17] list_lru: Combine code under the same define Kirill Tkhai
2018-05-18  8:41 ` [PATCH v6 02/17] mm: Introduce CONFIG_MEMCG_KMEM as combination of CONFIG_MEMCG && !CONFIG_SLOB Kirill Tkhai
2018-05-18  8:42 ` [PATCH v6 03/17] mm: Assign id to every memcg-aware shrinker Kirill Tkhai
2018-05-20  7:08   ` Vladimir Davydov
2018-05-18  8:42 ` [PATCH v6 04/17] memcg: Move up for_each_mem_cgroup{, _tree} defines Kirill Tkhai
2018-05-18  8:42 ` [PATCH v6 05/17] mm: Assign memcg-aware shrinkers bitmap to memcg Kirill Tkhai
2018-05-20  7:27   ` Vladimir Davydov
2018-05-21 10:16     ` Kirill Tkhai
2018-05-21 18:40       ` Vladimir Davydov
2018-05-18  8:42 ` [PATCH v6 06/17] mm: Refactoring in workingset_init() Kirill Tkhai
2018-05-18  8:42 ` [PATCH v6 07/17] fs: Refactoring in alloc_super() Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 08/17] fs: Propagate shrinker::id to list_lru Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 09/17] list_lru: Add memcg argument to list_lru_from_kmem() Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 10/17] list_lru: Pass dst_memcg argument to memcg_drain_list_lru_node() Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 11/17] list_lru: Pass lru " Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 12/17] mm: Set bit in memcg shrinker bitmap on first list_lru item apearance Kirill Tkhai
2018-05-20  7:55   ` Vladimir Davydov
2018-05-21  9:31     ` Kirill Tkhai [this message]
2018-05-21 18:16       ` Vladimir Davydov
2018-05-18  8:43 ` [PATCH v6 13/17] mm: Export mem_cgroup_is_root() Kirill Tkhai
2018-05-20  7:57   ` Vladimir Davydov
2018-05-18  8:44 ` [PATCH v6 14/17] mm: Iterate only over charged shrinkers during memcg shrink_slab() Kirill Tkhai
2018-05-20  8:00   ` Vladimir Davydov
2018-05-21  9:17     ` Kirill Tkhai
2018-05-21 17:56       ` Vladimir Davydov
2018-05-18  8:44 ` [PATCH v6 15/17] mm: Generalize shrink_slab() calls in shrink_node() Kirill Tkhai
2018-05-20  8:08   ` Vladimir Davydov
2018-05-21  9:19     ` Kirill Tkhai
2018-05-18  8:44 ` [PATCH v6 16/17] mm: Add SHRINK_EMPTY shrinker methods return value Kirill Tkhai
2018-05-18  8:44 ` [PATCH v6 17/17] mm: Clear shrinker bit if there are no objects related to memcg Kirill Tkhai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2a0ca70d-12bb-8087-9897-9cb33f676177@virtuozzo.com \
    --to=ktkhai@virtuozzo.com \
    --cc=akpm@linux-foundation.org \
    --cc=aryabinin@virtuozzo.com \
    --cc=chris@chris-wilson.co.uk \
    --cc=gregkh@linuxfoundation.org \
    --cc=guro@fb.com \
    --cc=hannes@cmpxchg.org \
    --cc=jbacik@fb.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux@roeck-us.net \
    --cc=lirongqing@baidu.com \
    --cc=longman@redhat.com \
    --cc=mgorman@techsingularity.net \
    --cc=mhocko@kernel.org \
    --cc=minchan@kernel.org \
    --cc=mka@chromium.org \
    --cc=penguin-kernel@I-love.SAKURA.ne.jp \
    --cc=pombredanne@nexb.com \
    --cc=sfr@canb.auug.org.au \
    --cc=shakeelb@google.com \
    --cc=stummala@codeaurora.org \
    --cc=tglx@linutronix.de \
    --cc=vdavydov.dev@gmail.com \
    --cc=viro@zeniv.linux.org.uk \
    --cc=willy@infradead.org \
    --cc=ying.huang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).