* [PATCH] batman-adv: Simplify 'batadv_v_ogm_aggr_list_free()'
@ 2019-10-31 7:42 Christophe JAILLET
2019-10-31 8:00 ` Sven Eckelmann
0 siblings, 1 reply; 2+ messages in thread
From: Christophe JAILLET @ 2019-10-31 7:42 UTC (permalink / raw)
To: davem, mareklindner, sw, a, sven
Cc: b.a.t.m.a.n, netdev, linux-kernel, kernel-janitors, Christophe JAILLET
Use 'skb_queue_purge()' instead of re-implementing it.
Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
BTW, I don't really see the need of 'aggr_list_lock'. I think that the code
could be refactored to drop 'aggr_list_lock' and use the already existing
'aggr_list.lock'.
This would require to use the lock-free __skb_... variants when working on
'aggr_list'.
As far as I understand, the use of 'aggr_list' and 'aggr_list_lock' is
limited to bat_v_ogm.c'. So the impact would be limited.
This would avoid a useless locking that never fails, so the performance
gain should be really limited.
So, I'm not sure this would be more readable and/or future proof, so
I just note it here to open the discussion.
If interested, I have a (compiled tested only) patch that implements this
change.
---
net/batman-adv/bat_v_ogm.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/net/batman-adv/bat_v_ogm.c b/net/batman-adv/bat_v_ogm.c
index dc4f7430cb5a..b841c83d9c3b 100644
--- a/net/batman-adv/bat_v_ogm.c
+++ b/net/batman-adv/bat_v_ogm.c
@@ -177,13 +177,9 @@ static bool batadv_v_ogm_queue_left(struct sk_buff *skb,
*/
static void batadv_v_ogm_aggr_list_free(struct batadv_hard_iface *hard_iface)
{
- struct sk_buff *skb;
-
lockdep_assert_held(&hard_iface->bat_v.aggr_list_lock);
- while ((skb = skb_dequeue(&hard_iface->bat_v.aggr_list)))
- kfree_skb(skb);
-
+ skb_queue_purge(&hard_iface->bat_v.aggr_list);
hard_iface->bat_v.aggr_len = 0;
}
--
2.20.1
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH] batman-adv: Simplify 'batadv_v_ogm_aggr_list_free()'
2019-10-31 7:42 [PATCH] batman-adv: Simplify 'batadv_v_ogm_aggr_list_free()' Christophe JAILLET
@ 2019-10-31 8:00 ` Sven Eckelmann
0 siblings, 0 replies; 2+ messages in thread
From: Sven Eckelmann @ 2019-10-31 8:00 UTC (permalink / raw)
To: Christophe JAILLET
Cc: davem, mareklindner, sw, a, b.a.t.m.a.n, netdev, linux-kernel,
kernel-janitors
[-- Attachment #1: Type: text/plain, Size: 1067 bytes --]
On Thursday, 31 October 2019 08:42:55 CET Christophe JAILLET wrote:
> Use 'skb_queue_purge()' instead of re-implementing it.
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
Consider this patch applied. I just have to leave now and thus I will only
apply after my return.
> ---
> BTW, I don't really see the need of 'aggr_list_lock'. I think that the code
> could be refactored to drop 'aggr_list_lock' and use the already existing
> 'aggr_list.lock'.
> This would require to use the lock-free __skb_... variants when working on
> 'aggr_list'.
>
> As far as I understand, the use of 'aggr_list' and 'aggr_list_lock' is
> limited to bat_v_ogm.c'. So the impact would be limited.
> This would avoid a useless locking that never fails, so the performance
> gain should be really limited.
>
> So, I'm not sure this would be more readable and/or future proof, so
> I just note it here to open the discussion.
>
> If interested, I have a (compiled tested only) patch that implements this
> change.
Yes, please send it over.
Kind regards,
Sven
[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 833 bytes --]
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2019-10-31 8:00 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-31 7:42 [PATCH] batman-adv: Simplify 'batadv_v_ogm_aggr_list_free()' Christophe JAILLET
2019-10-31 8:00 ` Sven Eckelmann
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).