linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* Fail mount root before USB device registered during boot
@ 2003-08-09 17:19 Phattanon Duangdara
  0 siblings, 0 replies; only message in thread
From: Phattanon Duangdara @ 2003-08-09 17:19 UTC (permalink / raw)
  To: linux-kernel

I'm using boot 2.6.0-test2 and 2.4.21 and last prepatch. I try to use
initrd to load needed USB and SCSI modules and also buit these modules
into kernel but booting from some USB devices doesn't work because USB
mass stroage device was successfully registered after kernel trying to
mount root duing boot.

I think some USB devices may have slow response of resetting device (I'm
using Cypress AT2 IDE-to-USB Bridge).

I don't know it happened only in SMP system or not. I'm using SMP on P4
with HyperThreading Enabled.

Is there any way to solve this problem. Curreny I have to add sleep to
script in initrd to wait for USB device active. Or is this a bug ?

[TLWG] Thai Linux Working Group http://linux.thai.net
-- ^ Gentoo! Fresh, Flavour, Ever ^ --

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2003-08-09 17:20 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2003-08-09 17:19 Fail mount root before USB device registered during boot Phattanon Duangdara

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).