linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Gustavo A. R. Silva" <gustavo@embeddedor.com>
To: Len Baker <len.baker@gmx.com>,
	Johannes Berg <johannes@sipsolutions.net>,
	"David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>
Cc: Kees Cook <keescook@chromium.org>,
	"Gustavo A. R. Silva" <gustavoars@kernel.org>,
	linux-wireless@vger.kernel.org, netdev@vger.kernel.org,
	linux-hardening@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] nl80211: prefer struct_size over open coded arithmetic
Date: Tue, 21 Sep 2021 13:51:58 -0500	[thread overview]
Message-ID: <47961463-5b2c-dd6f-0e98-ea95c13409fb@embeddedor.com> (raw)
In-Reply-To: <20210919114040.41522-1-len.baker@gmx.com>



On 9/19/21 06:40, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + count * size" in the kzalloc() functions.
> 
> Also, take the opportunity to refactor the memcpy() call to use the
> flex_array_size() helper.
> 
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Len Baker <len.baker@gmx.com>
> ---
>  net/wireless/nl80211.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/net/wireless/nl80211.c b/net/wireless/nl80211.c
> index bf7cd4752547..b56856349ced 100644
> --- a/net/wireless/nl80211.c
> +++ b/net/wireless/nl80211.c
> @@ -11766,9 +11766,10 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
>  	wdev_lock(wdev);
>  	if (n_thresholds) {
>  		struct cfg80211_cqm_config *cqm_config;
> +		size_t size = struct_size(cqm_config, rssi_thresholds,
> +					  n_thresholds);
> 
> -		cqm_config = kzalloc(sizeof(struct cfg80211_cqm_config) +
> -				     n_thresholds * sizeof(s32), GFP_KERNEL);
> +		cqm_config = kzalloc(size, GFP_KERNEL);

I don't think variable _size_ is needed here; this is just fine:

-               cqm_config = kzalloc(sizeof(struct cfg80211_cqm_config) +
-                                    n_thresholds * sizeof(s32), GFP_KERNEL);
+               cqm_config = kzalloc(struct_size(cqm_config, rssi_thresholds,
+                                                n_thresholds), GFP_KERNEL);

Thanks
--
Gustavo

>  		if (!cqm_config) {
>  			err = -ENOMEM;
>  			goto unlock;
> @@ -11777,7 +11778,8 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
>  		cqm_config->rssi_hyst = hysteresis;
>  		cqm_config->n_rssi_thresholds = n_thresholds;
>  		memcpy(cqm_config->rssi_thresholds, thresholds,
> -		       n_thresholds * sizeof(s32));
> +		       flex_array_size(cqm_config, rssi_thresholds,
> +				       n_thresholds));
> 
>  		wdev->cqm_config = cqm_config;
>  	}
> @@ -15081,9 +15083,7 @@ static int nl80211_set_sar_specs(struct sk_buff *skb, struct genl_info *info)
>  	if (specs > rdev->wiphy.sar_capa->num_freq_ranges)
>  		return -EINVAL;
> 
> -	sar_spec = kzalloc(sizeof(*sar_spec) +
> -			   specs * sizeof(struct cfg80211_sar_sub_specs),
> -			   GFP_KERNEL);
> +	sar_spec = kzalloc(struct_size(sar_spec, sub_specs, specs), GFP_KERNEL);
>  	if (!sar_spec)
>  		return -ENOMEM;
> 
> --
> 2.25.1
> 

      reply	other threads:[~2021-09-21 18:48 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-09-19 11:40 [PATCH] nl80211: prefer struct_size over open coded arithmetic Len Baker
2021-09-21 18:51 ` Gustavo A. R. Silva [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=47961463-5b2c-dd6f-0e98-ea95c13409fb@embeddedor.com \
    --to=gustavo@embeddedor.com \
    --cc=davem@davemloft.net \
    --cc=gustavoars@kernel.org \
    --cc=johannes@sipsolutions.net \
    --cc=keescook@chromium.org \
    --cc=kuba@kernel.org \
    --cc=len.baker@gmx.com \
    --cc=linux-hardening@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).