linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Markus Elfring <Markus.Elfring@web.de>
To: Joe Perches <joe@perches.com>,
	linux-s390@vger.kernel.org, kernel-janitors@vger.kernel.org
Cc: "Christian Bornträger" <borntraeger@de.ibm.com>,
	"Harald Freudenberger" <freude@linux.ibm.com>,
	"Heiko Carstens" <heiko.carstens@de.ibm.com>,
	"Ingo Franzki" <ifranzki@linux.ibm.com>,
	"Vasily Gorbik" <gor@linux.ibm.com>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: s390/pkey: Use memdup_user() rather than duplicating its implementation
Date: Wed, 6 Nov 2019 14:00:33 +0100	[thread overview]
Message-ID: <4fa0e106-2565-8610-1356-4adfba08c0a0@web.de> (raw)
In-Reply-To: <6137855bb4170c438c7436cbdb7dfd21639a8855.camel@perches.com>

>> Reuse existing functionality from memdup_user() instead of keeping
>> duplicate source code.
>>
>> Generated by: scripts/coccinelle/api/memdup_user.cocci
>> Fixes: f2bbc96e7cfad3891b7bf9bd3e566b9b7ab4553d ("s390/pkey: add CCA AES cipher key support")
>
> This doesn't fix anything

How would you categorise the proposed source code reduction and software reuse?


> and the Fixes: line is not appropriate.

Will the development opinions vary between contributors?


>> +	return !ukey || keylen < MINKEYBLOBSIZE || keylen > KEYBLOBBUFSIZE
>> +	       ? ERR_PTR(-EINVAL)
>> +	       : memdup_user(ukey, keylen);
>
> This is a very poor use of ternary ?: code.

The conditional operator is applied once more in the intended way,
isn't it?


> This is much more readable for humans.

Readability preferences can vary also for this code structure.


>> +	return uapqns && nr_apqns > 0
>> +	       ? memdup_user(uapqns, nr_apqns * sizeof(struct pkey_apqn))
>> +	       : NULL;
>
> And here you reverse the form of the earlier block.

I kept the previous condition specification.


> Please be consistent and use this style:

Would further developers like to get a more verbose variant for this
software transformation?

Regards,
Markus

  parent reply	other threads:[~2019-11-06 13:00 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-11-06 10:22 [PATCH] s390/pkey: Use memdup_user() rather than duplicating its implementation Markus Elfring
2019-11-06 10:38 ` Joe Perches
2019-11-06 13:00   ` Markus Elfring
2019-11-06 17:29     ` Joe Perches
2019-11-06 18:55       ` Markus Elfring
2019-11-06 19:01         ` Joe Perches
2019-11-06 19:18           ` Markus Elfring
2019-11-06 13:00   ` Markus Elfring [this message]
2019-11-06 18:30     ` Christian Borntraeger
2019-11-07  6:48       ` Dan Carpenter
2019-11-07  8:07         ` Christian Borntraeger
2019-11-07 10:06   ` [PATCH v2] " Markus Elfring
2019-11-07 12:44     ` Christian Borntraeger
2019-11-07 13:45       ` Markus Elfring
2019-11-07 13:54         ` Christian Borntraeger
2019-11-07 14:27           ` Markus Elfring
2019-11-08 11:32             ` Christian Borntraeger
2019-11-08 17:14               ` [PATCH v3] " Markus Elfring
2019-11-11  7:54                 ` Christian Borntraeger
2019-11-11  8:11                   ` [v3] " Markus Elfring
2019-11-11  8:27                     ` Christian Borntraeger
2019-11-11  8:42                       ` Markus Elfring
2019-11-11  8:56                         ` Christian Borntraeger
2019-11-11  9:06                           ` Markus Elfring
2019-11-11  9:08                             ` Christian Borntraeger
2019-11-11  9:17                               ` Markus Elfring
2019-11-11  9:18                                 ` Christian Borntraeger
2019-11-11  9:26                                   ` Markus Elfring
2019-11-11 14:45                   ` [PATCH v4] s390/pkey: Fix memory leak in error case by using memdup_user() rather than open coding Markus Elfring
2019-11-11 16:40                     ` Christian Borntraeger
2019-11-13 17:09                       ` [v4] " Markus Elfring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4fa0e106-2565-8610-1356-4adfba08c0a0@web.de \
    --to=markus.elfring@web.de \
    --cc=borntraeger@de.ibm.com \
    --cc=freude@linux.ibm.com \
    --cc=gor@linux.ibm.com \
    --cc=heiko.carstens@de.ibm.com \
    --cc=ifranzki@linux.ibm.com \
    --cc=joe@perches.com \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-s390@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).