linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Bagas Sanjaya <bagasdotme@gmail.com>
To: Peter Huewe <peterhuewe@gmx.de>,
	Jarkko Sakkinen <jarkko@kernel.org>,
	Jason Gunthorpe <jgg@ziepe.ca>,
	Luis Chamberlain <mcgrof@kernel.org>,
	Russ Weight <russell.h.weight@intel.com>,
	Marcus Seyfarth <m.seyfarth@gmail.com>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Linux Regressions <regressions@lists.linux.dev>,
	Linux Integrity <linux-integrity@vger.kernel.org>
Subject: Fwd: Slow boot and shutdown/reboot problems with 6.5.0+
Date: Thu, 7 Sep 2023 20:25:04 +0700	[thread overview]
Message-ID: <5011708f-b0ae-2853-0f87-a3b59845a2cc@gmail.com> (raw)

Hi,

I notice a regression report on Bugzilla [1]. Quoting from it:

> I've observed a slow boot and shutdown/reboot problems that have been verified on the stock Arch 6.5.1, CachyOS 6.5.0-2 and a custom-compiled 6.5.1 Kernel. I originally had seen a RCU-related trace which I thought to be the cause for these problems as well and reported it in https://bugzilla.kernel.org/show_bug.cgi?id=217864. However that specific trace turned out to be caused by an old patch that I carried around with me since 2022.
> 
> systemd-analyze with my custom compiled 6.5.1 shows a suspiciously long firmware time:
> Startup finished in 2min 42.000s (firmware) + 4.201s (loader) + 6.895s (kernel) + 1.541s (userspace) = 2min 54.640s  
> graphical.target reached after 1.539s in userspace.
> 
> For comparison, 6.4.14 starts in 16 seconds and doesn't even show a firmware section.
> 
> System:
>   Host: klx99 Kernel: 6.5.1-3.1-cachyos-lto arch: x86_64 bits: 64
>     Desktop: KDE Plasma v: 5.27.7 Distro: CachyOS
> Machine:
>   Mobo: Lenovo model: X99-TF Gaming v: G368J V1.1, NALEX
>     serial: <superuser required> UEFI: American Megatrends v: CX99DE26
>     date: 10/10/2020
> CPU:
>   Info: 18-core model: Intel Xeon E5-2696 v3 bits: 64 type: MT MCP cache:
>     L2: 4.5 MiB
> Graphics:
>   Device-1: AMD Navi 21 [Radeon RX 6950 XT] driver: amdgpu v: kernel
>   Display: x11 server: X.Org v: 21.1.99 with: Xwayland v: 23.2.0 driver: X:
>     loaded: amdgpu unloaded: modesetting dri: radeonsi gpu: amdgpu
>     resolution: 2560x1440~165Hz
>   API: OpenGL v: 4.6 Mesa 23.3.0-devel (git-8a32614a18) renderer: AMD
>     Radeon RX 6950 XT (navi21 LLVM 16.0.6 DRM 3.54 6.5.1-3.1-cachyos-lto)

See Bugzilla for the full thread.

FYI, it seems like this regression is related to systemd boot loop
reported earlier [2].

To Marcus: On Bugzilla, Artem had asked you to bisect. Do you have
any conclusion on it?

Anyway, I'm adding this regression to be tracked by regzbot:

#regzbot introduced: v6.4..v6.5 https://bugzilla.kernel.org/show_bug.cgi?id=217874
#regzbot title: slow boot possibly due to firmware (TPM?) issues

Thanks.

[1]: https://bugzilla.kernel.org/show_bug.cgi?id=217874
[2]: https://lore.kernel.org/all/028a21df-4397-80aa-c2a5-7c754560f595@gmail.com/

-- 
An old man doll... just what I always wanted! - Clara

             reply	other threads:[~2023-09-07 15:31 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-09-07 13:25 Bagas Sanjaya [this message]
     [not found] ` <CA+FbhJO8b5V_So2mMPu1ApKXTxk0ieWvNMa=HBTYTWDXLEA-ew@mail.gmail.com>
2023-09-08  1:38   ` Slow boot and shutdown/reboot problems with 6.5.0+ Bagas Sanjaya
2023-09-11 14:00   ` Bagas Sanjaya
2023-09-11 14:13     ` Thorsten Leemhuis

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5011708f-b0ae-2853-0f87-a3b59845a2cc@gmail.com \
    --to=bagasdotme@gmail.com \
    --cc=jarkko@kernel.org \
    --cc=jgg@ziepe.ca \
    --cc=linux-integrity@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=m.seyfarth@gmail.com \
    --cc=mcgrof@kernel.org \
    --cc=peterhuewe@gmx.de \
    --cc=regressions@lists.linux.dev \
    --cc=russell.h.weight@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).