linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Michal Simek <monstr@monstr.eu>
To: Rob Herring <robherring2@gmail.com>
Cc: Grant Likely <grant.likely@linaro.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>
Subject: Re: [PATCH v2 18/21] powerpc: use libfdt accessors for header data
Date: Wed, 23 Apr 2014 16:21:26 +0200	[thread overview]
Message-ID: <5357CC66.5080802@monstr.eu> (raw)
In-Reply-To: <CAL_JsqKg8oAd+JmmhERa3Xb1dD9CPz1_cVM3mb=ypWhxkZJHtQ@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 1917 bytes --]

On 04/23/2014 04:05 PM, Rob Herring wrote:
> On Wed, Apr 23, 2014 at 8:48 AM, Michal Simek <monstr@monstr.eu> wrote:
>> On 04/23/2014 03:18 AM, Rob Herring wrote:
>>> From: Rob Herring <robh@kernel.org>
>>>
>>> With libfdt support, we can take advantage of helper accessors in libfdt
>>> for accessing the FDT header data. This makes the code more readable and
>>> makes the FDT blob structure more opaque to the kernel. This also
>>> prepares for removing struct boot_param_header completely.
> 
> [...]
> 
>>> @@ -117,14 +118,14 @@ static void __init move_device_tree(void)
>>>       DBG("-> move_device_tree\n");
>>>
>>>       start = __pa(initial_boot_params);
>>> -     size = be32_to_cpu(initial_boot_params->totalsize);
>>> +     size = fdt_totalsize(initial_boot_params);
>>
>> In 19/21 you use your newly introduced of_get_flat_dt_size()
>> that's why I expect you will use it here too.
>> size = of_get_flat_dt_size();
>>
>> The same is for 14/21 where you can use this new function too.
>> It means moving 14/21 to the end and using this new function
>> makes more sense.
> 
> Really, I would prefer to just use libfdt accessors directly rather
> than have wrappers, but including libfdt.h is not the cleanest
> solution. Since x86 just needed this one function, I added a wrapper.
> Since PPC needs other header fields I prefer to use the libfdt
> accessors directly for all fields. The same goes for drivers/of/fdt.c.

Ok. I see your point but maybe will be good to reflect that it is
there just for x86 case and none else should use it.

Thanks,
Michal


-- 
Michal Simek, Ing. (M.Eng), OpenPGP -> KeyID: FE3D1F91
w: www.monstr.eu p: +42-0-721842854
Maintainer of Linux kernel - Microblaze cpu - http://www.monstr.eu/fdt/
Maintainer of Linux kernel - Xilinx Zynq ARM architecture
Microblaze U-BOOT custodian and responsible for u-boot arm zynq platform



[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 263 bytes --]

  reply	other threads:[~2014-04-23 14:21 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-04-23  1:18 [PATCH v2 00/21] FDT clean-ups and libfdt support Rob Herring
2014-04-23  1:18 ` [PATCH v2 01/21] mips: octeon: convert to use unflatten_and_copy_device_tree Rob Herring
2014-04-23  1:18 ` [PATCH v2 02/21] mips: lantiq: copy built-in DTB out of init section Rob Herring
2014-04-23  1:18 ` [PATCH v2 03/21] mips: xlp: " Rob Herring
2014-04-23  1:18 ` [PATCH v2 04/21] mips: ralink: convert to use unflatten_and_copy_device_tree Rob Herring
2014-04-23  1:18 ` [PATCH v2 05/21] ARM: dt: use default early_init_dt_alloc_memory_arch Rob Herring
2014-04-23  1:18 ` [PATCH v2 06/21] c6x: convert fdt pointers to opaque pointers Rob Herring
2014-04-24 14:21   ` Mark Salter
2014-04-23  1:18 ` [PATCH v2 07/21] mips: " Rob Herring
2014-04-23  1:18 ` [PATCH v2 08/21] of/fdt: consolidate built-in dtb section variables Rob Herring
2014-04-23  1:18 ` [PATCH v2 09/21] of/fdt: remove some unneeded includes Rob Herring
2014-04-23  1:18 ` [PATCH v2 10/21] of/fdt: remove unused of_scan_flat_dt_by_path Rob Herring
2014-04-23  1:18 ` [PATCH v2 11/21] of/fdt: update of_get_flat_dt_prop in prep for libfdt Rob Herring
2014-04-23  1:18 ` [PATCH v2 12/21] of/fdt: Convert FDT functions to use libfdt Rob Herring
2014-04-23  1:18 ` [PATCH v2 13/21] of/fdt: use libfdt accessors for header data Rob Herring
2014-04-23  1:18 ` [PATCH v2 14/21] of/fdt: create common debugfs Rob Herring
2014-04-23 13:52   ` Michal Simek
2014-04-23  1:18 ` [PATCH v2 15/21] of/fdt: move memreserve and dtb memory reservations into core Rob Herring
2014-05-01 16:27   ` Catalin Marinas
2014-04-23  1:18 ` [PATCH v2 16/21] of/fdt: fix phys_addr_t related print size warnings Rob Herring
2014-04-23  1:18 ` [PATCH v2 17/21] of/fdt: introduce of_get_flat_dt_size Rob Herring
2014-04-23 13:45   ` Michal Simek
2014-04-23  1:18 ` [PATCH v2 18/21] powerpc: use libfdt accessors for header data Rob Herring
2014-04-23 13:48   ` Michal Simek
2014-04-23 14:05     ` Rob Herring
2014-04-23 14:21       ` Michal Simek [this message]
2014-04-23  1:18 ` [PATCH v2 19/21] x86: use FDT accessors for FDT blob " Rob Herring
2014-04-23  1:18 ` [PATCH v2 20/21] of/fdt: convert initial_boot_params to opaque pointer Rob Herring
2014-04-23  1:18 ` [PATCH v2 21/21] of: push struct boot_param_header and defines into powerpc Rob Herring
2014-04-28  1:37   ` Benjamin Herrenschmidt
2014-04-23 14:22 ` [PATCH v2 00/21] FDT clean-ups and libfdt support Michal Simek
2014-04-23 21:04 ` Max Filippov
2014-04-29 14:00 ` Grant Likely
2014-04-30  0:33 ` Stephen N Chivers

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5357CC66.5080802@monstr.eu \
    --to=monstr@monstr.eu \
    --cc=benh@kernel.crashing.org \
    --cc=devicetree@vger.kernel.org \
    --cc=grant.likely@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=paulus@samba.org \
    --cc=robherring2@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).