linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Guenter Roeck <linux@roeck-us.net>
To: Pawel Moll <pawel.moll@arm.com>,
	Grant Likely <grant.likely@linaro.org>,
	Rob Herring <robh+dt@kernel.org>,
	Samuel Ortiz <sameo@linux.intel.com>,
	Lee Jones <lee.jones@linaro.org>, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Russell King <linux@arm.linux.org.uk>
Cc: linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, arm@kernel.org,
	Jean Delvare <jdelvare@suse.de>,
	lm-sensors@lm-sensors.org
Subject: Re: [PATCH 10/10] hwmon: vexpress: Use devm helper for hwmon device registration
Date: Mon, 28 Apr 2014 15:59:21 -0700	[thread overview]
Message-ID: <535EDD49.8050107@roeck-us.net> (raw)
In-Reply-To: <1398707877-22596-11-git-send-email-pawel.moll@arm.com>

On 04/28/2014 10:57 AM, Pawel Moll wrote:
> Use devm_hwmon_device_register_with_groups instead of
> the old-style manual attributes and hwmon device registration.
>
> Also, unwind the attribute group macros for better code
> readability.
>
> Cc: Jean Delvare <jdelvare@suse.de>
> Cc: Guenter Roeck <linux@roeck-us.net>
> Cc: lm-sensors@lm-sensors.org
> Signed-off-by: Pawel Moll <pawel.moll@arm.com>
> ---
>   drivers/hwmon/vexpress.c | 91 ++++++++++++++++--------------------------------
>   1 file changed, 30 insertions(+), 61 deletions(-)
>
> diff --git a/drivers/hwmon/vexpress.c b/drivers/hwmon/vexpress.c
> index d853332..ed6bf0e 100644
> --- a/drivers/hwmon/vexpress.c
> +++ b/drivers/hwmon/vexpress.c
> @@ -27,17 +27,8 @@
>   struct vexpress_hwmon_data {
>   	struct device *hwmon_dev;
>   	struct regmap *reg;
> -	const char *name;
>   };
>
> -static ssize_t vexpress_hwmon_name_show(struct device *dev,
> -		struct device_attribute *dev_attr, char *buffer)
> -{
> -	struct vexpress_hwmon_data *data = dev_get_drvdata(dev);
> -
> -	return sprintf(buffer, "%s\n", data->name);
> -}
> -
>   static ssize_t vexpress_hwmon_label_show(struct device *dev,
>   		struct device_attribute *dev_attr, char *buffer)
>   {
> @@ -95,16 +86,6 @@ static umode_t vexpress_hwmon_attr_is_visible(struct kobject *kobj,
>   	return attr->mode;
>   }
>
> -static DEVICE_ATTR(name, S_IRUGO, vexpress_hwmon_name_show, NULL);
> -
> -#define VEXPRESS_HWMON_ATTRS(_name, _label_attr, _input_attr)	\
> -struct attribute *vexpress_hwmon_attrs_##_name[] = {		\
> -	&dev_attr_name.attr,					\
> -	&dev_attr_##_label_attr.attr,				\
> -	&sensor_dev_attr_##_input_attr.dev_attr.attr,		\
> -	NULL							\
> -}
> -
>   struct vexpress_hwmon_type {
>   	const char *name;
>   	const struct attribute_group **attr_groups;
> @@ -114,10 +95,13 @@ struct vexpress_hwmon_type {
>   static DEVICE_ATTR(in1_label, S_IRUGO, vexpress_hwmon_label_show, NULL);
>   static SENSOR_DEVICE_ATTR(in1_input, S_IRUGO, vexpress_hwmon_u32_show,
>   		NULL, 1000);
> -static VEXPRESS_HWMON_ATTRS(volt, in1_label, in1_input);
>   static struct attribute_group vexpress_hwmon_group_volt = {
>   	.is_visible = vexpress_hwmon_attr_is_visible,
> -	.attrs = vexpress_hwmon_attrs_volt,
> +	.attrs = (struct attribute *[]) {

Is this typecast necessary ?

> +		&dev_attr_in1_label.attr,
> +		&sensor_dev_attr_in1_input.dev_attr.attr,
> +		NULL
> +	},
>   };
>   static struct vexpress_hwmon_type vexpress_hwmon_volt = {
>   	.name = "vexpress_volt",
> @@ -131,10 +115,13 @@ static struct vexpress_hwmon_type vexpress_hwmon_volt = {
>   static DEVICE_ATTR(curr1_label, S_IRUGO, vexpress_hwmon_label_show, NULL);
>   static SENSOR_DEVICE_ATTR(curr1_input, S_IRUGO, vexpress_hwmon_u32_show,
>   		NULL, 1000);
> -static VEXPRESS_HWMON_ATTRS(amp, curr1_label, curr1_input);
>   static struct attribute_group vexpress_hwmon_group_amp = {
>   	.is_visible = vexpress_hwmon_attr_is_visible,
> -	.attrs = vexpress_hwmon_attrs_amp,
> +	.attrs = (struct attribute *[]) {
> +		&dev_attr_curr1_label.attr,
> +		&sensor_dev_attr_curr1_input.dev_attr.attr,
> +		NULL
> +	},
>   };
>   static struct vexpress_hwmon_type vexpress_hwmon_amp = {
>   	.name = "vexpress_amp",
> @@ -147,10 +134,13 @@ static struct vexpress_hwmon_type vexpress_hwmon_amp = {
>   static DEVICE_ATTR(temp1_label, S_IRUGO, vexpress_hwmon_label_show, NULL);
>   static SENSOR_DEVICE_ATTR(temp1_input, S_IRUGO, vexpress_hwmon_u32_show,
>   		NULL, 1000);
> -static VEXPRESS_HWMON_ATTRS(temp, temp1_label, temp1_input);
>   static struct attribute_group vexpress_hwmon_group_temp = {
>   	.is_visible = vexpress_hwmon_attr_is_visible,
> -	.attrs = vexpress_hwmon_attrs_temp,
> +	.attrs = (struct attribute *[]) {
> +		&dev_attr_temp1_label.attr,
> +		&sensor_dev_attr_temp1_input.dev_attr.attr,
> +		NULL
> +	},
>   };
>   static struct vexpress_hwmon_type vexpress_hwmon_temp = {
>   	.name = "vexpress_temp",
> @@ -163,10 +153,13 @@ static struct vexpress_hwmon_type vexpress_hwmon_temp = {
>   static DEVICE_ATTR(power1_label, S_IRUGO, vexpress_hwmon_label_show, NULL);
>   static SENSOR_DEVICE_ATTR(power1_input, S_IRUGO, vexpress_hwmon_u32_show,
>   		NULL, 1);
> -static VEXPRESS_HWMON_ATTRS(power, power1_label, power1_input);
>   static struct attribute_group vexpress_hwmon_group_power = {
>   	.is_visible = vexpress_hwmon_attr_is_visible,
> -	.attrs = vexpress_hwmon_attrs_power,
> +	.attrs = (struct attribute *[]) {
> +		&dev_attr_power1_label.attr,
> +		&sensor_dev_attr_power1_input.dev_attr.attr,
> +		NULL
> +	},
>   };
>   static struct vexpress_hwmon_type vexpress_hwmon_power = {
>   	.name = "vexpress_power",
> @@ -179,10 +172,13 @@ static struct vexpress_hwmon_type vexpress_hwmon_power = {
>   static DEVICE_ATTR(energy1_label, S_IRUGO, vexpress_hwmon_label_show, NULL);
>   static SENSOR_DEVICE_ATTR(energy1_input, S_IRUGO, vexpress_hwmon_u64_show,
>   		NULL, 1);
> -static VEXPRESS_HWMON_ATTRS(energy, energy1_label, energy1_input);
>   static struct attribute_group vexpress_hwmon_group_energy = {
>   	.is_visible = vexpress_hwmon_attr_is_visible,
> -	.attrs = vexpress_hwmon_attrs_energy,
> +	.attrs = (struct attribute *[]) {
> +		&dev_attr_energy1_label.attr,
> +		&sensor_dev_attr_energy1_input.dev_attr.attr,
> +		NULL
> +	},
>   };
>   static struct vexpress_hwmon_type vexpress_hwmon_energy = {
>   	.name = "vexpress_energy",
> @@ -218,7 +214,6 @@ MODULE_DEVICE_TABLE(of, vexpress_hwmon_of_match);
>
>   static int vexpress_hwmon_probe(struct platform_device *pdev)
>   {
> -	int err;
>   	const struct of_device_id *match;
>   	struct vexpress_hwmon_data *data;
>   	const struct vexpress_hwmon_type *type;
> @@ -232,45 +227,19 @@ static int vexpress_hwmon_probe(struct platform_device *pdev)
>   	if (!match)
>   		return -ENODEV;
>   	type = match->data;
> -	data->name = type->name;
>
>   	data->reg = devm_regmap_init_vexpress_config(&pdev->dev);
> -	if (!data->reg)
> -		return -ENODEV;
> -
> -	err = sysfs_create_groups(&pdev->dev.kobj, type->attr_groups);
> -	if (err)
> -		goto error;
> -
> -	data->hwmon_dev = hwmon_device_register(&pdev->dev);
> -	if (IS_ERR(data->hwmon_dev)) {
> -		err = PTR_ERR(data->hwmon_dev);
> -		goto error;
> -	}
> +	if (IS_ERR(data->reg))
> +		return PTR_ERR(data->reg);

Did the API for devm_regmap_init_vexpress_config change ?
If so, it might make sense to separate this out into a separate patch,
together with the API change (it is a logically different change).

Otherwise looks good.

One question - I seem to be unable to apply the patch. What is your baseline branch / repository ?

Thanks,
Guenter


  reply	other threads:[~2014-04-28 22:59 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-04-28 17:57 [PATCH 00/10] Versatile Express changes for 3.16 Pawel Moll
2014-04-28 17:57 ` [PATCH 01/10] of: Keep track of populated platform devices Pawel Moll
2014-04-28 18:02   ` Rob Herring
2014-04-29 12:56     ` Grant Likely
2014-04-30 11:48       ` Pawel Moll
2014-04-28 17:57 ` [PATCH 02/10] mfd: vexpress: Convert custom func API to regmap Pawel Moll
2014-04-29 22:21   ` Mark Brown
2014-04-30 13:58   ` Lee Jones
2014-04-30 14:13     ` Pawel Moll
2014-04-30 14:29       ` Lee Jones
2014-04-30 14:38         ` Pawel Moll
2014-04-30 16:01   ` [PATCH v2] " Pawel Moll
2014-04-30 17:05     ` Guenter Roeck
2014-05-01 18:58     ` Mike Turquette
2014-04-28 17:57 ` [PATCH 03/10] mfd: syscon: Add platform data with a regmap config name Pawel Moll
2014-04-28 17:57 ` [PATCH 04/10] mfd: vexpress: Define the device as MFD cells Pawel Moll
2014-05-09 11:24   ` Lee Jones
2014-04-28 17:57 ` [PATCH 05/10] clk: versatile: Split config options for sp810 and vexpress_osc Pawel Moll
2014-05-01 18:55   ` Mike Turquette
2014-04-28 17:57 ` [PATCH 06/10] clocksource: Sched clock source for Versatile Express Pawel Moll
2014-04-28 17:57 ` [PATCH 07/10] ARM: vexpress: remove redundant vexpress_dt_cpus_num to get cpu count Pawel Moll
2014-04-28 17:57 ` [PATCH 08/10] ARM: vexpress: Simplify SMP operations for DT-powered system Pawel Moll
2014-04-28 17:57 ` [PATCH 09/10] ARM: vexpress: move HBI check to sysreg driver Pawel Moll
2014-04-30 14:02   ` Lee Jones
2014-04-28 17:57 ` [PATCH 10/10] hwmon: vexpress: Use devm helper for hwmon device registration Pawel Moll
2014-04-28 22:59   ` Guenter Roeck [this message]
2014-04-30 15:16     ` Pawel Moll
2014-04-30 15:27       ` Guenter Roeck
2014-04-30 15:33         ` Pawel Moll

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=535EDD49.8050107@roeck-us.net \
    --to=linux@roeck-us.net \
    --cc=arm@kernel.org \
    --cc=arnd@arndb.de \
    --cc=grant.likely@linaro.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jdelvare@suse.de \
    --cc=lee.jones@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@arm.linux.org.uk \
    --cc=lm-sensors@lm-sensors.org \
    --cc=pawel.moll@arm.com \
    --cc=robh+dt@kernel.org \
    --cc=sameo@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).